Iptables not blocking ip

Hello. Currently i'm trying to block access to my router (192.168.0.1), switch (192.168.0.100) from everyone except one IP. This is my current configuration in web interface under traffic rules https://imgur.com/eJyKOJb https://imgur.com/CivxnfA for router, but if i add the same for the switch or any other device it is not working. Other strange behavior is configured that way all my smart TV with are connected via LAN cable is accessible via ping but they cannot access the internet. I lost almost a day playing around with different settings even add them in custom rules but still not working. Did my configurations are wrong and how i can make it work?

This is because you can only firewall using a router when the traffic must pass through it (FORWARD) or enter it (INPUT).

Since LAN does not need a router to connect to another LAN device, this doesn't work. It will only work to block access to the router and Internet. You will need to make the block or access rule on the switch itself.

Likely because you blocked DHCP and/or DNS requests.

Thank you, blocking the lan i understand now but i guess it should not be accessible from wi-fi since router has wi-fi and it is the entry point switch is connected to the router. If i blocked DHCP and/or DNS i assume other devices will not be able to connect not only TV's. Currently i have only settings from the pictures and it is acting like what i mention above.

Why are not blocking only http/https and ssh to your router except for your pc?
With your setting, no device except your single pc could use your router as gateway, dhcp, dns and probably more services...

The traffic from wifi does also not pass the rule because there is by default no routing between bridged lan and wifi... This is only layer 2 traffic and you couldn't block that with iptables on layer 3.