IPQ9574/AP-AL02-C4 no connection with internet

Good afternoon,

I was assigned an OpenWrt project, but I have limited experience with the subject. I’m currently familiarizing myself with the documentation on the website, and I have a question. I’m unable to access the internet with my board, as shown in the photos. I configured the WAN port interface as a DHCP client, but it still doesn’t ping or obtain an IP.

I’ve attached some photos of the interface configuration for reference.

Additionally, here are the hardware specifications I’m working with:

Chip Manufacturer Primary Application
IPQ9570 Qualcomm Technologies, Inc. Wi-Fi 6E routers and access points
QCN9274 Qualcomm Technologies, Inc. Wi-Fi 6E access points
AQR8081 Marvell Technology Group 400 Gbps switches and routers
ARQ113C Microchip Technology Inc. Industrial Ethernet controllers

Any help or guidance would be greatly appreciated!

What we can see from your screenshot is that you don't have an address on the wan interface. But it is not necessarily clear why...

  • What is the upstream network (is it a home/lab network, or a direct connection to an ISP)?
  • Does the upstream network use DHCP for its connection method (vs PPPoE or static IP)?
  • Does the upstream network require a VLAN?
  • Does the physical link on the wan port (eth0) show that it is active?

In addition to the above answers, let's take a look at your complete config to understand more about the device in question:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
3 Likes

Judging from MAC address you can find many yuncore devices supported.

  • It’s a lab network, but we are already setting up a separate network to configure the ISP.
  • The connection method is a DHCP network.
  • The network does not require a VLAN for use.
  • Where can I check if the eth0 interface is active or not?
root@OpenWrt:~# ubus call system board
{
        "kernel": "5.4.213",
        "hostname": "OpenWrt",
        "system": "ARMv7 Processor rev 0 (v7l)",
        "model": "Qualcomm Technologies, Inc. IPQ9574/AP-AL02-C4",
        "board_name": "qcom,ipq9574-ap-al02-c4",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05-SNAPSHOT",
                "revision": "r0+24213-a132865f62cc",
                "target": "ipq95xx/ipq95xx_32",
                "description": "OpenWrt 23.05-SNAPSHOT r0+24213-a132865f62cc"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7f:546e:b5ba::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'eth1'
        list ports 'eth2'
        list ports 'eth3'
        list ports 'eth4'
        list ports 'eth5'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option multicast_querier '0'
        option igmp_snooping '0'
        option ieee1905managed '1'
        option force_link '1'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth0'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'wifi0'
        option type 'qcawificfg80211'
        option channel 'auto'
        option hwmode '11a'
        option country 'BR'

config wifi-iface 'wifinet0'
        option device 'wifi0'
        option network 'lan'
        option mode 'sta'
        option ssid 'IPQ95XX-1'
        option encryption 'none'
        option disablecoext '1'
        option cwmenable '0'
        option key '66666666'
        option sae '1'

config wifi-device 'wifi1'
        option type 'qcawificfg80211'
        option channel '64'
        option hwmode '11a'

config wifi-iface 'wifinet1'
        option device 'wifi1'
        option network 'lan'
        option mode 'ap'
        option ssid 'IPQ95XX-2'
        option encryption 'none'
        option key '66666666'
        option sae '1'

config wifi-device 'wifi2'
        option type 'qcawificfg80211'
        option channel '100'
        option hwmode '11bea'
        option htmode 'HT160'
        option disabled '1'

config wifi-iface 'wifinet2'
        option device 'wifi2'
        option network 'lan'
        option mode 'ap'
        option ssid 'IPQ95XX-3'
        option encryption 'ccmp'
        option key '66666666'
        option sae '1'
        option disabled '1'

config qcawifi 'qcawifi'
        option non_mlo_11be_ap_operation_enable '1'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option force '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option disabled '0'
        option synflood_protect '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include 'qcanssecm'
        option type 'script'
        option path '/etc/firewall.d/qca-nss-ecm'

config forwarding
        option src 'wan'
        option dest 'lan'

root@OpenWrt:~# client_loop: send disconnect: Connection reset
PS C:\Users\Carlo>
type or paste code here

eth0 assignment doesn't look right.

but it's also unsupported.


It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

1 Like

You have to remove eth0 from the unrelated bridge. (and try to port official OpenWrt to your device?)

Good morning, and thank you very much for the guidance on the previous issues!

This board is a version that currently does not have support for OpenWRT. I installed a generic version to see if I could make it work.

Since it is not a configuration issue, I tried creating a new image using the Make development environment. In it, there were configuration options for the board model. The problem is that after creating the image, I get this error:

you're not going from OpenWRT nor to OpenWRT, we have no idea ...

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.