IPQ807X NSS Build

Hi @Merwenus

Yes, you can sysupgrade from official snapshot to my snapshot, even keeping the configuration.

Regards, Agustin

Sorry, I thought the code was older

Hi boys,

Again, I am redo the repos over the latest commit from OpenWRT.

Changelog:

Next Goal:

  • Update to kernel 6.1, it's already released for ipq807x by @robimarko
  • Rebased the code of NSS to kernel 6.1

Sources:

BUILDED: https://github.com/AgustinLorenzo/openwrt/releases/tag/ipq807x-2023-06-07-0157

Regards, Agustin

4 Likes

Have you actually tried SSDK 12.4?
Cause it was completely messing up the clocks and nothing worked.

1 Like

Just updated to latest build by @AgustinLorenzo, I got a suspicious SSL connection error soon after... It seems to happen rarely, but still happens

Hi @robimarko

At the moment I am not noticing anything strange (except for the SSL problems, which we have been discussing for several days), but if you indicate how I can check it, I will look at it and tell you.

Regards, Agustín

So, wired ports work with SSDK 12.4?

Pozdrav Robert :slight_smile:
I'm using build from Agustin as I have1 Gbps connection and official release is giving me max 600 Mbps on wired port. I did not notice any problems (again, except SSL) in newest build - using wireless and wired.
Regards, Goran

1 Like

Hi @robimarko

Yes, wired is working, you can try it yourself: https://github.com/AgustinLorenzo/openwrt/releases/tag/ipq807x-2023-06-07-0157

Regards, Agustin

Hi @cobric

WiFi is not accelerated by NSS.....

For ssl problems, you can try the following:

uci set ecm.@general[0].disable_offloads=1
uci set ecm.@general[0].disable_flow_control=1
uci set ecm.@general[0].disable_interrupt_moderation=1
uci commit
Restart your router

One of those 3 things is what causes the problem, so if you can try it and tell us.

Regards, Agustin

Hi Agustin,
I will try those commands, thx for the tip.
Regards, Goran

Not sure if this is the right place for this post, but...

I'm fighting with the TP-Link EAP660 HD, which will boot the WAX218 image (NSS or non-NSS) via TFTP without any hiccups. The wired network connection isn't actually providing connectivity in either case. The connection is being reported accurately, the PoE is working, but something is wonky. I'm not sure what is going on with the NSS side of things and wanted to know if there might be something there that I'm missing?

Here's the unplug / plug in event. If there's something else I can track down that might help, let me know.

[ 1169.440375] nss-dp 3a007000.dp6-syn lan: PHY Link is down
[ 1169.457004] br-lan: port 1(lan) entered disabled state
------
[ 1173.536208] nss-dp 3a007000.dp6-syn lan: PHY Link up speed: 1000
[ 1173.536295] br-lan: port 1(lan) entered blocking state
[ 1173.541303] br-lan: port 1(lan) entered forwarding state

thanks,

jmspswny

Hi
should i turn software flow offloading on with your build?

Hi @hingbong

You can try it to see if you experience any performance improvement on the WiFi network since the wired one is accelerated by NSS.

Regards, Agustin

Hi boys,

Again, I am redo the repos over the latest commit from OpenWRT.

Changelog:

Next Goal:

  • Update to kernel 6.1 and rebased the code of NSS to kernel 6.1

Sources:

BUILDED: https://github.com/AgustinLorenzo/openwrt/releases/tag/ipq807x-2023-06-12-2358

Regards, Agustin

5 Likes

FYI

@neg3ntropy @cobric @olci

Thanks for Your work, it works nice on my dynalink, when i got back to my home next week i can play with new image.

Thx! Installing now.

Updated to latest build, thanks @AgustinLorenzo, I still saw the SSL issue. It might be a little better, I don't know for sure: I am not testing scientifically enough. I don't fully understand what is going on, is there a issue tracker for that, somewhere?

all good i got no ssl error too
but it feels more stable without packet steering and software offloading i disabled those
also my isp requires 1492 for mtu size this may be what me apart from the rest of people i don't know
not many people sets their mtu to 1492 i suppose