IPQ807X NSS Build

Has anyone tried the latest build? I am getting proxy errors and DHCP is not working.

Did you try here: https://github.com/AgustinLorenzo/nss-packages

No, it does not.

Have you tried dimfish's tc-* packages did it work?

Hi @juliank

This is a known issue, put IP in your interface wired or wireless:, enter with SSH client to and put this:

uci set dhcp.lan.ignore=0
uci commit
service dnsmasq restart

and the issue with the DHCP is fixed

I don't know what is causing DHCP to be deactivated by default, even appearing in LUCI as active but if you look at UCI it appears deactivated

Regards, Agustin

1 Like

No, I have not tried it because of reasons.

Hi boys,

I am releasing a new version of the build based in the code of @bitthief and some tweaks.


  • Updated kernel and NSS code to 6.1.54
  • Updated ath11k-firmware to 1890



BUILDED: https://github.com/AgustinLorenzo/openwrt/releases/tag/ipq807x-2023-09-23-1933

Regards, Agustin


I tried dimfish's nss tc-* traffic shaping packages with Lorenzo build but didn't work. Did anyone get it to work?

For those who want to give it a try, simply download one of them packages, upload directly via luci software page, put these on startup box, and reboot.

insmod nss-ifb nss_dev_name=wan
ip link set up nssifb

# Shape ingress traffic to 500 Mbit with chained NSSFQ_CODEL
tc qdisc add dev nssifb root handle 1: nsstbl rate 500Mbit burst 1Mb
tc qdisc add dev nssifb parent 1: handle 10: nssfq_codel limit 10240 flows 1024 quantum 1514 target 5ms interval 100ms set_default

# Shape egress traffic to 500 Mbit with chained NSSFQ_CODEL
tc qdisc add dev wan root handle 1: nsstbl rate 500Mbit burst 1Mb
tc qdisc add dev wan parent 1: handle 10: nssfq_codel limit 10240 flows 1024 quantum 1514 target 5ms interval 100ms set_default

Yes, they worked for me with dimfish build from 7/9/2023 i have not tested them in a latest one, as i believe they need to be recompiled for each build .

Can I upgrade from 2023-06-12-2358 to latest using this without wiping my config: https://github.com/AgustinLorenzo/openwrt/issues/9 or do I have to upgrade to another version first?

Running on Xiaomi AX3600

Hi @strxno

Yes, just follow the steps

Thanks for using.

Regards, Agustín

What is better in your build than the daily snapshot of Openwrt?
What should I expect if i Update to it? Better WAN speeds? Better WIFI?

The builds of this thread are EXPERIMENTAL builds that enable the NSS cores (network acceleration). So you can expect CPU near 0 when doing some tasks. It can do better wan speeds if the speed is limited by the CPU of the router.

For those of you who have the NBG7815 and want support for Leds and fan, you can try the new version that I have compiled.

The firstboot problem is still there so read the flashing procedure.

Here you have the link.


Anyone has ported these build on Arcadyan AW 1000?

Can it be used on WXR-6000AX12P/N or WXR-11000XE12?


Do either of you two see your devices in the https://openwrt.org/toh/start, if not, you have your answer.

The schedule is easy:

  • first you need to get support for your device into plain OpenWrt/master
  • then you can start thinking about NSS
1 Like

Hello there and thanks for your work on this. I am using my ax3600 xiaomi under a bridge setup now and since I cannot use pppoe passthrough it is in dhcp client/static ip behind it.
Compared to using pppoe directly nothing works, cannot download most of things, sometimes pages do not load or partially load and there is lag/connection errors on most web services. As soon as i turn software offload off, everything is fine (but cpu usage get up considerably). So I am convinced everything is due to NSS patches.
I've tried to set MTU of the wan as suggested to 1480, but no change. Is it due of using it behind a bridge? Thanks in advance for your help. Else I'll have to dismiss it cause internet is totally unusable

This patch seems to be failing

Applying /home/beaver/openwrt-nss/openwrt/target/linux/qualcommax/patches-6.1/0903-net-stmmac-revert-hrtimer.patch using plaintext: 
patching file drivers/net/ethernet/stmicro/stmmac/stmmac.h
Hunk #1 succeeded at 12 with fuzz 1 (offset -1 lines).
patching file drivers/net/ethernet/stmicro/stmmac/stmmac_main.c
Hunk #1 succeeded at 144 (offset 2 lines).
Hunk #2 FAILED at 2725.
Hunk #3 FAILED at 3019.
Hunk #4 succeeded at 2989 (offset -41 lines).
Hunk #5 succeeded at 3007 (offset -41 lines).
Hunk #6 succeeded at 3029 (offset -41 lines).
Hunk #7 succeeded at 3860 (offset -39 lines).
Hunk #8 succeeded at 3918 (offset -37 lines).
Hunk #9 succeeded at 6589 (offset -63 lines).
Hunk #10 succeeded at 6686 (offset -61 lines).
Hunk #11 succeeded at 6709 (offset -61 lines).
Hunk #12 succeeded at 7430 (offset -61 lines).
2 out of 12 hunks FAILED -- saving rejects to file drivers/net/ethernet/stmicro/stmmac/stmmac_main.c.rej
Patch failed!  Please fix /home/beaver/openwrt-nss/openwrt/target/linux/qualcommax/patches-6.1/0903-net-stmmac-revert-hrtimer.patch!
make[4]: *** [Makefile:31: /home/beaver/openwrt-nss/openwrt/build_dir/target-aarch64_cortex-a53_musl/linux-qualcommax_ipq807x/linux-6.1.55/.prepared_739e89461a740f18b606c1bedfe074bd] Error 1

Is there any way to turn on the AIoT(phy0)?