IPQ807X NSS Build

based on your output, there are six that are loaded in 'qca_nss_qdisc'. Mine shows 0.

that's weird ... and you have netlink etc installed
the only thing - is you already have loaded fq_codel against nssifb ... so wondering if you remove this disc by rmmod nssifb and retry may work but beyond this don't know

Do you also build for ax3600 devices with nss?

not ax3600 ... only the qnap ... but it shouldn't be different. @bitthief 's device i understand is an ax3600

1 Like

New version. Get 983Mbit with ondemand governor for wifi-lan on 36ch 160Mhz


@rmandrad Are you getting better throughput now on your QNAP?

i have the same 3 devices, so id love to test your build and share finding

Hi @a011528 the repo you should use is @bitthief . Yes overall better throughput in particular for packets that make use of NSS (accel_mode=0) however do expect higher latency. I presume the latency issue is related additional handover as part of the nss code.

There are some tweaks you can add on the ECM and NSS_DRV Makefiles. As I use macvlan I enabled it ...

Unfortunately I wasn't able to test NSS with 10G/2.5G ethernet...

1 Like

Which is your wireless config to use ch36 with he160?

Do u mean what Country? CN (also PA has almost full range of frequencies and power)

1 Like

New version

  • Latest ath11k (@robimarko) + 160MHz fix
  • mac80211: ath11k: add HACK patch to fix failing sysupgrade (@Ansuel) + fix

DE / Channel 52 / 160 Mhz works.
What is the 160 Mhz fix and when can I ASU upgrade to this via snapshot?

Follow the issue


@bitthief just updated his repo with a patch

1 Like

@rmandrad can you share what else you have done on the QNAP ? or anyone else for that matter.

I've built image from bitthief and flashed, but this is now very new territory for me and I'm trying to learn and understand what else you & others have installed / tweaked / settings set etc

Someone are making dynalink wrx36 image?

@rmandrad ive tried to recompile build using bitthief's repo and the commands for nss qdisc works now. Thanks.

1 Like

there are only a few things

  1. enabled the ondemand governor on target/linux/ipq807x/config-5.15
  2. enabled all the options of the nss-drv
  3. compile the nss-ecm with the following
                ECM_FRONT_END_SFE_ENABLE=n \
                ECM_INTERFACE_BOND_ENABLE=n \
                ECM_INTERFACE_IPSEC_ENABLE=n \
                ECM_INTERFACE_PPTP_ENABLE=n \
                ECM_INTERFACE_PPPOE_ENABLE=y \
                ECM_INTERFACE_L2TPV2_ENABLE=n \
                ECM_INTERFACE_GRE_TAP_ENABLE=n \
                ECM_INTERFACE_GRE_TUN_ENABLE=n \
                ECM_INTERFACE_SIT_ENABLE=n \
                ECM_INTERFACE_RAWIP_ENABLE=y \
                ECM_INTERFACE_VLAN_ENABLE=y \
                ECM_INTERFACE_VXLAN_ENABLE=y \
                ECM_CLASSIFIER_MARK_ENABLE=y \
                ECM_CLASSIFIER_DSCP_ENABLE=n \
                ECM_CLASSIFIER_PCC_ENABLE=n \
                ECM_CLASSIFIER_MSCS_ENABLE=y \
                ECM_CLASSIFIER_NL_ENABLE=n \
                ECM_BAND_STEERING_ENABLE=n \
1 Like

New version

  • Fix 160MHz (Robimarco)

Hi, my compilation from @bitthief's repo ends with errors:

make[3]: Leaving directory '/home/patrik/Documents/AX6/NSS_02/openwrt/package/kernel/mac80211'
time: package/kernel/mac80211/regular/compile#119.67#11.50#92.90
make[2]: Leaving directory '/home/patrik/Documents/AX6/NSS_02/openwrt'
make[1]: *** [package/Makefile:110: /home/patrik/Documents/AX6/NSS_02/openwrt/staging_dir/target-aarch64_cortex-a53_musl/stamp/.package_compile] Error 2
make[1]: Leaving directory '/home/patrik/Documents/AX6/NSS_02/openwrt'
make: *** [/home/patrik/Documents/AX6/NSS_02/openwrt/include/toplevel.mk:231: world] Error 2

Does anyone know what could be the problem? Or does anyone have a compiled AX6 firmware with the nss and ath11k patch for 160MHz?


@KingCZE You can use dimfish's fork.