That looks good so far, try to tftpboot/bootm the initramfs from the DL-WRX36 and post the serial log output
What address should I use?
tftpboot 0x???????? 192.168.0.66:dynalink_dl-wrx36-initramfs-uImage.itb
Is that the correct file?(https://downloads.openwrt.org/releases/23.05.4/targets/ipq807x/generic/openwrt-23.05.4-ipq807x-generic-dynalink_dl-wrx36-initramfs-uImage.itb)
Better use a snapshot image. just tftpboot (the default load address should do)
On console
IPQ807x# tftpboot 192.168.0.66:openwrt-ipq807x-generic-dynalink_dl-wrx36-initramfs-uImage.itb
tftpboot 192.168.0.66:openwrt-ipq807x-generic-dynalink_dl-wrx36-initramfs-uImage.itb
ipq807x_eth_halt: done
Phy ops not mapped
Phy ops not mapped
Phy ops not mapped
Phy ops not mapped
eth0 PHY4 up Speed :1000 Full duplex
eth0 PHY5 Down Speed :10 Half duplex
ipq807x_eth_init: done
Using eth0 device
TFTP from server 192.168.0.66; our IP address is 192.168.0.1
Filename 'openwrt-ipq807x-generic-dynalink_dl-wrx36-initramfs-uImage.itb'.
Load address: 0x44000000
Loading: *
Got TFTP_OACK: TFTP remote port: changes from 69 to 64726
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#####
3.5 MiB/s
done
Bytes transferred = 12471232 (be4bc0 hex)
ipq807x_eth_halt: done
and "bootm"
IPQ807x# bootm
bootm
## Loading kernel from FIT Image at 44000000 ...
Using 'config@rt5010w-d350-rev0' configuration
Trying 'kernel-1' kernel subimage
Description: ARM64 OpenWrt Linux-6.1.33
Type: Kernel Image
Compression: gzip compressed
Data Start: 0x440000e8
Data Size: 12426741 Bytes = 11.9 MiB
Architecture: AArch64
OS: Linux
Load Address: 0x41000000
Entry Point: 0x41000000
Hash algo: crc32
Hash value: 276eed86
Hash algo: sha1
Hash value: b34c244b8a4bbc64b09d3faec736375b0c3f2d9c
Verifying Hash Integrity ... crc32+ sha1+ OK
## Loading fdt from FIT Image at 44000000 ...
Using 'config@rt5010w-d350-rev0' configuration
Trying 'fdt-1' fdt subimage
Description: ARM64 OpenWrt dynalink_dl-wrx36 device tree blob
Type: Flat Device Tree
Compression: uncompressed
Data Start: 0x44bda024
Data Size: 42547 Bytes = 41.5 KiB
Architecture: AArch64
Hash algo: crc32
Hash value: 2959141c
Hash algo: sha1
Hash value: c2f143166aecd74b956f01e9f838bb4f6b009c4d
Verifying Hash Integrity ... crc32+ sha1+ OK
Booting using the fdt blob at 0x44bda024
Uncompressing Kernel Image ... OK
Loading Device Tree to 4a3f2000, end 4a3ff632 ... OK
Could not find PCI in device tree
Using machid 0x8010400 from environment
Starting kernel ...
Jumping to AARCH64 kernel via monitor
[ 0.000000] Booting Linux on physical CPU 0x0000000000 [0x410fd034]
[ 0.000000] Linux version 6.1.33 (builder@buildhost) (aarch64-openwrt-linux-musl-gcc (OpenWrt GCC 12.3.0 r23375-cdfcac6e24) 12.3.0, GNU ld (GNU Binutils) 2.40.0) #0 SMP Wed Jun 14 21:27:29 2023
[ 0.000000] Machine model: Dynalink DL-WRX36
[ 0.000000] Zone ranges:
[ 0.000000] DMA [mem 0x0000000040000000-0x000000007fffffff]
[ 0.000000] DMA32 empty
[ 0.000000] Normal empty
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x0000000040000000-0x0000000040ffffff]
[ 0.000000] node 0: [mem 0x0000000041000000-0x000000004a3fffff]
[ 0.000000] node 0: [mem 0x000000004a400000-0x00000000510fffff]
[ 0.000000] node 0: [mem 0x0000000051100000-0x000000007fffffff]
[ 0.000000] Initmem setup node 0 [mem 0x0000000040000000-0x000000007fffffff]
[ 0.000000] psci: probing for conduit method from DT.
[ 0.000000] psci: PSCIv1.0 detected in firmware.
[ 0.000000] psci: Using standard PSCI v0.2 function IDs
[ 0.000000] psci: MIGRATE_INFO_TYPE not supported.
[ 0.000000] psci: SMC Calling Convention v1.0
[ 0.000000] percpu: Embedded 17 pages/cpu s31592 r8192 d29848 u69632
[ 0.000000] Detected VIPT I-cache on CPU0
[ 0.000000] alternatives: applying boot alternatives
[ 0.000000] Built 1 zonelists, mobility grouping on. Total pages: 258048
[ 0.000000] Kernel command line: root=/dev/ubiblock0_1
[ 0.000000] Dentry cache hash table entries: 131072 (order: 8, 1048576 bytes, linear)
[ 0.000000] Inode-cache hash table entries: 65536 (order: 7, 524288 bytes, linear)
[ 0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[ 0.000000] Memory: 879944K/1048576K available (8128K kernel code, 872K rwdata, 2276K rodata, 8576K init, 291K bss, 168632K reserved, 0K cma-reserved)
[ 0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[ 0.000000] rcu: Hierarchical RCU implementation.
[ 0.000000] Tracing variant of Tasks RCU enabled.
[ 0.000000] rcu: RCU calculated value of scheduler-enlistment delay is 10 jiffies.
[ 0.000000] NR_IRQS: 64, nr_irqs: 64, preallocated irqs: 0
[ 0.000000] Root IRQ handler: gic_handle_irq
[ 0.000000] GICv2m: range[mem 0x0b00a000-0x0b00affc], SPI[448:479]
[ 0.000000] rcu: srcu_init: Setting srcu_struct sizes based on contention.
[ 0.000000] arch_timer: cp15 and mmio timer(s) running at 19.20MHz (virt/virt).
[ 0.000000] clocksource: arch_sys_counter: mask: 0xffffffffffffff max_cycles: 0x46d987e47, max_idle_ns: 440795202767 ns
[ 0.000001] sched_clock: 56 bits at 19MHz, resolution 52ns, wraps every 4398046511078ns
[ 0.000113] Calibrating delay loop (skipped), value calculated using timer frequency.. 38.40 BogoMIPS (lpj=192000)
[ 0.000127] pid_max: default: 32768 minimum: 301
[ 0.000612] Mount-cache hash table entries: 2048 (order: 2, 16384 bytes, linear)
[ 0.000627] Mountpoint-cache hash table entries: 2048 (order: 2, 16384 bytes, linear)
[ 0.002489] cblist_init_generic: Setting adjustable number of callback queues.
[ 0.002502] cblist_init_generic: Setting shift to 2 and lim to 1.
[ 0.002695] rcu: Hierarchical SRCU implementation.
[ 0.002699] rcu: Max phase no-delay instances is 1000.
[ 0.003475] smp: Bringing up secondary CPUs ...
[ 0.004109] Detected VIPT I-cache on CPU1
[ 0.004249] CPU1: Booted secondary processor 0x0000000001 [0x410fd034]
[ 0.004907] Detected VIPT I-cache on CPU2
[ 0.005007] CPU2: Booted secondary processor 0x0000000002 [0x410fd034]
[ 0.005621] Detected VIPT I-cache on CPU3
[ 0.005723] CPU3: Booted secondary processor 0x0000000003 [0x410fd034]
[ 0.005790] smp: Brought up 1 node, 4 CPUs
[ 0.005798] SMP: Total of 4 processors activated.
[ 0.005803] CPU features: detected: 32-bit EL0 Support
[ 0.005808] CPU features: detected: CRC32 instructions
[ 0.005871] CPU features: emulated: Privileged Access Never (PAN) using TTBR0_EL1 switching
[ 0.005877] CPU: All CPU(s) started at EL1
[ 0.005880] alternatives: applying system-wide alternatives
[ 0.015925] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[ 0.015951] futex hash table entries: 1024 (order: 4, 65536 bytes, linear)
[ 0.016165] pinctrl core: initialized pinctrl subsystem
[ 0.017610] NET: Registered PF_NETLINK/PF_ROUTE protocol family
[ 0.018114] DMA: preallocated 128 KiB GFP_KERNEL pool for atomic allocations
[ 0.018170] DMA: preallocated 128 KiB GFP_KERNEL|GFP_DMA pool for atomic allocations
[ 0.018206] DMA: preallocated 128 KiB GFP_KERNEL|GFP_DMA32 pool for atomic allocations
[ 0.018594] thermal_sys: Registered thermal governor 'step_wise'
[ 0.018779] cpuidle: using governor menu
[ 0.019031] ASID allocator initialised with 65536 entries
[ 0.071291] qcom,cpr4-apss-regulator b018000.cpr4-ctrl: CPR valid fuse count: 4
[ 0.079800] SCSI subsystem initialized
[ 0.079985] usbcore: registered new interface driver usbfs
[ 0.080037] usbcore: registered new interface driver hub
[ 0.080117] usbcore: registered new device driver usb
[ 0.080536] qcom_scm: convention: smc arm 64
[ 0.082012] clocksource: Switched to clocksource arch_sys_counter
[ 0.083155] NET: Registered PF_INET protocol family
[ 0.083310] IP idents hash table entries: 16384 (order: 5, 131072 bytes, linear)
[ 0.084749] tcp_listen_portaddr_hash hash table entries: 512 (order: 1, 8192 bytes, linear)
[ 0.084775] Table-perturb hash table entries: 65536 (order: 6, 262144 bytes, linear)
[ 0.084789] TCP established hash table entries: 8192 (order: 4, 65536 bytes, linear)
[ 0.084876] TCP bind hash table entries: 8192 (order: 6, 262144 bytes, linear)
[ 0.085153] TCP: Hash tables configured (established 8192 bind 8192)
[ 0.085256] UDP hash table entries: 512 (order: 2, 16384 bytes, linear)
[ 0.085295] UDP-Lite hash table entries: 512 (order: 2, 16384 bytes, linear)
[ 0.085522] NET: Registered PF_UNIX/PF_LOCAL protocol family
[ 0.085560] PCI: CLS 0 bytes, default 64
[ 0.086694] workingset: timestamp_bits=46 max_order=18 bucket_order=0
[ 0.091714] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.091728] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 0.092900] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 248)
[ 0.094804] qcom-qmp-usb-phy 78000.phy: supply vdda-phy not found, using dummy regulator
[ 0.094981] qcom-qmp-usb-phy 78000.phy: supply vdda-pll not found, using dummy regulator
[ 0.096827] qcom-qusb2-phy 79000.phy: supply vdd not found, using dummy regulator
[ 0.096979] qcom-qusb2-phy 79000.phy: supply vdda-pll not found, using dummy regulator
[ 0.097082] qcom-qusb2-phy 79000.phy: supply vdda-phy-dpdm not found, using dummy regulator
[ 0.097237] qcom-qusb2-phy 79000.phy: Registered Qcom-QUSB2 phy
[ 0.102095] bam-dma-engine 704000.dma-controller: num-channels unspecified in dt
[ 0.102111] bam-dma-engine 704000.dma-controller: num-ees unspecified in dt
[ 0.106703] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[ 0.108861] msm_serial 78b3000.serial: msm_serial: detected port #0
[ 0.108900] msm_serial 78b3000.serial: uartclk = 3686400
[ 0.109002] 78b3000.serial: ttyMSM0 at MMIO 0x78b3000 (irq = 20, base_baud = 230400) is a MSM
[ 0.109031] msm_serial: console setup on port #0
[ 0.766409] printk: console [ttyMSM0] enabled
[ 0.771564] msm_serial: driver initialized
[ 0.780459] loop: module loaded
[ 0.780534] Loading iSCSI transport class v2.0-870.
[ 0.784599] nand: device found, Manufacturer ID: 0xc8, Chip ID: 0x61
[ 0.787278] nand: ESMT PSR1GA30DT
[ 0.793896] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[ 0.797088] nand: ECC (step, strength) = (512, 8) does not fit in OOB
[ 0.797098] qcom-nandc 79b0000.nand-controller: No valid ECC settings possible
[ 0.811132] qcom-nandc: probe of 79b0000.nand-controller failed with error -28
[ 0.818762] spmi spmi-0: PMIC arbiter version v2 (0x20010000)
[ 0.843549] mdio_bus 90000.mdio-1: MDIO device at address 0 is missing.
[ 0.843647] mdio_bus 90000.mdio-1: MDIO device at address 1 is missing.
[ 0.849033] mdio_bus 90000.mdio-1: MDIO device at address 2 is missing.
[ 0.855653] mdio_bus 90000.mdio-1: MDIO device at address 3 is missing.
[ 0.872698] i2c_dev: i2c /dev entries driver
[ 0.878667] sdhci: Secure Digital Host Controller Interface driver
[ 0.878713] sdhci: Copyright(c) Pierre Ossman
[ 0.883808] sdhci-pltfm: SDHCI platform and OF driver helper
[ 0.890047] remoteproc remoteproc0: releasing cd00000.q6v5_wcss
[ 0.896793] NET: Registered PF_INET6 protocol family
[ 0.900618] Segment Routing with IPv6
[ 0.904814] In-situ OAM (IOAM) with IPv6
[ 0.908379] NET: Registered PF_PACKET protocol family
[ 0.912352] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[ 0.917388] 8021q: 802.1Q VLAN Support v1.8
[ 0.952337] qcom,cpr4-apss-regulator b018000.cpr4-ctrl: CPR valid fuse count: 4
[ 0.952683] cpr4_ipq807x_apss_read_fuse_data: apc_corner: speed bin = 0
[ 0.958464] cpr4_ipq807x_apss_read_fuse_data: apc_corner: CPR fusing revision = 1
[ 0.965076] cpr4_ipq807x_apss_read_fuse_data: apc_corner: CPR misc fuse value = 0
[ 0.972731] cpr4_ipq807x_apss_read_fuse_data: apc_corner: Voltage boost fuse config = 0 boost = disable
[ 0.980252] cpr3_mem_acc_init: apc: not using memory accelerator regulator
[ 0.989375] cpr4_ipq807x_apss_calculate_open_loop_voltages: apc_corner: fused SVS: open-loop= 704000 uV
[ 0.996322] cpr4_ipq807x_apss_calculate_open_loop_voltages: apc_corner: fused NOM: open-loop= 816000 uV
[ 1.006305] cpr4_ipq807x_apss_calculate_open_loop_voltages: apc_corner: fused TURBO: open-loop= 880000 uV
[ 1.016114] cpr4_ipq807x_apss_calculate_open_loop_voltages: apc_corner: fused STURBO: open-loop= 968000 uV
[ 1.025974] cpr4_ipq807x_apss_calculate_target_quotients: apc_corner: fused SVS: quot[ 7]= 703, quot_offset[ 7]= 0
[ 1.035735] cpr4_ipq807x_apss_calculate_target_quotients: apc_corner: fused NOM: quot[ 7]= 917, quot_offset[ 7]= 210
[ 1.046586] cpr4_ipq807x_apss_calculate_target_quotients: apc_corner: fused TURBO: quot[ 7]=1028, quot_offset[ 7]= 110
[ 1.057523] cpr4_ipq807x_apss_calculate_target_quotients: apc_corner: fused STURBO: quot[ 7]=1188, quot_offset[ 7]= 160
[ 1.068672] cpr3_regulator_init_ctrl: apc: Default CPR mode = closed-loop
[ 1.071609] cpufreq: cpufreq_online: CPU0: Running at unlisted initial frequency: 19200 KHz, changing to: 1017600 KHz
Û[ 1.100241] Freeing unused kernel memory: 8576K
[ 1.162065] Run /init as init process
[ 1.322662] init: Console is alive
[ 1.322832] init: - watchdog -
[ 1.330821] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[ 1.354866] ssdk_switch_device_num_init[1335]:INFO:ess-switch dts node number: 1
[ 1.354970] ssdk_dt_get_switch_node[1124]:INFO:ess-switch DT exist!
[ 1.361335] ssdk_dt_parse_access_mode[999]:INFO:switch_access_mode: local bus
[ 1.367358] ssdk_dt_parse_access_mode[1012]:INFO:switchreg_base_addr: 0x3a000000
[ 1.374619] ssdk_dt_parse_access_mode[1013]:INFO:switchreg_size: 0x1000000
[ 1.382081] ssdk_dt_parse_mac_mode[327]:INFO:mac mode = 0xb
[ 1.388758] ssdk_dt_parse_mac_mode[336]:INFO:mac mode1 = 0xff
[ 1.394233] ssdk_dt_parse_mac_mode[345]:INFO:mac mode2 = 0xc
[ 1.400143] ssdk_dt_parse_phy_info[716]:INFO:[PORT 6] port_mac_sel = QGMAC_PORT
[ 1.405896] ssdk_dt_parse_uniphy[364]:INFO:ess-uniphy DT exist!
[ 1.413164] ssdk_plat_init[1692]:INFO:ssdk_plat_init start
[ 1.533376] ssdk_gcc_clock_init[1275]:INFO:SSDK gcc clock init successfully!
[ 1.534340] ssdk_phy_driver_init[363]:INFO:dev_id = 0, phy_adress = 0, phy_id = 0xffffffff phytype doesn't match
[ 1.539544] ssdk_phy_driver_init[363]:INFO:dev_id = 0, phy_adress = 1, phy_id = 0xffffffff phytype doesn't match
[ 1.549722] ssdk_phy_driver_init[363]:INFO:dev_id = 0, phy_adress = 2, phy_id = 0xffffffff phytype doesn't match
[ 1.559872] ssdk_phy_driver_init[363]:INFO:dev_id = 0, phy_adress = 3, phy_id = 0xffffffff phytype doesn't match
[ 1.570072] qca803x_phy_api_ops_init[2198]:INFO:qca probe qca803x phy driver succeeded!
[ 1.580268] qca808x_phy_api_ops_init[2570]:INFO:qca probe qca808x phy driver succeeded!
[ 1.589101] regi_init[3953]:INFO:Initializing HPPE!!
[ 1.832018] ssdk_ppe_reset_init[1535]:INFO:ppe reset successfully!
[ 1.835530] qca_hppe_portctrl_hw_init[126]:INFO:Hawkeye PPE port initializing
[ 1.837170] hsl_phy_phydev_get[773]:ERROR:phy_addr 4 phydev is NULL
[ 1.844446] hsl_phy_phydev_get[773]:ERROR:phy_addr 4 phydev is NULL
[ 1.851879] ssdk_switch_register[2017]:INFO:Chip version 0x1500
[ 1.856640] qca_link_polling_select[1487]:INFO:link-polling-required node does not exist
[ 1.862535] ssdk_switch_register[2043]:INFO:polling is selected
[ 1.870861] regi_init[3957]:INFO:Initializing HPPE Done!!
[ 1.876593] ssdk_genl_init[211]:INFO:ssdk genl family register success.
[ 1.882070] regi_init[4020]:INFO:qca-ssdk module init succeeded!
[ 1.890869] EDMA ver 1 hw init
[ 1.894965] EDMA HW Reset completed succesfully
[ 1.897621] Num rings - TxDesc:1 (23-23) TxCmpl:1 (7-7)
[ 1.902031] RxDesc:1 (15-15) RxFill:1 (7-7)
[ 1.907566] GMAC1(ffffff8002d7e940) Invalid MAC@ - using fa:69:e6:49:30:bf
[ 1.911655] nss-dp 3a001000.dp1: Could not attach to PHY
[ 1.952057] nss-dp: probe of 3a001000.dp1 failed with error -14
[ 1.952223] GMAC2(ffffff800369e940) Invalid MAC@ - using 8a:04:48:ab:a5:18
[ 1.956798] nss-dp 3a001200.dp2: Could not attach to PHY
[ 1.963749] nss-dp: probe of 3a001200.dp2 failed with error -14
[ 1.969229] GMAC3(ffffff800369e940) Invalid MAC@ - using b2:f1:ca:4d:c0:90
[ 1.974848] nss-dp 3a001400.dp3: Could not attach to PHY
[ 1.981793] nss-dp: probe of 3a001400.dp3 failed with error -14
[ 1.987287] GMAC4(ffffff800369e940) Invalid MAC@ - using e6:11:d1:7c:23:30
[ 1.992906] nss-dp 3a001600.dp4: Could not attach to PHY
[ 1.999859] nss-dp: probe of 3a001600.dp4 failed with error -14
[ 2.205915] QCA808X ethernet 90000.mdio-1:1c: attached PHY driver (mii_bus:phy_addr=90000.mdio-1:1c, irq=POLL)
[ 2.206512] nss-dp 3a007000.dp6-syn wan: Registered netdev wan(qcom-id:6)
[ 2.214923] **********************************************************
[ 2.221654] * NSS Data Plane driver
[ 2.228081] **********************************************************
[ 2.240708] xhci-hcd xhci-hcd.1.auto: xHCI Host Controller
[ 2.240756] xhci-hcd xhci-hcd.1.auto: new USB bus registered, assigned bus number 1
[ 2.245274] xhci-hcd xhci-hcd.1.auto: hcc params 0x0220fe65 hci version 0x110 quirks 0x0000000002010010
[ 2.252689] xhci-hcd xhci-hcd.1.auto: irq 36, io mem 0x08a00000
[ 2.262110] xhci-hcd xhci-hcd.1.auto: xHCI Host Controller
[ 2.267922] xhci-hcd xhci-hcd.1.auto: new USB bus registered, assigned bus number 2
[ 2.273490] xhci-hcd xhci-hcd.1.auto: Host supports USB 3.0 SuperSpeed
[ 2.281395] hub 1-0:1.0: USB hub found
[ 2.287671] hub 1-0:1.0: 1 port detected
[ 2.291846] usb usb2: We don't know the algorithms for LPM for this host, disabling LPM.
[ 2.295990] hub 2-0:1.0: USB hub found
[ 2.303557] hub 2-0:1.0: 1 port detected
[ 2.308571] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[ 2.314631] init: - preinit -
[ 2.572012] usb 1-1: new high-speed USB device number 2 using xhci-hcd
[ 2.872017] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 2.872051] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 2.877088] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 2.883344] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 3.912006] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 3.912027] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 3.917067] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 3.923322] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 4.952005] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 4.952025] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 4.957065] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 4.963321] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 6.472006] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 6.472026] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 6.477064] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 6.483321] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 7.512006] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 7.512025] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 7.517065] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 7.523321] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 8.552005] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 8.552025] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 8.557064] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 8.563319] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 8.732006] random: crng init done
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[ 9.592028] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 9.592075] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 9.597112] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 9.603380] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 10.632027] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 10.632071] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 10.637109] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 10.643377] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 10.886115] procd: - early -
[ 10.886194] procd: - watchdog -
[ 11.404606] procd: - watchdog -
[ 11.404843] procd: - ubus -
[ 11.457771] procd: - init -
Please press Enter to activate this console.
[ 11.559172] kmodloader: loading kernel modules from /etc/modules.d/*
[ 11.589202] Loading modules backported from Linux version v6.1.24-0-g0102425ac76b
[ 11.589243] Backport generated by backports.git v5.15.92-1-44-gd6ea70fafd36
[ 11.599906] NET: Registered PF_QIPCRTR protocol family
[ 11.606074] urngd: v1.0.2 started.
[ 11.625642] PPP generic driver version 2.4.2
[ 11.626311] NET: Registered PF_PPPOX protocol family
[ 11.634381] ath11k c000000.wifi: ipq8074 hw2.0
[ 11.634414] ath11k c000000.wifi: FW memory mode: 0
[ 11.638404] remoteproc remoteproc0: powering up cd00000.q6v5_wcss
[ 11.643126] remoteproc remoteproc0: Booting fw image IPQ8074/q6_fw.mdt, size 668
[ 11.672044] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 11.672092] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 11.677129] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 11.683391] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 11.994242] remoteproc remoteproc0: remote processor cd00000.q6v5_wcss is now up
[ 11.998887] kmodloader: done loading kernel modules from /etc/modules.d/*
[ 12.038132] ath11k c000000.wifi: qmi ignore invalid mem req type 3
[ 12.045590] ath11k c000000.wifi: chip_id 0x0 chip_family 0x0 board_id 0xff soc_id 0xffffffff
[ 12.045626] ath11k c000000.wifi: fw_version 0x290c84a5 fw_build_timestamp 2023-03-25 07:34 fw_build_id WLAN.HK.2.9.0.1-01385-QCAHKSWPL_SILICONZ-1
[ 12.115036] ath11k c000000.wifi: failed to fetch board data for bus=ahb,qmi-chip-id=0,qmi-board-id=255,variant=Dynalink-DL-WRX36 from ath11k/IPQ8074/hw2.0/board-2.bin
[ 12.115097] ath11k c000000.wifi: failed to fetch board data for bus=ahb,qmi-chip-id=0,qmi-board-id=255 from ath11k/IPQ8074/hw2.0/board-2.bin
[ 12.128959] ath11k c000000.wifi: failed to fetch board.bin from IPQ8074/hw2.0
[ 12.141590] ath11k c000000.wifi: qmi failed to fetch board file: -12
[ 12.148604] ath11k c000000.wifi: failed to load board data file: -12
[ 12.712031] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 12.712076] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 12.717114] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 12.723380] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 13.752045] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 13.752091] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 13.757130] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 13.763449] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 14.792054] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 14.792101] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 14.797139] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 14.803437] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 15.842027] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 15.842075] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 15.847114] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 15.853392] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 16.872028] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 16.872076] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 16.877113] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 16.883389] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 17.912018] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 17.912044] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 17.917084] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 17.923349] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 18.952025] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 18.952058] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 18.957097] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 18.963366] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 19.752196] nss-dp 3a007000.dp6-syn wan: PHY Link up speed: 1000
[ 19.752250] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
[ 19.992030] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 19.992079] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 19.997117] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 20.003391] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 21.032026] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 21.032073] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 21.037110] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 21.043385] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 22.072029] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 22.072059] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 22.077099] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 22.083368] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 23.112021] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 23.112049] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 23.117088] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 23.123357] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 24.152023] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 24.152061] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 24.157100] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 24.163370] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 25.192017] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 25.192044] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 25.197083] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 25.203351] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 26.232023] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 26.232063] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 26.237102] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 26.243372] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 27.272017] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 27.272043] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 27.277082] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 27.283349] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 28.312023] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 28.312055] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 28.317093] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 28.323363] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 29.352019] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 29.352050] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 29.357088] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 29.363358] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 30.392018] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 30.392044] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 30.397084] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 30.403351] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 31.192056] l11: disabling
BusyBox v1.36.1 (2023-06-14 21:27:29 UTC) built-in shell (ash)
_______ ________ __
| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -__| || | | || _|| _|
|_______|| __|_____|__|__||________||__| |____|
|__| W I R E L E S S F R E E D O M
-----------------------------------------------------
OpenWrt SNAPSHOT, r23375-cdfcac6e24
-----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:/#
root@OpenWrt:/# [ 48.072028] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 48.072075] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 48.077112] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 48.083386] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 49.112019] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 49.112045] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 49.117085] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 49.123352] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
[ 50.152022] hsl_phy_phydev_get[773]:ERROR:phy_addr 0 phydev is NULL
[ 50.152052] hsl_phy_phydev_get[773]:ERROR:phy_addr 1 phydev is NULL
[ 50.157091] hsl_phy_phydev_get[773]:ERROR:phy_addr 2 phydev is NULL
[ 50.163359] hsl_phy_phydev_get[773]:ERROR:phy_addr 3 phydev is NULL
Keeps doing that until I interupt with Enter
That phydev is NULL error can be ignored, the DL-WRX-36 has a QCA8075 Ethernet phy, the X80 has only a QCA8081 and AR8033.
According to the log of the ssdk both are successfully initialized
[ 1.570072] qca803x_phy_api_ops_init[2198]:INFO:qca probe qca803x phy driver succeeded!
[ 1.580268] qca808x_phy_api_ops_init[2570]:INFO:qca probe qca808x phy driver succeeded!
Just try to connect via Ethernet, try both ports if you get an ip via dhcp
EDIT
Only the WAN port seems to work (QCA8081) due to the DP5 is not defined in the DL-WRX-36.
That makes it difficult, you would need to edit the /etc/config/network, rm the wan interface and add the wan port to the br-lan bridge.
It's not easy to use vi in the serial console due to the log spamming
Thanks for the assist thus far.
Can't stop the spamming I guess?
No way to "echo" the entire file into the location?
cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd1a:8727:a27b::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'wan'
option proto 'dhcp'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
You would need to build an image with a proper dts to stop the log spamming.
Echoing the network config might work, but I never tried it myself.
That config should work
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd1a:8727:a27b::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'wan'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
you need to restart the network afterwards (service network restart)
And there is another problem, the nand controller isn't recognised:
[ 0.784599] nand: device found, Manufacturer ID: 0xc8, Chip ID: 0x61
[ 0.787278] nand: ESMT PSR1GA30DT
[ 0.793896] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[ 0.797088] nand: ECC (step, strength) = (512, 8) does not fit in OOB
[ 0.797098] qcom-nandc 79b0000.nand-controller: No valid ECC settings possible
[ 0.811132] qcom-nandc: probe of 79b0000.nand-controller failed with error -28
might be an issue with the ecc strength settings...so I guess you need to build a proper device image
EDIT:
nand-ecc-strength = <4>; is required (instead of 8)
That was ugly, but output seemed to match. Still no network on DHCP or static 192.168.1.0/24
echo "config interface 'loopback'" > /etc/config/network.new
echo " option device 'lo'" >> /etc/config/network.new
echo " option proto 'static'" >> /etc/config/network.new
echo " option ipaddr '127.0.0.1'" >> /etc/config/network.new
echo " option netmask '255.0.0.0'" >> /etc/config/network.new
echo "" >> /etc/config/network.new
echo "config globals 'globals'" >> /etc/config/network.new
echo " option ula_prefix 'fd1a:8727:a27b::/48'" >> /etc/config/network.new
echo "" >> /etc/config/network.new
echo "config device" >> /etc/config/network.new
echo " option name 'br-lan'" >> /etc/config/network.new
echo " option type 'bridge'" >> /etc/config/network.new
echo " list ports 'wan'" >> /etc/config/network.new
echo "">> /etc/config/network.new
echo "">> /etc/config/network.new
echo "config interface 'lan'" >> /etc/config/network.new
echo " option device 'br-lan'" >> /etc/config/network.new
echo " option proto 'static'" >> /etc/config/network.new
echo " option ipaddr '192.168.1.1'" >> /etc/config/network.new
echo " option netmask '255.255.255.0'" >> /etc/config/network.new
echo " option ip6assign '60'" >> /etc/config/network.new
cat /etc/config/network.new
mv /etc/config/network /etc/config/network.bak
mv /etc/config/network.new /etc/config/network
service network restart
See my other post regarding NAND.
I think you need to go the "add new device" route.
I can assist you with that.
That would be amazing.
So we could just clone the DL-WRX36 and edit the ecc strength and comment out the network stuff in the dts that throws errors?
then touch target/linux/*/Makefile and build to get a some what more usable image?
We also don't need to map the partitions in the DTS because it is pre configured in the smem tables and it will just work?
[ 1.032842] 25 qcomsmem partitions found on MTD device qcom_nand.0
[ 1.040001] Creating 25 MTD partitions on "qcom_nand.0":
[ 1.046234] 0x000000000000-0x000000100000 : "0:sbl1"
[ 1.052942] 0x000000100000-0x000000200000 : "0:mibib"
[ 1.057788] 0x000000200000-0x000000280000 : "0:bootconfig"
[ 1.062396] 0x000000280000-0x000000300000 : "0:bootconfig1"
[ 1.067730] 0x000000300000-0x000000600000 : "0:qsee"
[ 1.075143] 0x000000600000-0x000000900000 : "0:qsee_1"
[ 1.080386] 0x000000900000-0x000000980000 : "0:devcfg"
[ 1.083370] 0x000000980000-0x000000a00000 : "0:devcfg_1"
[ 1.088488] 0x000000a00000-0x000000a80000 : "0:apdp"
[ 1.093983] 0x000000a80000-0x000000b00000 : "0:apdp_1"
[ 1.098916] 0x000000b00000-0x000000b80000 : "0:rpm"
[ 1.103917] 0x000000b80000-0x000000c00000 : "0:rpm_1"
[ 1.108628] 0x000000c00000-0x000000c80000 : "0:cdt"
[ 1.113873] 0x000000c80000-0x000000d00000 : "0:cdt_1"
[ 1.118521] 0x000000d00000-0x000000d80000 : "0:appsblenv"
[ 1.123787] 0x000000d80000-0x000000e80000 : "0:appsbl"
[ 1.129553] 0x000000e80000-0x000000f80000 : "0:appsbl_1"
[ 1.134546] 0x000000f80000-0x000001000000 : "0:art"
[ 1.139649] 0x000007a00000-0x00000db00000 : "rootfs"
[ 1.218611] mtd: device 18 (rootfs) set to be root filesystem
[ 1.218902] mtdsplit: no squashfs found in "rootfs"
[ 1.223390] 0x000007100000-0x000007a00000 : "0:wififw"
[ 1.235357] 0x000001000000-0x000007100000 : "rootfs_1"
[ 1.310378] 0x00000db00000-0x00000e400000 : "0:wififw_1"
[ 1.317740] 0x00000e400000-0x00000fa00000 : "ubifs"
[ 1.335127] 0x00000fa00000-0x00000fa80000 : "0:ethphyfw"
[ 1.335936] 0x00000fa80000-0x00000fd00000 : "certificate"
so all we need to add is gpio led's and patch the network stuff in the dts ?
Yeah, pretty much.
-
Use nand-ecc-strength = <4>; in the nand node
-
Adapt the network related nodes, try that
aliases{
ethernet0 = &dp5;
ethernet1 = &dp6_syn;
}
&mdio {
status = "okay";
pinctrl-0 = <&mdio_pins>;
pinctrl-names = "default";
reset-gpios = <&tlmm 37 GPIO_ACTIVE_LOW>;
qca8033: ethernet-phy@4 {
compatible = "ethernet-phy-ieee802.3-c22";
reg = <0x4>;
};
qca8081: ethernet-phy@28 {
compatible = "ethernet-phy-id004d.d101";
reg = <28>;
reset-deassert-us = <10000>;
reset-gpios = <&tlmm 44 GPIO_ACTIVE_LOW>;
leds {
#address-cells = <1>;
#size-cells = <0>;
led@0 {
reg = <0>;
color = <LED_COLOR_ID_GREEN>;
function = LED_FUNCTION_WAN;
default-state = "keep";
};
led@1 {
reg = <1>;
color = <LED_COLOR_ID_YELLOW>;
function = LED_FUNCTION_WAN;
default-state = "keep";
};
};
};
};
&switch {
status = "okay";
switch_lan_bmp = <ESS_PORT6>; /* lan port bitmap */
switch_wan_bmp = <ESS_PORT5>; /* wan port bitmap */
switch_mac_mode1 = <MAC_MODE_SGMII_CHANNEL0>; /* mac mode for uniphy instance1*/
switch_mac_mode2 = <MAC_MODE_SGMII_CHANNEL0>; /* mac mode for uniphy instance2*/
qcom,port_phyinfo {
port@6 {
port_id = <6>;
phy_address = <4>;
};
port@5 {
port_id = <5>;
phy_address = <28>;
port_mac_sel = "QGMAC_PORT";
};
};
};
&dp5 {
status = "okay";
phy-handle = <&qca8081>;
label = "wan";
};
&dp6_syn {
status = "okay";
phy-handle = <&qca8033>;
label = "lan";
};
Thanks heaps Ill have a play and see if I can come up with something.
I'm guessing i can use binwalk and https://github.com/PabloCastellano/extract-dtb to try extract a stock dts from an update file, or is there a better method ?
I'm guessing I can pull one from failsafe mode? might be easier
Thanks so much for the effort.
Ready to rock when you guys are
Yes, I'm using extract-dtb and pydtc (to decompile the dtb) as well.
I did some things
14_dtbdump_Qualcomm_Technologies,_Inc._IPQ8074-HK01.dts
22_dtbdump_Qualcomm_Technologies,_Inc._IPQ807x_AP-AC02.dts