IPQ806x NSS Drivers

Thank you @Gram! I'll try and report back. I had the governor set to on-demand

Speaking of NSS and VPN, any idea if ipsec is or can be offloaded to NSS?
I'm currently running a separate VM for VPN related stuff (to keeps the route's CPU utilization low)
Was wondering if R7800 could handle the VPN part as well with the help of NSS

I run a variant of hnyman's build on my R7800 (i won't tag him as i don't think it's anything to do with his build), with some minor changes of my own, among them support for jumbo frames and using DSA instead of swconfig.

I tried merging this in but could not get it to work successfully...I left the DSA config in place initially (including the DTS changes) which resulted in none of the ethernet ports starting, luckily wireless still worked. I reverted the DSA changes in the DTS and in /etc/config, still no joy. Then I did a factory reset and the LAN ports came up, but still no WAN port. In luci it complains that the device is not present, in the kernel log you can see eth1 start up, but not eth0.

I'm afraid all this is a bit beyond me, anything obvious I've missed?

this is my tree: https://github.com/facboy/openwrt/tree/hnyman-ct-nss
and the kernel log: https://gist.github.com/facboy/854d09d45ff55b1f4ced23c8893449ef

nss doesn't like the dsa system... For ethernet you are stuck with swconfig for now.

Wish I knew why NSS enabled image won't boot for me. The config i use is basically the same config as hnyman use in his builds now when he enabled wireguard support.

I'm stuck also, no boot at my EA7500 V1.

My build is pretty similar to hynman’s. I have my diffconfig posted if you want to compare - or if it is helpful you could try my sysupgrade and add on your packages (just to try it out).

There must be a package or dependency that it doesn’t like.

Still getting spontaneous reboots. Anyone else? It reboots quickly and comes back, but still reboots periodically.

yes, i switched back to swconfig, but eth0 still doesn't come up.

Did you updated the dts?

I've been seeing these spurious reboots with r14721-4ff7bdfeeb (including ARM_QCOM_KRAIT_CACHE=y) and r14870-93adba4597 (without ARM_QCOM_KRAIT_CACHE patches) on my nbg6817 as well, neither of those builds include NSS patches.

That said, I've seen similar behaviour on lantiq/ bthub5 as well.

yes, i reverted everything. you can see the revert in my tree:

output of command swconfig list ?

i had to put it back to a working firmware, angry family :frowning:.

i might be able to try tomorrow.

you would expect to see eth0 in the kernel log though, no? i must admit i have no idea how any of this part works.

you should see in the log that the gmac has loaded


[   22.338596] **********************************************************
[   22.339800] * Driver    :NSS GMAC Driver - RTL v(3.72a)
[   22.346135] * Version   :1.0
[   22.351324] * Copyright :Copyright (c) 2013-2018 The Linux Foundation. All rights reserved.
[   22.354384] **********************************************************

later there is eth1, but never eth0:

[   47.336476] ipq8064-mdio 37000000.mdio eth1: 1000 Mbps Full Duplex
[   48.418037] br-lan: port 1(eth1.1) entered blocking state
[   48.418096] br-lan: port 1(eth1.1) entered disabled state
[   48.423472] device eth1.1 entered promiscuous mode
[   48.427806] device eth1 entered promiscuous mode
[   48.433804] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[   48.437949] br-lan: port 1(eth1.1) entered blocking state
[   48.443340] br-lan: port 1(eth1.1) entered forwarding state

or something else?

There was a netifd commit that breaks eth0 but they pushed a new fix two days ago.
Might because of that?

breaks in what way ? no connection?

It showed "Network Device is not present" on Luci and eth0 was not in the log at all.

Fixed in this commit

you have got to be kidding me. well, i only wasted 4 hours on it, so it could have been worse :slight_smile: !

how can i tell if it is enabled/working or not? should i have software/hardware offloading enabled?