Ipq806x NSS build (Netgear R7800 / TP-Link C2600 / Linksys EA8500)

missing dts nss gmac tho'

Agreed. I’ve only compiled for r7800s because that is what I’ve got. Looks like the devices supported are:
R7500 v1 & v2
R7800
C2600
EA7500
EA8500

I can build some untested builds for these other targets if anyone is interested in testing.

To get the zyxel_nbg6817 working with NSS I’d need @Ansuel help.

hey, i'm interested in trying on C2600, could you give me a build?

edit: thanks, I'll try after Christmas. w/ official openwrt im getting about 400 mbps, w/ enabled flow offload it bumps almost to 800 mbps, but the CPU is bottlenecked. (speedtest measurements)

p.s.: there's no chance that these (nss) changes getting merged into official repo?

@asturel - C2600 build posted. I don't have a C2600 so it is untested. Feel free to try it out and post some speed test results.

@Gilgamesh added adblock and upnp - enjoy!

1 Like

thank you! I just noticed when flashed latest one, why do I still have adblock and upnp? :joy: now I can just flash and forget, only thing I add is the Luci 2020 theme as I use my phone and the UI is much better than the stock one :slightly_smiling_face: maybe I should go to sleep now at 3:25 am :joy:

1 Like

EA8500 fails to boot with sysupgrade on top of the master openwrt


Three failed boots resulted in master back in operation. Tried with keeping settings and with resetting the whole config, same results.

Any errors or logs by chance? (Probably not since it didn’t boot)

update: Added wireguard.

Any C2600 or EA8500 users - the build is untested - let me know if it works and let me know if you are able to capture any logs so that I can help the developers to get your devices working with NSS drivers. I haven't seen any one post on the forum with a successful booting C2600 or EA8500 NSS build- I want to see if we can get them working.

2 Likes

Yesterday, I have tried to compile and test build for nbg6817 without success.

For dts, I have found a working (but old) NSS build by quarky. Extracted dtb file from it and then converted to dts. Resulting dts is quite hard to read, but it was enough to confirm that almost all gmac parameters are the same as for R7800 (“mtd-mac-address =” part is missing).

So, I have copied gmac parameters from R7800 dts, changed diff to zyxel_nbg6817 target and successfully compiled bin files. But after installing over stock firmware or via tftp method I am getting bootloop.

I am not a programmer in any way, so most likely I did something stupid)

Was it this commit by @quarky - this has a dts file that looks like it is worth trying for your zyxel

https://github.com/openwrt/openwrt/commit/795475842b34fc47ea4a0185c7fac6f77caba5ff

I have fashed a first nss build onto the EA8500. Problem is located in nss init phase. I'm going to debug this after christmas. The dts for the ipq8064 units is not correct and lacks a few things.

2 Likes

Let me know when it is ready for testing. :sunglasses:

Unluckily, the result is the same – bootloop after flashing. Can I ask you to built one test version for nbg6817 with quarky’s dts file in your build environment? I am starting to think, that it was a bad idea to build firmware using WSL.

you really need serial for this...

if it's used you need to confirm this is coded to support APPSBLENV mtd in addition to 'art'...

Did you remove;

> 	device_type = "network"; ?

For the ea8500 and probably a few more you can't set mtd-mac-address from art, but the fix is easy I already corrected the code in nss_gmac_ctrl.c. I will create a patch file for nss-gmac, I also updated the dts with a few corrections. I did a quick test on my ea8500 wan/lan had no issues, haven't done a performance test yet, will run some nat perfs tonight.

ACwifidude, should the pull reuest go to your branch or ansuels? Who is going to maintain the nss branch?

1 Like

I have tried both, with and without "network".
Looks like the problem is in MAC address. I have found an USB to Serial dongle and disassembled my NBG6871. The output repeats in a loop:

1 Like

To address the boot loop because of the wrong / missing MAC address there is this patch:

Works fine on my NBG6817. I copied and pasted the gmac parts over from the R7800 and it works.

1 Like

Can confirm, this is almost the same fix, that I created, with the exception that I used !IS_ERR_OR_NULL, to check the return.

@drbrains @KONG - appreciate it - I’ll include it in today’s build

There are multiple NSS branches - my goal is to consolidate everyone’s great work in to my github so that we can share best practices and maximize the potential of all ipq806x devices. :sunglasses:

Thank you for assistance!

With R7800 gmac config and mac fix NBG6817 firmware compiled and booted successfully.
But there still is one "Mac1 unit failed" error though.
Will test it tonight.