Ipq806x NSS build (Netgear R7800 / TP-Link C2600 / Linksys EA8500)

@ACwifidude, I was trying to make a new build this morning of the 22.03 branch with your patches included and ran into a snag. The 999-01a-qca-nss-ecm-support-CORE.patch threw an error that it could not be applied. Looking at the newest changes made to 22.03 it looks like this has changed the file that is to be patched. kernel: remove obsolete netfilter tcp window size check... I'm not sure what to fix, so I thought I'd let you know. Thanks.


I thought I was the only one! Thank you for mentioning this, I was about to go crazy.

1 Like

Thanks for the heads up. I’ll probably have time to build next week so I’ll evaluate the change and see how I can get the patch to work again.


After 6 days uptime i've made it reboot, the culprit? 2.4ghz wifi :wink: (i had it on ac80 only previously)

I recommend a reboot schedule every 3 days or so as past the third day's mark the avail. ram dropped slightly to 25MB.

Other than that, all good.

1 Like

Works fine on a Asus OnHub mesh node. Thanks a lot!


Any chance for meraki mr42?

1 Like

@altuntepe @M10 Feel free to take a look at the NSS patch for the different device .dts files.

I don’t personally have those devices so I would need someone to figure out for their device how to change that devices parameters to get NSS to work (and test it).

As an example the change could be as small as changing a couple lines like this to get your devices to work, just need someone to make some adjustments and load firmware with those changes to test it out:

--- a/arch/arm/boot/dts/qcom-ipq8064-r7500.dts
+++ b/arch/arm/boot/dts/qcom-ipq8064-r7500.dts
@@ -258,6 +258,9 @@

 &gmac1 {
 	status = "okay";
+	qcom,phy-mdio-addr = <4>;
+	qcom,poll-required = <0>;
+	qcom,rgmii-delay = <1>;
 	phy-mode = "rgmii";
 	qcom,id = <1>;

@@ -275,6 +278,9 @@

 &gmac2 {
 	status = "okay";
+	qcom,phy-mdio-addr = <0>;
+	qcom,poll-required = <0>;
+	qcom,rgmii-delay = <0>;
 	phy-mode = "sgmii";
 	qcom,id = <2>;
1 Like

I'll be in home before holidays soni can play with my : nokia ac400i, linksys ea7500 v1,trendnet tdw-827dru r1.0 , meraki mr42.


Both of my mr42 arrived yesterday, I'm just getting Openwrt installed and then one of them can be used for testing NSS.

1 Like

Just got fiber installed at my house. Now I have the ISP "horsepower" to run ipq806x and the max it can give. Speed test results look good!

R7800 with NSS wired speeds (using default build settings, no NSS SQM):


Just tried to update my old stable nss firmware on Asrock G10 with master firmware with new NSS-driver and bricked my router. It boots up, but no connection is made by wire or wireless. Reset doesn't help at all, it just boots and that's it. I guess it's time to order a uart adapter. Can someone recommend a good uart for linux? I'm gonna order it from aliexpress.

I found master can be a little finicky with startup settings that use to work with 22.03. As an example I found master does not like turning off the firewall on the access points during start up as an example - I had to tftp my two R7800's access points to get them back after that failure. Haha.

The reset button takes at least 10 seconds of pressing with a paperclip to fully reset the router. If that doesn't work than uart is the way to go!

I was looking in to this issue today. We'll have to find a better long term fix. Both master and 22.03 have this commit. As far as a short term fix I found that master rebuilt nicely after a "git revert" of that commit and a make clean. 22.03 should be the same (haven't tried but will try either today or tomorrow).

I was able to successfully build by removing the references to nf_ct_tcp_no_window_check from the patch (0008-frontends-drop-use-of-static-be_liberal-and-no_windo.patch) which "fixed" the issue for me.

I was working on the assumption that, given the original patch was deemed to be obsolete and of little value, then not having it wasn't going to adversely impact. I don't know if this is the best approach or not, but I've not seen any adverse effects in the three days I've been running with the changes and can still get close to a 1GB on a wired connection, although upstream for me is only 50Mbps so I'm a little jealous by your early speed test results :slight_smile:

1 Like

Congrats on the fiber! Here's hoping someday I get the opportunity.

1 Like

Ok. I'm trying that approach now with 22.03 to see if it will build. The other thing I came across is that the QCA repository address has changed as of April 1st as mentioned here

I found the location and manually changed the addresses as needed and am able to download the nss files again as it was giving an error before.

1 Like

That didn't work for me. It threw another error in regards to 999-07g-vlan-u64stats.patch. I tried without that patch but it didn't like that either. I will just wait patiently for a fix from those more knowledgeable than myself. I have a working version from before that is running fine. For my scenario, I find that 22.03 works better than master. Samba4 under master just isn't as smooth and quick as it is in 22.03 for me.

Do you still see those NSS TX failed with error: NSS_TX_FAILURE_TOO_SHORT errors?

acfiwidude, the kernel version 5.15, does not appear to download software?


tested the new 5.15 repo on my R7800 and EA8500, both working fine.

btw, missing Software button in System Menu,
I have to add CONFIG_PACKAGE_luci-app-opkg=y in diffconfig file, manually,
or add CONFIG_PACKAGE_luci=y, then CONFIG_PACKAGE_luci-app-opkg=y will be set auto.