Ipq806x NSS build (Netgear R7800 / TP-Link C2600 / Linksys EA8500)

i wrote to @Ansuel , the only problem i see is that he is creating magics on ipq807, 5.15 and DSA, but for sure he can sort this out.. also because if pppoe is broken for ipq806 easily it's also broken for ipq807 (is it?)

1 Like

You need to take the common sense approach by going back to the OEM firmware. If no improvement is seen, your device may have some hardware issue.

One last (futile :slight_smile: ) possibility: disconnect all devices from your LAN ports and try the WIFI speed test again. You can also try to temporarily disable the 2.4 GHz radio.

3 Likes

The only way to get back to OEM is TFTP right?

1 Like

By all accounts your settings look good. Either there is one setting that is off somewhere, there is a bug in the software (OpenWrt or NSS patches), or something is up with your r7800.

If I were in your shoes I would do the following:

  1. OpenWrt- reset all settings to default, restart. Apply minimal 80Mhz settings with wpa2 (no other clients attached) and test.

If that doesn’t give you 500mbps+ on iperf3 with multiple streams…..

  1. tftp to stock firmware and test iperf3.

If stock firmware doesn’t get you full speed then there is an issue with your router. If it does give you full speed there is a bug somewhere with OpenWrt and/or NSS.

2 Likes

think that even some neighbor has joined your wifi frequency or nearby and is causing that speed drop.
With version 22.02 of awifidude I actually get almost wan, 300/500 mbits

I wanted to say that the wifi speed of me is close to the maximum of the wan line which is 300/900 mbits. I get 300/500 mbits approx, but my mobile is only 2x2 mime and connects at 800mbits, so it would be impossible to reach the maximum wan on my WiFi. You should look at your mobile to see what speed it has negotiated with the router, the same is true for your limitation.

:innocent: :innocent: :innocent: we are following immediately

Updated the master build today. Removed bcp38. Otherwise just a simple rebase off master.

2 Likes

Here are my findings. I've installed your Master build from Today without keeping any settings. Configured WAN PPPoE and setup utterly new wireless as below:


config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '5g'
	option htmode 'VHT80'
	option channel 'auto'
	option txpower '20'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'psk2+ccmp'
	option key '********'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

No device connected via LAN / WIFI other than the one below.
Here are the results:

Notebook via LAN: https://www.speedtest.net/result/13493224356
Notebook via WIFI ( channel 149, 5GHz, 866/866 (Mbps), 1m next to the router): https://www.speedtest.net/result/13493239041
Mobile phone via WIFI ( 866 Mbps , next to the router ): https://www.speedtest.net/result/a/8577122831

Iperf3 where notebook via LAN was a server:

[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-30.01  sec   912 MBytes   255 Mbits/sec                  sender
[  5]   0.00-30.01  sec  912 MBytes  255 Mbits/sec                  receiver

I see no difference...

VHT160 on channel 104 (5.520 GHz) and iperf test between notebook LAN and Mobile Wifi (1,7GHz):

[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-30.01  sec   930 MBytes   260 Mbits/sec                  sender
[  5]   0.00-30.01  sec  930 MBytes  260 Mbits/sec                  receiver

Not better... it is only better when iperf with my NAS, but it doesn't matter.

Time for speedtest on VHT160 and 1,7GHz Mobile: 113/95 - sucks.

Now I'm going to install OEM firmware to test.

EDIT:

I can't see any difference with OEM software. Iperf3 between PC and phone is the same around 250mbit. The only change I can see now is that my notebook can run a speed test with 350mbit over wifi, while for the other 2 phones, it is still a max 150Mbit.
Should I send it for the guarantee? I have 1 month to do x) If yes, what should I say and how to proof?

EDIT2:
I have TP-LINK Archer AX1500, so I've plugged it and got the same results speed test and iperf. :open_mouth: now it looks it is not my netgear problem but? but what?!

Only notebook got 'proper' (still not max) speed test over wifi and archer: https://www.speedtest.net/result/13493578892
anyway still iperf is same shit when on Archer...

Did you take the patch from the robi's ipq807x repo?

You may want to watch the 5ghz radio bit rate (reported on the luci status and network->wireless pages) - changes as your wireless devices connect or are disconnected.

For example, my R7800's 5ghz radio will have a bit rate of 866mbit with my desktop and tablet connected but it drops to 500 - 600Mbit when my phone is connected.

I now use 2.4ghz for the phone as my priority is LAN throughput to the desktop.

Mmmv,
M.

We are discussing my case here for quite a bit and everything I think is explained above. I'm disappointed and have no clue, why by wireless next to the router I can't get proper speeds over iperf / speed test and different router / configuration :confused: and it is not only 1 device, but 2 phones with latest android... flagship phones....

Based on your findings with both OEM and OpenWRT, I believe it’s safe to say your issue is hardware related. Unfortunate for sure, but I’m not sure what else there is to say about it.

eghm but with both routers? It sounds impossible.. more like phone issues, but it's very strange it happens on both devices and two different routers :frowning:

since it's definitely not related with this nss build, i please you to open a specific topic on your problem. Thanks, this should be dedicated to @ACwifidude 's NSS builds and related issues

2 Likes

I guess what I’m implying is that this thread is about the NSS build, and at this point I think it’s safe to assume your issue is unrelated to this build… so perhaps a separate thread in the hardware section would be more appropriate to get better answers.

Simple reason: You're too close to Russia!. Too much of their electronic jamming warfare j/k

C&R partnership to turn the world up side down, reverting us to the Cavemen era. We NSS people will return PPPoE back to its sanity.

1 Like

@ACwifidude
I tried to back pppoe offload and add ds-lite offload in master.
please review pull request.

2 Likes

The pppoe patch is slightly modified from the 5.4 (to get it to compile). I have no way of testing it so…. it compiled but wasn’t able to test it / troubleshoot if it worked.

@tishipp appreciate it! Do the patches work for you?

1 Like

have you modified pppoe then?? I can do the test if you want.

yes please confirm there is a try to fix pppoe, tomorrow morning i can build and test :slight_smile: