IPQ40xx target & Single NIC devices

I wish I had found this thread earlier, could have saved many hours. I have submitted an update to the MR33 page to show this.

Firmware: OpenWrt 19.07.4 r11208-ce6496d796 / LuCI openwrt-19.07 branch git-20.310.50568-7b1b82d
Kernel: 4.14.195

At the very least the documentation on https://openwrt.org/toh/meraki/mr33 needs to be updated with VLANs listed in the "Unsupported Features" section.

1 Like

Does anyone have any new information about the issue with VLANs, especially with the MR33, or if there was any progress made in the last few months?

The changelog for 19.07.4 mentions a fix for VLANs on this target, is it related somehow?

ipq40xx: fix ethernet vlan double tagging (+193)

[OpenWrt Wiki] OpenWrt v19.07.4 Changelog

I'm on MR33 & stable OpenWrt v19.07.6 Changelog

I did a quick test adding eth0.x but could not get it to work, it receives some packages on the interface but does not send anything out. I have not tested with the trunk.

Looking at the git code changes, there are no specific changes for mr33 & ipq40xx besides some i2c that I'm not sure if they are related.

As AP is the main WiFi for my home network, I did not want to test more, but I have another one that is pending for boot loader downgrade and OpenWRT liberation, and I will have spare to do more tests if it's needed and play with it.

Cheers,

I wanted to use VLANs to have seperate networks for IoT, guest, etc. Are you doing this somehow in your network?
How are you downgrading the bootloader?
Thanks for the feedback!

Hi Sergio,

I do love the speeds of MR33, and the lack of VLAN is a bit downside but I can't rewrite or contribute to the code yet :wink: and I'm grateful to all developers that made OpenWRT possible on MR33 because it's still very reliable and does support multi SSID without VLANs.

For example, I run three SSID's WiD, KIDs, DEV on a flat network, KIDs is auto-down/up on schedule when it's time for a rest. I do not run any wifi IoT yet only a wired LAN bridge but have a few MR16,18,24 that do supports VLANs and pair well with my router OpenWRT/MX60 and most of my VLAN ports are directly connected to a MacMini as VM host and to a secondary AP for my garage(workshop).

For MR33 with multi SSID, it should be possible to divide the SSID across the three radio interfaces and add isolation with firewall rules, but it's a trade-off. Actually right now I do not use radio0 - Qualcomm Atheros QCA9887 802.11bgnac because when I did measure the wifi speeds it was performing better without it. But have not tested any isolation.

How are you downgrading the bootloader?

Most of the details are here

Cheers,

For VLAN to not work in MR33 is this driver specific or hardware config or both?

Looking here (mind this may be hardware-specific) ESS-SWITCH config and the MR33 config they look completely different.

The "IPQ4xx Ethernet Analysis" article ess is different and on different addresses:

 ess-switch@c000000 {
        compatible = "qcom,ess-switch";
        reg = <0xc000000 0x80000>; /* 512KB */
        switch_access_mode = "local bus";
        resets = <&gcc ESS_RESET>, <&gcc ESS_MAC1_CLK_DIS>, \
                <&gcc ESS_MAC2_CLK_DIS>, <&gcc ESS_MAC3_CLK_DIS>, \
                <&gcc ESS_MAC4_CLK_DIS>, <&gcc ESS_MAC5_CLK_DIS>;
        reset-names = "ess_rst","ess_mac1_clk_dis", \
                "ess_mac2_clk_dis","ess_mac3_clk_dis", \
                "ess_mac4_clk_dis", "ess_mac5_clk_dis";
        clocks = <&gcc GCC_ESS_CLK>;
        clock-names = "ess_clk";
        switch_cpu_bmp = <0x1>;  /* cpu port bitmap */
        switch_lan_bmp = <0x1e>; /* lan port bitmap */
        switch_wan_bmp = <0x20>; /* wan port bitmap */
};

MR33:

 ess-switch@c000000 {
	switch_mac_mode = <0x3>; /* mac mode for RGMII RMII */
	switch_lan_bmp = <0x0>; /* lan port bitmap */
	switch_wan_bmp = <0x10>; /* wan port bitmap */
};

I guess ess-switch config is not the same and depends on the PHY chip used in MR33 AR8035?

Edit: Disregard the ESS above it's for ADM6996L this is switch controller It is not single-port "dumb" PHY

Best regards,

If there is anything i can check / test / verify please let me know. I have 2 unlocked MR33 here to test on.

You could check what the current state is. Is incoming vlan tagged traffic working? Is outgoing vlan tagged traffic working?

Hi,

I'm curious, I want to use an aruba 303 that also have de Qualcomm IPQ4029 and has also good memory and flash. I want to use it with vlans, is this issue and Qualcomm IPQ4029 issue, or only in an MR33?

Its the same SoC, but you can use the DSA PR and have the working VLAN-s.
AP303 is already converted there

1 Like

Driver-level VLANs are working fine on my AP-303, which is running stable OpenWrt 21.02.x.
Neither swconfig nor DSA patches are required.

Good to hear.I hope to buy the aruba ap11and play with it the vlans , and does bluetooth also work?

ok, is the 303H also converted?

What do you mean wirth DSA PR? Is this another image?

I dont think that 303H was converted.

DSA PR is here:

I got issues with the vlans with the cpus en ehternetports and vlans . The devices has 2 cpu's and 4 ethernet ports. In openwrt eth0 on the fysical device (POE) is the wan port. So the wan port should be the normal lan port , but with the vlans I can't solve it. So I hoped that maybe this issue is resolved also with this?

I have this issue posted here

I don't really understand, but IPQ40xx only has one 1Gbit Full duplex CPU ethernet uplink, everything user-facing is just the switch interfaces.

I am just telling you that with DSA VLAN-s work fine even on multiport devices

ok. Is it possible to have the patch also for the 303h applied?

Sure, anybody can contribute to the conversion list

Hi,

I'm trying on my 303h the same, but de dhcp request doesn't work. Do you have an example with driver-level vlans?

here is the config I use. This works on my older aruba ap-105

root@OpenWrt:/etc/init.d# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd41:d718:0624::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.199.199'
	option netmask '255.255.255.0'
	option gateway '192.168.199.254'
	option ip6assign '60'
	list dns '192.168.180.254'
	option delegate '0'

config device
	option name 'br-vlan10'
	option type 'bridge'
	option ipv6 '0'
	list ports 'et1.10'

config interface 'vlan10'
	option proto 'none'
	option device 'br-vlan10'
	option delegate '0'

I cannot say anything about the 303h.
This is my config for the AP11/AP-303 (the model without 'h'):


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdXX:XXXX:XXXX::/48'

config device
	option name 'eth0.1'
	option type '8021q'
	option macaddr 'XX:XX:XX:XX:XX:fe'
	option ifname 'eth0'
	option vid '1'

config device
	option name 'eth0.2'
	option type '8021q'
	option macaddr 'XX:XX:XX:XX:XX:ff'
	option ifname 'eth0'
	option vid '2'

config device
	option name 'br-lan'
	option type 'bridge'
	option macaddr 'XX:XX:XX:XX:XX:fe'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr 'ddd.ddd.ddd.ddd'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'