Ipq40xx multiple wan ports

i have wan and wanb on the zyxel 6617, now i want create anothert wan, how i should do that? that's my config

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'
	option metric '10'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 2 3 4'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t 1 5'

config interface 'wanb'
	option ifname 'eth0.2'
	option proto 'dhcp'
	option metric '20'

on ipq40xx platform, by qualcomm's driver, switch will auto tag vlan1 to traffic which from lan (port 1 2 3 4),and tag vlan2 to traffic which from wan (port 5).
that mean the vlan id 2 has been used by switch.

you can try associate another vlan id to wanb.

if you can complie openwrt yourself, then this patch is usefull for you.
https://drive.google.com/file/d/1syq4NccB_2RJ3N_MnQHxs441LC-omb-V/view?usp=sharing