IPQ4019 Fritz!Box 7530 no 2GHz

Hi@all,

I've successfully installed OpenWrt for FritzBox 7530.
Everything works fine but enabling 2,4GHz AP doesn't work.
Unlike this there is no problem with 5GHz at all. But activating 2,4 only shows Bitrate: ? Mbit/s

Is there some way to fix that? I know it worked before in the past for like 1 day.

Cheers

/etc/config/network
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.128.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '9.9.9.9'
	list dns '1.1.1.1'
cat /etc/config/wireless
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option channel 'auto'
	option band '2g'
	option cell_density '1'
	option htmode 'HT20'
	option country 'DE'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option country 'DE'
	option cell_density '0'

config wifi-iface 'wifinet0'
	option device 'radio1'
	option mode 'ap'
	option ssid 'WiFi5SSID'
	option encryption 'sae'
	option key 'WiFi5Key'
	option network 'lan'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid 'WiFI2SSID'
	option encryption 'psk2'
	option key 'WiFi2Key'
	option network 'lan'
logread
Mon Mar  4 08:50:59 2024 daemon.notice netifd: Wireless device 'radio0' is now down
Mon Mar  4 08:51:08 2024 daemon.notice netifd: radio0 (19006): WARNING: Variable 'data' does not exist or is not an array/object
Mon Mar  4 08:51:09 2024 daemon.notice hostapd: Set new config for phy phy0:
Mon Mar  4 08:51:09 2024 daemon.notice wpa_supplicant[1131]: Set new config for phy phy0
Mon Mar  4 08:51:09 2024 daemon.notice wpa_supplicant[1131]: Set new config for phy phy0
Mon Mar  4 08:51:09 2024 daemon.notice hostapd: Set new config for phy phy0: /var/run/hostapd-phy0.conf
Mon Mar  4 08:51:09 2024 daemon.notice hostapd: Restart interface for phy phy0
Mon Mar  4 08:51:09 2024 daemon.notice hostapd: Configuration file: data: driver=nl80211 logger_syslog=127 logger_syslog_level=2 logger_stdout=127 logger_stdout_level=2 country_code=DE ieee80211d=1 hw_mode=g supported_rates=60 90 120 180 240 360 480 540 basic_rates=60 120 240 beacon_int=100 #num_global_macaddr=1 ieee80211n=1 ht_coex=0 ht_capab=[LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][MAX-AMSDU-7935][DSSS_CCK-40] channel=acs_survey  interface=phy0-ap0 bssid=48:5d:35:ac:7b:92 ctrl_interface=/var/run/hostapd ap_isolate=1 bss_load_update_period=60 chan_util_avg_period=600 disassoc_low_ack=1 skip_inactivity_poll=0 preamble=1 wmm_enabled=1 ignore_broadcast_ssid=0 uapsd_advertisement_enabled=1 utf8_ssid=1 multi_ap=0 wpa_passphrase=WiFi2Key wpa_psk_file=/var/run/hostapd-phy0-ap0.psk auth_algs=1 wpa=2 wpa_pairwise=CCMP ssid=WiFi2SSID bridge=br-lan wds_bridge= snoop_iface=br-lan wpa_disable_eapol_key_retries=0 wpa_key_mgmt=WPA-PSK okc=0 disable_pmksa_caching=1 dynamic_vlan=0 vlan_naming=1 vlan_no_bridge=1 vlan_fil
Mon Mar  4 08:51:11 2024 kern.warn kernel: [350782.331741] ath10k_ahb a000000.wifi: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
Mon Mar  4 08:51:11 2024 kern.warn kernel: [350782.331815] ath10k_ahb a000000.wifi: msdu-desc: 2500  skid: 32
Mon Mar  4 08:51:11 2024 kern.info kernel: [350782.366549] ath10k_ahb a000000.wifi: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
Mon Mar  4 08:51:11 2024 kern.info kernel: [350782.370199] ath10k_ahb a000000.wifi: wmi print 'free: 53252 iram: 13432 sram: 35752'
Mon Mar  4 08:51:11 2024 kern.info kernel: [350782.650026] ath10k_ahb a000000.wifi: rts threshold -1
Mon Mar  4 08:51:11 2024 kern.warn kernel: [350782.652151] ath10k_ahb a000000.wifi: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4
Mon Mar  4 08:51:11 2024 kern.info kernel: [350782.664996] br-lan: port 6(phy0-ap0) entered blocking state
Mon Mar  4 08:51:11 2024 kern.info kernel: [350782.665397] br-lan: port 6(phy0-ap0) entered disabled state
Mon Mar  4 08:51:11 2024 kern.info kernel: [350782.672332] device phy0-ap0 entered promiscuous mode
Mon Mar  4 08:51:11 2024 daemon.notice hostapd: phy0-ap0: interface state UNINITIALIZED->COUNTRY_UPDATE
Mon Mar  4 08:51:11 2024 daemon.notice hostapd: ACS: Automatic channel selection started, this may take a bit
Mon Mar  4 08:51:11 2024 kern.info kernel: [350782.680060] device phy0-ap0 left promiscuous mode
Mon Mar  4 08:51:11 2024 kern.info kernel: [350782.682025] br-lan: port 6(phy0-ap0) entered disabled state
Mon Mar  4 08:51:11 2024 daemon.notice hostapd: phy0-ap0: interface state COUNTRY_UPDATE->ACS
Mon Mar  4 08:51:11 2024 daemon.notice hostapd: phy0-ap0: ACS-STARTED
Mon Mar  4 08:51:11 2024 kern.info kernel: [350782.752404] br-lan: port 6(phy0-ap0) entered blocking state
Mon Mar  4 08:51:11 2024 kern.info kernel: [350782.752486] br-lan: port 6(phy0-ap0) entered disabled state
Mon Mar  4 08:51:11 2024 kern.info kernel: [350782.757864] device phy0-ap0 entered promiscuous mode
Mon Mar  4 08:51:11 2024 daemon.notice netifd: Wireless device 'radio0' is now up

Are clients connected to the AP? If not, then this is the intended behavior.

No there are not. It doesn‘t even show up at all in WiFi-Scans. SSID is visible.

In wireless overview it says also —-/66 dBm where my 5GHz has a value (-93/-110 dBm).

Same thing - no clients connected. This is how it looks like on mine with no clients connected to the 5GHz AP:

It might also be due to automatic channel selection - what happens if you manually select a channel for the 2.4GHz WiFi?

OK, weird. Though I could compore both networks.

Nothing - same thing. WiFi won‘t show up anywhere :confused:

Hm...your 2G config also has cell_density set to 1. What happens if you set it to 0?

My working config (I don't remember why I need to allow legacy rates, but there was a reason for it - maybe some old IoT device?).

onfig wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option band '2g'
	option htmode 'HT20'
	option country 'AT'
	option cell_density '0'
	option legacy_rates '1'
	option channel '8'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'xxxxxxxxxxx'
	option encryption 'psk2'
	option key 'xxxxxxxxxxxx'
	option dtim_period '3'
	option max_inactivity '86400'
	option disassoc_low_ack '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option band '5g'
	option htmode 'VHT80'
	option country 'AT'
	option channel '52'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'xxxxxxxxxxx'
	option encryption 'psk2'
	option key 'xxxxxxxxxxxxxxx'
	option dtim_period '3'
	option max_inactivity '86400'
	option disassoc_low_ack '0'

Unfortunatelly setting cell density to disabled doesn‘t change anything. I triyed legacy options too, but with no success either :confused:

push
Nobody has got an idea on how to solve?

I'm, clearly, confused; sorry about that.

Snip your wireless page and redact personal info but include wireless clients.

Also snip part of the interface page: just the red and green rectangles. I do not need the stats.

Well.. me too.

I was just creating a new wifi network for showing that no client is able to even see the ssid but.. out of the sudden it works like a charme.

I didn‘t change anything :face_with_peeking_eye:

But hey, it works. Thanks for your help :slight_smile:

1 Like

I'll take the credit! :rofl:

It was probably just not showing up because it had to do to a clear channel check for DFS.
All things being equal 'auto' in channel selections will warn all clients where it is going if interference is possible, move the AP's channel to a clear channel and reestablish connectivity.
Unless you have a great reason not to use 'auto' just know it might take around 10 minutes to ensure it will not interfere with airport or, more commonly, weather radar and without 'auto' it cannot move and just fails.

Anyway to close the topic:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.