Ipad ios12.5.7 cannot connect


my iPad used to connect to my newly installed openwrt23 router, until I tested it again today.

last week I had a problem with the same iPad connecting to the router, and I include a link to the thread:

It is a bit strange because the only message I get is: incorrect password for the Wi-Fi network. I checked the system logs, and there are no entries in it with my iPad Mac address. I deleted the network from my iPad, and I did it again, I even copied it from the password from the Lula Wi-Fi interface page using another devuce. yet messages the same incorrect password.

Myother Apple devices can connect without any problems.

The iPad can connect with the Wi-Fi 5 GHz. Which is strange. The 5 ghz uses the same encryption as the 2.4 ghz (CCMP).

Any ideas?

Are you using by any chance wpa3?



Can you create another SSID with some simple password, like 123456qwert , and verify that ipad can join?

1 Like

I tried setting up a network called test with a passwd of testtest. I could not even get my iphone to join it - Or rather the iphone icon sat spinning forever, and openwrt said it was connected. In the end I rebooted the iphone: Even this prompted for the password again. This all went strange after I upgraded openwrt from 23 to the latest release :wink: I ran out of time in the end to further investigate, and I fly out somewhere tomorrow.

I will tether the ipad to my mobile hotspot on my iphone and watch Netflix over this. At least mobile data is reliable and faster (40 Mbits download) than my broadband connection (3 Mbits download).

They are rolling out fibre optic down my road right now - by hanging the cable along the 1st floor of the houses and securing it with cable ties and long nails. I kid you not - so perhaps I might get faster broadband in a few months. I will plug the openwrt box into it.

1 Like

Update: After bashing my head against the wall, I gave up.

I decided that my last test is to force "802.11g" on the 2.4ghz, and competition disable all the other standards.

I cannot find any reference to "802.11g" in openwrt , and not when I google.

Lula only has:

radio0 11n, Legacy
radio1 11n, 11ac, Legacy

I don't know which is 5ghz or 2.4ghz any more. Wifi was simpler 20 years.

Does Openwrt support 802.11g and how can I enable this?

Disabled radio1 ( I think it was 5ghz, but it is unclear)

Set radio0 to Legacy. ( I think this is 2.4ghz but again it's unclear)

Result: ipad can connect but bandwidth is about 2-4kbps.
My iphone connected to same ssid gets a good 13mbps.