IoT wlan - disable multicast and broadcast traffic?

I have a IOT device sniffing kwh used and sending that to my home assistant server.
The issue is that this device is running on power from the HAN-port on my fuse box port, and has a built in small battery/capacitor. This device needs to sleep between sending data, but multicast will keep it awake.

I've created a new IOT wlan (wireless lan).
I've tried to disable multicast support on the wlan1-1 device under network settings. Didn't help much.
Is this the correct way to disable multicast/broadcast messages on this network?
I believe that devices will still communicate to this wlan from other wlan's and thats why I don't see any improvement so far.

Multicast should be easier to disable, as long as you don't use ipv6 or any other applications which use it.
Broadcast is more difficult to limit, unless you can have only one device in the wireless network and statically assign the arp entries.

Hi, so far there is only one device on that wlan. But it's not going to stay that way. I don't use ipv6 locally, so should be fine to disable that too?
How do I proceed on disabling mutlicast, is it under device wlan1-1 as mentioned before? I

You could do that.

Where did you see that exactly? I am not sure I follow.

Hi, this is what I did yesterday;
network - interfaces - devices - wlan1-1 - configure : disabled ipv6 and multicast support.
My IoT device has been up and running steady for some 12 hours now, so might be that it did the trick.

Yeah, it looks like it. Verify it remains steady and then you could mark the topic as solved.