iOS 14 device no internet

Long story short

I've just setup my OpenWrt and for some reason, two devices running iOS 14 have no internet.

Long story, well... long

Hello, for a few days, I've been playing with the OpenWrt in order to replace my old router with a Raspberry Pi 4 running OpenWrt r16771-f726b37b68. Everything works as it should, except 2 out of 3 iOS devices. These two are an an iPhone and iPad running an iOS 14 (unlike the 1 iPad that works, which has iOS 12) and for some reason, even though they are successfully connected to the network and can locally communicate with them, they have no internet access (but I'm able to ping them from my PC and they can connect to my webserver).

Unfortunately my networking knowledge is almost non-existent and OpenWrt is very new for me, which is why I'm here. I did some googling about similar problems but almost always when they were related to an iOS 14, it was about some USB tethering which most definitely isn't my problem.

Setup

My setup is pretty straight forward, I have a router from an ISP in a bridge mode, on that I have my Raspberry Pi acting as a router, that is connected to the switch that branches across the whole house and to my Ubiquity AP onto which are all devices (those 3 iOS devices included) connected.

If someone wants a visual

ISP router
     \
 Raspberry Pi
       \
      switch
     ____|____________________________
     \ \ \ \ \                        \
     desktop, webserver, etc.     wireless AP
                            ___________|_______________________
                            \ \ \ \ \ \     \        \         \
                            laptop, etc.   iOS14    iOS14     iOS12

Configs

Most of the configs are left unchanged since I have no idea what they do. For now I've just set up wan connection where I used this blogpost as a start reference since my setup is almost the same down to USB-Ethernet connector.


Now for the configs:

/etc/config/network


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd5c:b242:8b85::/48'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.1.69'
	option netmask '255.255.255.0'
	option dns '1.1.1.1'
	option type 'bridge'
	option ifname 'eth0'

config interface 'wan'
	option ifname 'eth1'
	option proto 'pppoe'
	option username '**************'
	option password '*********'
	option peerdns '0'
	option ipv6 '0'

/etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'
	option port '553'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

/etc/config/firewall


config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'

config include
	option path '/etc/firewall.user'

Thank you in advance,
Mat5i6.

This is a non standard port. Delete it and restart the dhcp server.

2 Likes

Sorry for the late reply, got a bit busy week. Anyway, I just tried your solution and after a restart or two :smiley: it worked so thank you very much.
I still would like to know how that port get there when it's non standard as you say and I haven't touch that config, but I will leave it at that.

You must have accidentally changed that. The port setting is left empty to default 53.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.