Invalid Firmware Upload on Asus RT-N66U B1


This is my first attempt to install an OpenWRT firmware on a Asus RT-N66U B1 wireless router. I followed instructions on the Factory install: First-time installation on a device. I selected the file and proceeded with uploading but received a Invalid Firmware Upload message.

I was unable to find a troubleshoot guide on this particular issue. Any help would be much appreciated.


Try downgrading to an earlier firmware version from the asus support page before installing Openwrt.

Otherwise you could probably bypass the web GUI checks by using Asus recovery tools to install openwrt.


Before forcing the flashing, please ask yourself if you really want to use this device with OpenWrt, even if that means effectively losing WLAN functionality.

The above also applies for the ASUS RT-N66U, with the obvious caveat of s/RT-AC68U/RT-N66U/g and s/BCM4360/BCM4331/g.


Oh, thanks @slh. I am glad I didn't try to flash my RT-N66U then!

@kiekar: If you want to flash then you could have a look at AsusWRT-Merlin, DD-WRT. You may need to do some research to see how secure they are, or if hey are based on a recent kenrel and free form known vulnerabilities.

There are also some Tomato variants of firmware, such as AdvancedTomato--which has good looking interface really but it was last updated in May 2017, so will be vulnerable. There is also FreshTomato, which is currency an active project and recently released a beta, but I don't see a download there for RT-N66U. You could probably check with them.

The original firmware is recent (Version 2018/07/10) is there a reason you need to use custom?

1 Like

My asus router is behind a pfSense box. I would like to use some more customization such as vlans to seperate guest and iot from my secure wifi network

Then if vulnerability isn't a concern, then you could give AdvancedTomato a try.


Tried to install openwrt and advanced tomato using the asus restoration utility with no success. Each time I tried I received a message "The wireless router is not in rescue mode" even when the router was indicating it was by a slow flashing blue light. I even tried clearing the nvram but still no success. Any other thoughts.

I didn't try flashing OpenWrt on RT-AC66U, but I flashed AdvancedTomoato form the stock web interface. That was a while ago, but I don't remember any issues.

just follow this but use the asus rt 68u Open wrt,(replacing the tomato download) worked ok for me, as we know no WIFI but didnt bother me, will probably upgrade wrt 1900 if all works out well using wiregaurd

Thanks dinky for your reply.

I read the instructions but unfortunately the CFE browser does not load using

Setting your PC to stating IP such as and pinging gets you anything?

I did exactly that. When I pinged I received a reply back at

Can you access it via SSH then?

sorry i thought you were trying the RT68u, may it cant be done done that way on the RTN66u, sorry cant help more as im a newbie, but the RT68 is definitely working on OpenWRT

I decided to start from the beginning and this time I was able to get to the CFE Browser and upload the openwrt firmware.

I want to thank all of you for helping me finally get it uploaded.


1 Like

@kiekar If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

1 Like

Glad you got all up and running, im new to forum but i thought what i posted for tomato why cant it work for Open Wrt happy days


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.