Internet up on router, cannot access via LAN or WLAN

Hello

Linksys WRT3200ACM connected to DSL modem - no need for anything complicated, just basic internet setup.

I recently changed the wireless channels on both 2.4Ghz and 5Ghz to achieve better signal. After applying the 5Ghz adapter wouldn't come up, and I couldn't get internet on 2.4Ghz.

I updated from 19.04 to 19.07 to try and resolve issue and I now have both wireless adapters up OK although I still cannot get internet. I have reverted the wireless adapter config back to what it was (auto).

My WAN interface reports a public IP address and all seems well. I suspect some sort of weird VLAN/Firewall/bridge setting has changed somehow although I am a total noob and really am not sure what the configuration of either should be.

network:


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd4:acdb:d3bf::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.254'
	option ifname 'eth0.1'
	option igmp_snooping '1'
	option stp '1'
	option delegate '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '5t 3 2 1 0'

config dsl 'dsl'
	option annex 'b'
	option tone 'a'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t 4'
	option vid '101'

config interface 'WAN'
	option proto 'dhcp'
	option ifname 'eth1.101'

firewall:



config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option masq '1'
	option mtu_fix '1'
	option input 'ACCEPT'
	option forward 'ACCEPT'
	option output 'ACCEPT'
	option network 'WAN'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config include 'miniupnpd'
	option type 'script'
	option path '/usr/share/miniupnpd/firewall.include'
	option family 'any'
	option reload '1'

config rule
	option dest_port '80'
	option src 'wan'
	option name 'Allow-WAN-Web'
	option target 'ACCEPT'
	option dest 'lan'
	list proto 'tcp'
	option src_port '8080'

wireless


config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option channel 'auto'
	option htmode 'VHT80'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option key ''
	option ssid 'Yorkshire Pudding'
	option encryption 'psk2'
	option network 'lan'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option htmode 'HT40'
	option channel 'auto'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key ''
	option ssid 'Haggis'
	option encryption 'psk-mixed'

config wifi-device 'radio2'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option key ''
	option ssid 'Haggis'
	option encryption 'psk2'
	option disabled '1'


I would do a complete OpenWRT setting reset and start from scratch: keyword is „firstboot“: https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset

remember that on the 3200 you have a full functioning alternate partition in which you can also boot, if everything goes down the drain (check the device page for howto) and from there you can also reflash the first partition (where you currently have OpenWRT).

remember to not set a Wifi region on most 3200 devices manually, keep it default, as this otherwise easily conflicts with the 3200 chip internal hard-coded Wifi region and disables e.g. DFS wifi channels and reduces wifi transmit power as side effects.

Unfortunately I am without a computer that has an ethernet port at the moment so a reset isn't an option...

Turn it off/on 3x with the switch on the back side, that is one of the options to boot into the other partition.
As far as I remember that other partition (if that is still on stock firmware) shares the same config partition als the original firmware that formerly was there in the first partition. I am rather sure OpenWRT did not overwrite that stock config data.

It is at least worth a check, maybe your original Wifi is still there with the stock firmware in the other partition.
If not, just turn it off/on again 3x to boot back to your (broken) OpenWRT partition.

You posted twice the network configuration.

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*
1 Like

Thank you very much for your response, although I realised that as I was doing nothing fancy with my router other than basic internet/wifi I have reverted to stock firmware.

That's a handy bit of bash which I will certainly keep for future use, thank you!

I have updated my post to include the firewall config anyway just in case anyone was interested.