Internet repeater (or bridge) without depending on IPs from the source router

My current setup (a bit outdated):
TP-Link WR842Nd (with OpenWRT 21) as the main router for my net (2 laptops, tuner and an hdd),
Huawei e589 as my Internet router.

So, I have configured the repeater-bridge from the following website. It works. I set up 2 different networks (2 different names).

Unfortunately, now every device connected to the main router has an IP number from the Internet router. So, if it doesn't work too well, my whole net is broken.

I would like to have an independent network on my main router and use the Internet router only as a source of the Internet. So, if for example, something is wrong with the Internet access from e589, I could connect my phone and have Internet access from it - without relying on my phone as part of infrastructure to use my whole home net.

Is that possible at all? No WDS or 802.11s, please.

I've tried to find a solution on the Internet (and on this forum) but either I didn't search well or I didn't understand the found topics.

This is the routed client. It's very simple, it works like a regular router except that the connection to the Internet is wireless instead of wired. That wireless interface holds one IP on the "upstream" network. All the users are on a LAN network which has a different IP range and a local DHCP server.

This is the default configuration of OpenWrt except for setting up the wireless WAN connection. From a default configuration, edit the wan network and remove any Ethernet ports. The protocol should remain as DHCP client. There should be no devices listed. Then create a wifi client matching the band and encryption needed by the upstream network, and attach it to 'wan' on the wifi page.

1 Like

OK, So I did the following steps. Access to the Internet works. Thanks!

  1. reset router
  2. connect with the cable; set the laptop's IP to 192.168.1.100 in the properties for the Ethernet connection.
    Connect with the router; address: 192.168.1.1
  3. set up a password to the router
  4. Network/Wireless - add the main (home) network; don't forget about security - set up the key!
  5. Network/Wireless - scan and add a client to the net from the router with the Internet access
    The name of the new network will be "wwan".
    Create / Assign firewall zone: wan, wan6
  6. I had to reconnect from ethernet to wifi; the address is still the same 192.168.1.1
  7. Network/Interfaces
    WAN - device: choose the wireless network with the main wifi (should be wlan0-1)
    WAN6 - device: the same as above
    WWAN - device: choose the wifi network with the access to the Internet
    LAN (br-lan): IPv4 address: 192.168.2.1 - otherwise the Internet access will not work
  8. Restart your wifi connection on your laptop.
    You can connect to the router by using address: 192.168.2.1

Questions:

  1. Now, I can access the Internet router with the address 192.168.1.1 - I assume, it is correct?
  2. Should I add/change any additional configuration? For example, for the firewall?
  3. For some reason, now the addresses in the main net are like: 192.168.2.216, 192.168.2.228. What should I change in the main router, to allow it to assign addresses in better series like 100, 101, 102? I left the DHCP settings of the LAN interface with default values. The addresses should start with 100. But it doesn't work.

1 yes
2 no
3 the assigning is random, there's however an option to make in sequential.

Allocate IP sequentially under DHCP->advanced options.

1 Like

These settings work for me...

By default, addresses are chosen by hashing the device MAC address in a way that the "random" hash result is distributed throughout the allowed IP range. This has the advantage that a returning client will likely get the same IP address as long as no one else took it with the same MAC hash.

Access to devices on the LAN should be done by hostname whenever possible. An option host can be set up with only MAC and hostname. When that MAC requests a DHCP, the hostname it sends will be overridden by your setting. This is useful to give short unique DNS hostnames to your iOS or Android devices.

@frollic Thanks, I've checked it. Unfortunately, it didn't change anything.
@mk24 Thanks. But with the default settings (Internet from the Wan port of the device) the addresses are like 100, 101, 102. So, something is wrong.

I wouldn't care about the addresses but I think, it is a part of the deeper problem. All routers work together well but if I put the Internet router off, the main wifi net stops working. When I restarted the main router, it didn't even show its wifi net. I connected it to my laptop with an Ethernet cable. It showed, the radio was off. I tried to restart it with the "Restart" button. No success.