Internet only on WiFi but no on wired connections


I have TP-Link Archer C7v5 running OpenWRT 18.06.02. Most of the settings are the default ones, except the password and WiFi network settings where I had to activate the wireless interfaces and configure SSIDs, passwords, etc. There is DHCP server enabled by default I get connection details over it for both Wifi and wired connection.

On either WiFi networks(2.4 and 5GHz) I have internet, but if I connect to one of the LAN ports, I don't have connectivity - no ping nothing. I get IP, gateway etc, from the DHCP server. I can also reach the LUCI interface.

Also under "Active DHCP leases" in Status/Overview, I see the host name of my machine when it's connected over WiFi. But when I connect it over the wired LAN, the host name is shown as "?". However, the rest settings are ok - it has IP, MAC and lease time.

I'm sure it's something related to the configuration and it's really easy to setup, but I couldn't find the setting.


Have you confirmed that you disconnected WiFi on that test computer before connecting to the wired Ethernet?

1 Like

No ping to what? IP or domain? Can you ping the router itself? Can you ping an external IP (e.g. or from you PC?

Also could you confirm that you don't have manual DNS entered for your PC Ethernet card?


Yes, I did.

No ping to both - domain and IP, e.g. There is ping to the gateway:

$ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=0.328 ms
64 bytes from icmp_seq=2 ttl=64 time=0.287 ms
64 bytes from icmp_seq=3 ttl=64 time=0.264 ms
^[c64 bytes from icmp_seq=4 ttl=64 time=0.365 ms
64 bytes from icmp_seq=5 ttl=64 time=0.291 ms
--- ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4104ms
rtt min/avg/max/mdev = 0.264/0.307/0.365/0.035 ms

You're right that it's a local issue. I tried with another laptop and it had i-net through the same LAN port.

1 Like

Check the settings of your PC network card. Make sure you have no manual DNS entered there (or any other settings for that matter).


Ok, after finding out that the issue is in my laptop instead of the router, I deleted the Ethernet Connection profile(I'm running Linux Mint) and I have internet over wired connection now. I also flushed the DNS with '$ sudo /etc/init.d/dns-clean start' .

Thanks @Hegabo for the quick reply!


I'm glad I helped!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.