Internet not working

Provider-static ip with MAC address binding.
I got mi router 4a gigabit edition.
I used the stock firmware for two days, but then I decided to add functionality and switched to openwrt 21.02.1 using the exploit and it seems everything went well!
The problem is that now the Internet does not work for me. In openwrt, I only configured the wan interface by changing dhcp to static ip and registered ip, mask, gateway, dns provided by my provider. I contacted the technical support of the provider, and the specialist said that he did not see the mac address of the router on his equipment! To check, I connected my old serrcom router back and there were no problems with it, the provider's specialist said that he sees his poppy address, then I also connected the provider's cable directly to the laptop and everything was fine, the laptop's poppy address was displayed at the provider and the Internet worked. What am I doing with openwrt?

You could spoof the MAC address of the Sercomm router on your openwrt router. That should get around any filtering.

Openwrt has detailed logs, it’s likely recording what’s going on

Yes, I forgot to mention, but I tried to substitute the mac address of sercomm on the wan interface in openwrt but it didn't help, in the statistics of wan I see that the mac address really changed to mac from sercomm, but the Internet still does not work and the isp gateway does not ping either from owrt itself, not from my wifi connected laptop.

...I also looked at the system log through luci web, I didn’t see anything interesting there. I can post the log tomorrow if that helps.

A log would be interesting.

If you have the ip, netmask, dns and default gateway configured the same as the working router then there’s not much left.

Possibly a speed negotiation issue, which willl mean setting the port speed manually. Or could be a flaky Ethernet cable.

Also check the details on the openwrt build for your device to confirm the wan port isn’t being mapped to another port etc

It seems that something is wrong with link negotiation 10\100\1000 on the wan port.

When I insert the ISP cable into the connector, dmesg reports that the interface is up at 1Gbit, which is strange, actually physics from the 100mbit provider.

> kernel: [ 26.465783] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control off

In order to force the link to be limited to 100Mbps, I tried to remake the connector in my apartment using only two pairs of cables instead of four.
But this did not help, when connecting the dmesg cable, everything also displays 1Gbit link up instead of 100Mbps. In the LuCI web interface, I did not find how to force limit port speeds and therefore connected mirouter to my old working sercomm to install the ethtool package and change the speed of the wan port from 1Gb --> 100Mb forcibly.
Oddly enough, in this case, mirouter gets an ip address from the lan port of sercomm without any problems and distributes the Internet.

I added two entries to rc.local to set up negotiation and network restart.

> ethtool -s wan speed 100 duplex full autoneg off
> /etc/init.d/network restart

Now everything works) Guys, tell me, maybe there is a more elegant solution?

1 Like

What hardware (running openwrt) are you using? Make and model.

Is the upstream device actually only 100Mbps or are you referring to the speed of your service? What is the hardware that you have upstream?

ISP gives physical link - 100mbit. The tariff is also 100mbit.
Mirouter gbit edition with openwrt installed.

What hardware is installed above, at isp I have no idea

Just because you have a 100mbit subscription, doesn't mean the port can't be gigabit.

Port 100Mbps. I called the provider and clarified it.

1 Like

I found a bug for my problem and there is a workaround FS#3839

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.