Internet connexion suddenly stoped working on WAN interface

Hello,

It has been a couple years already that I run OpenWRT. I have my router connected to my ISP router directly through the WAN port (No bridging). This setup was working fine until a few days ago when suddenly the internet connexion stopped working on devices using my subnet. I ssh'd into the router and tried to ping 9.9.9.9 only to get Network unreachable. I tried connecting a device directly with the cable that my router is using and it was able to reach the internet.

I'm not sure where to look exactly as the config seems correct and hasn't been changed since it was working.

I can ping the ISP router with ping 192.168.1.1 and the ISP router DHCP gives me the address 192.168.1.51. I would greatly appreciate if someone could help me find other things I could look at to debug this issue

ip addr show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1508 qdisc mq state UP qlen 1024
    link/ether ... brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ea9f:80ff:fe1b:7ee8/64 scope link
       valid_lft forever preferred_lft forever
3: lan4@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether ... brd ff:ff:ff:ff:ff:ff
4: lan3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether ... brd ff:ff:ff:ff:ff:ff
5: lan2@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether ... brd ff:ff:ff:ff:ff:ff
6: lan1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether ... brd ff:ff:ff:ff:ff:ff
7: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether ... brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.51/24 brd 192.168.1.255 scope global wan
       valid_lft forever preferred_lft forever
    inet6 fe80::ea9f:80ff:fe1b:7ee8/64 scope link
       valid_lft forever preferred_lft forever
11: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether ... brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ea9f:80ff:fe1b:7ee8/64 scope link
       valid_lft forever preferred_lft forever
12: br-lan.1@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether ... brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.1/24 brd 192.168.2.255 scope global br-lan.1
       valid_lft forever preferred_lft forever
    inet6 fd51:4f6a:cd2e::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::ea9f:80ff:fe1b:7ee8/64 scope link
       valid_lft forever preferred_lft forever
13: br-lan.2@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether ... brd ff:ff:ff:ff:ff:ff
    inet 10.0.2.1/24 brd 10.0.2.255 scope global br-lan.2
       valid_lft forever preferred_lft forever
    inet6 fe80::ea9f:80ff:fe1b:7ee8/64 scope link
       valid_lft forever preferred_lft forever
14: br-lan.3@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether ... brd ff:ff:ff:ff:ff:ff
    inet 10.0.3.1/24 brd 10.0.3.255 scope global br-lan.3
       valid_lft forever preferred_lft forever
    inet6 fe80::ea9f:80ff:fe1b:7ee8/64 scope link
       valid_lft forever preferred_lft forever
15: br-lan.99@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether ... brd ff:ff:ff:ff:ff:ff
    inet 10.0.99.1/24 brd 10.0.99.255 scope global br-lan.99
       valid_lft forever preferred_lft forever
    inet6 fe80::ea9f:80ff:fe1b:7ee8/64 scope link
       valid_lft forever preferred_lft forever
17: phy0-ap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether ... brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ea9f:80ff:fe1b:7eea/64 scope link
       valid_lft forever preferred_lft forever
18: phy1-ap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether ... brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ea9f:80ff:fe1b:7ee9/64 scope link
       valid_lft forever preferred_lft forever

ip route show

10.0.2.0/24 dev br-lan.2 scope link  src 10.0.2.1
10.0.3.0/24 dev br-lan.3 scope link  src 10.0.3.1
10.0.99.0/24 dev br-lan.99 scope link  src 10.0.99.1
192.168.1.0/24 via 192.168.1.1 dev wan
192.168.2.0/24 dev br-lan.1 scope link  src 192.168.2.1

cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd51:4f6a:cd2e::/48'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.1'
	option force_link '0'
	option device 'br-lan.1'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option force_link '1'
	option broadcast '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1:t'
	list ports 'lan2:u*'
	list ports 'lan3:u*'
	list ports 'lan4:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '2'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '3'
	list ports 'lan1:t'

config interface 'VLAN2'
	option proto 'static'
	option device 'br-lan.2'
	option netmask '255.255.255.0'
	option ipaddr '10.0.2.1'

config interface 'VLAN3'
	option proto 'static'
	option device 'br-lan.3'
	option netmask '255.255.255.0'
	option ipaddr '10.0.3.1'

config bridge-vlan
	option device 'br-lan'
	option vlan '99'

config interface 'GUEST'
	option proto 'static'
	option device 'br-lan.99'
	option netmask '255.255.255.0'
	option ipaddr '10.0.99.1'

config route
	option interface 'wan'
	option target '192.168.1.1/24'
	option gateway '192.168.1.1'

Firewall settings:

Does the ISP router have connectivity?

can you access the isp router and try to test the internet connectivity from this router?

It seems to me that you are missing a default router on your Openwrt

the "ip route show" command should show something like this at the first line

default via 192.168.1.1 dev wan 

or "route -n"

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0     0        0 wan
1 Like

This route is not needed.
As mentioned earlier by @ncompact the default route is missing. This is usually advertised by DHCP.
A quick solution would be to manually add the default route:

config route
	option interface 'wan'
	option target '0.0.0.0/0'
	option gateway '192.168.1.1'
2 Likes

Been answered.

@ncompact yes the ISP router has correct connectivity. Thanks for pointing out the missing default route. I tried to run the following command to add it

ip route add default via 192.168.1.1 dev wan

But this results in the following error:

ip: RTNETLINK answers: Network unreachable

(I can still ping 192.168.1.1)

@trendy I applied your suggestion. Changed the target of the mentioned route to 0.0.0.0/0 and rebooted the router. This didn't work until I ran /etc/init.d/network restart but seems to work now. I can now see default via 192.168.1.1 dev wan src 192.168.1.51 in ip route show and have internet access again. Thank you very much for your precious help

This message, along with the fact that it doesn't work after reboot is worrying.
Can you reboot and send the output of logread and dmesg ?

Sure, here is the result for logread (cut before reboot)

Fri Apr 12 15:59:55 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.2) ...
Fri Apr 12 15:59:55 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.2) 10.0.2.116 ...
Fri Apr 12 15:59:56 2024 daemon.info hostapd: phy1-ap0: STA ... IEEE 802.11: associated (aid 1)
Fri Apr 12 15:59:56 2024 daemon.notice hostapd: phy1-ap0: AP-STA-CONNECTED ... auth_alg=open
Fri Apr 12 15:59:56 2024 daemon.info hostapd: phy1-ap0: STA ... WPA: pairwise key handshake completed (RSN)
Fri Apr 12 15:59:56 2024 daemon.notice hostapd: phy1-ap0: EAPOL-4WAY-HS-COMPLETED ...
Fri Apr 12 15:59:57 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.2) 10.0.2.173 ...
Fri Apr 12 15:59:57 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.2) 10.0.2.173 ...
Fri Apr 12 15:59:57 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.2) ...
Fri Apr 12 15:59:57 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.2) 10.0.2.116 ...
Fri Apr 12 15:59:57 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.2) 10.0.2.116 ...
Fri Apr 12 15:59:57 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.2) 10.0.2.116 ...
Fri Apr 12 15:59:58 2024 daemon.info hostapd: phy1-ap0: STA ... IEEE 802.11: authenticated
Fri Apr 12 16:00:02 2024 daemon.warn odhcpd[1910]: No default route present, overriding ra_lifetime!
Fri Apr 12 16:00:18 2024 daemon.warn odhcpd[1910]: No default route present, overriding ra_lifetime!
Fri Apr 12 16:00:37 2024 daemon.info hostapd: phy0-ap0: STA ... IEEE 802.11: associated (aid 3)
Fri Apr 12 16:00:37 2024 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED ... auth_alg=open
Fri Apr 12 16:00:37 2024 daemon.info hostapd: phy0-ap0: STA ... WPA: pairwise key handshake completed (RSN)
Fri Apr 12 16:00:37 2024 daemon.notice hostapd: phy0-ap0: EAPOL-4WAY-HS-COMPLETED ...
Fri Apr 12 16:00:37 2024 daemon.info hostapd: phy0-ap0: STA ... IEEE 802.11: authenticated
Fri Apr 12 16:00:38 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.2) 10.0.2.129 ...
Fri Apr 12 16:00:38 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.2) 10.0.2.129 ...

And here is dmesg

Could not include everything due to characters limitation
[    0.000271] CPU: Testing write buffer coherency: ok
[    0.000285] CPU0: Spectre v2: using BPIALL workaround
[    0.000289] pid_max: default: 32768 minimum: 301
[    0.000562] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.000569] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.001159] CPU0: thread -1, cpu 0, socket 0, mpidr 80000000
[    0.001407] Setting up static identity map for 0x100000 - 0x100060
[    0.001471] mvebu-soc-id: MVEBU SoC ID=0x6820, Rev=0xA
[    0.001535] mvebu-pmsu: Initializing Power Management Service Unit
[    0.001592] rcu: Hierarchical SRCU implementation.
[    0.001713] smp: Bringing up secondary CPUs ...
[    0.001854] Booting CPU 1
[    0.001964] CPU1: thread -1, cpu 1, socket 0, mpidr 80000001
[    0.001970] CPU1: Spectre v2: using BPIALL workaround
[    0.002015] smp: Brought up 1 node, 2 CPUs
[    0.002020] SMP: Total of 2 processors activated (3732.00 BogoMIPS).
[    0.002025] CPU: All CPU(s) started in SVC mode.
[    0.003810] VFP support v0.3: implementor 41 architecture 3 part 30 variant 9 rev 4
[    0.003853] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.003862] futex hash table entries: 512 (order: 3, 32768 bytes, linear)
[    0.003959] pinctrl core: initialized pinctrl subsystem
[    0.004490] NET: Registered PF_NETLINK/PF_ROUTE protocol family
[    0.004938] DMA: preallocated 256 KiB pool for atomic coherent allocations
[    0.005317] thermal_sys: Registered thermal governor 'step_wise'
[    0.005425] cpuidle: using governor ladder
[    0.005556] mvebu-pmsu: CPU hotplug support is currently broken on Armada 38x: disabling
[    0.005562] mvebu-pmsu: CPU idle is currently broken on Armada 38x: disabling
[    0.011850] cryptd: max_cpu_qlen set to 1000
[    0.012755] SCSI subsystem initialized
[    0.012819] libata version 3.00 loaded.
[    0.012886] usbcore: registered new interface driver usbfs
[    0.012920] usbcore: registered new interface driver hub
[    0.012935] usbcore: registered new device driver usb
[    0.013497] clocksource: Switched to clocksource arm_global_timer
[    0.013926] NET: Registered PF_INET protocol family
[    0.013997] IP idents hash table entries: 8192 (order: 4, 65536 bytes, linear)
[    0.014310] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 6144 bytes, linear)
[    0.014326] Table-perturb hash table entries: 65536 (order: 6, 262144 bytes, linear)
[    0.014333] TCP established hash table entries: 4096 (order: 2, 16384 bytes, linear)
[    0.014352] TCP bind hash table entries: 4096 (order: 3, 32768 bytes, linear)
[    0.014382] TCP: Hash tables configured (established 4096 bind 4096)
[    0.014425] UDP hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.014441] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.014532] NET: Registered PF_UNIX/PF_LOCAL protocol family
[    0.014547] PCI: CLS 0 bytes, default 64
[    0.015773] workingset: timestamp_bits=14 max_order=17 bucket_order=3
[    0.017818] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.017824] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.018385] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 250)
[    0.019369] armada-38x-pinctrl f1018000.pinctrl: registered pinctrl driver
[    0.019783] debugfs: Directory 'f1018100.gpio' with parent 'regmap' already present!
[    0.020022] debugfs: Directory 'f1018140.gpio' with parent 'regmap' already present!
[    0.020274] mvebu-pcie soc:pcie: host bridge /soc/pcie ranges:
[    0.020296] mvebu-pcie soc:pcie:      MEM 0x00f1080000..0x00f1081fff -> 0x0000080000
[    0.020310] mvebu-pcie soc:pcie:      MEM 0x00f1040000..0x00f1041fff -> 0x0000040000
[    0.020321] mvebu-pcie soc:pcie:      MEM 0x00f1044000..0x00f1045fff -> 0x0000044000
[    0.020331] mvebu-pcie soc:pcie:      MEM 0x00f1048000..0x00f1049fff -> 0x0000048000
[    0.020341] mvebu-pcie soc:pcie:      MEM 0xffffffffffffffff..0x00fffffffe -> 0x0100000000
[    0.020351] mvebu-pcie soc:pcie:       IO 0xffffffffffffffff..0x00fffffffe -> 0x0100000000
[    0.020361] mvebu-pcie soc:pcie:      MEM 0xffffffffffffffff..0x00fffffffe -> 0x0200000000
[    0.020370] mvebu-pcie soc:pcie:       IO 0xffffffffffffffff..0x00fffffffe -> 0x0200000000
[    0.020380] mvebu-pcie soc:pcie:      MEM 0xffffffffffffffff..0x00fffffffe -> 0x0300000000
[    0.020389] mvebu-pcie soc:pcie:       IO 0xffffffffffffffff..0x00fffffffe -> 0x0300000000
[    0.020399] mvebu-pcie soc:pcie:      MEM 0xffffffffffffffff..0x00fffffffe -> 0x0400000000
[    0.020406] mvebu-pcie soc:pcie:       IO 0xffffffffffffffff..0x00fffffffe -> 0x0400000000
[    0.020525] mvebu-pcie soc:pcie: PCI host bridge to bus 0000:00
[    0.020533] pci_bus 0000:00: root bus resource [bus 00-ff]
[    0.020540] pci_bus 0000:00: root bus resource [mem 0xf1080000-0xf1081fff] (bus address [0x00080000-0x00081fff])
[    0.020547] pci_bus 0000:00: root bus resource [mem 0xf1040000-0xf1041fff] (bus address [0x00040000-0x00041fff])
[    0.020552] pci_bus 0000:00: root bus resource [mem 0xf1044000-0xf1045fff] (bus address [0x00044000-0x00045fff])
[    0.020558] pci_bus 0000:00: root bus resource [mem 0xf1048000-0xf1049fff] (bus address [0x00048000-0x00049fff])
[    0.020563] pci_bus 0000:00: root bus resource [mem 0xe0000000-0xe7ffffff]
[    0.020567] pci_bus 0000:00: root bus resource [io  0x1000-0xeffff]
[    0.020637] pci 0000:00:01.0: [11ab:6820] type 01 class 0x060400
[    0.020768] pci 0000:00:02.0: [11ab:6820] type 01 class 0x060400
[    0.021436] PCI: bus0: Fast back to back transfers disabled
[    0.021442] pci 0000:00:01.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    0.021450] pci 0000:00:02.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    0.021507] pci 0000:01:00.0: [11ab:2b40] type 00 class 0x020000
[    0.021525] pci 0000:01:00.0: reg 0x10: [mem 0x40000000-0x401fffff 64bit pref]
[    0.021538] pci 0000:01:00.0: reg 0x18: [mem 0x40200000-0x402fffff 64bit pref]
[    0.021602] pci 0000:01:00.0: supports D1 D2
[    0.021607] pci 0000:01:00.0: PME# supported from D0 D1 D3hot D3cold
[    0.022309] PCI: bus1: Fast back to back transfers disabled
[    0.022315] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    0.022379] pci 0000:02:00.0: [11ab:2b40] type 00 class 0x020000
[    0.022399] pci 0000:02:00.0: reg 0x10: [mem 0x42000000-0x421fffff 64bit pref]
[    0.022413] pci 0000:02:00.0: reg 0x18: [mem 0x42200000-0x422fffff 64bit pref]
[    0.022503] pci 0000:02:00.0: supports D1 D2
[    0.022507] pci 0000:02:00.0: PME# supported from D0 D1 D3hot D3cold
[    0.022532] pci 0000:02:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:02.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
[    0.023228] PCI: bus2: Fast back to back transfers disabled
[    0.023233] pci_bus 0000:02: busn_res: [bus 02-ff] end is updated to 02
[    0.023259] pci 0000:00:01.0: BAR 8: assigned [mem 0xe0000000-0xe02fffff]
[    0.023267] pci 0000:00:02.0: BAR 8: assigned [mem 0xe0400000-0xe06fffff]
[    0.023274] pci 0000:01:00.0: BAR 0: assigned [mem 0xe0000000-0xe01fffff 64bit pref]
[    0.023284] pci 0000:01:00.0: BAR 2: assigned [mem 0xe0200000-0xe02fffff 64bit pref]
[    0.023294] pci 0000:00:01.0: PCI bridge to [bus 01]
[    0.023300] pci 0000:00:01.0:   bridge window [mem 0xe0000000-0xe02fffff]
[    0.023312] pci 0000:02:00.0: BAR 0: assigned [mem 0xe0400000-0xe05fffff 64bit pref]
[    0.023323] pci 0000:02:00.0: BAR 2: assigned [mem 0xe0600000-0xe06fffff 64bit pref]
[    0.023334] pci 0000:00:02.0: PCI bridge to [bus 02]
[    0.023339] pci 0000:00:02.0:   bridge window [mem 0xe0400000-0xe06fffff]
[    0.023590] mv_xor f1060800.xor: Marvell shared XOR driver
[    0.093835] mv_xor f1060800.xor: Marvell XOR (Descriptor Mode): ( xor cpy intr )
[    0.093973] mv_xor f1060900.xor: Marvell shared XOR driver
[    0.153823] mv_xor f1060900.xor: Marvell XOR (Descriptor Mode): ( xor cpy intr )
[    0.153998] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.154721] printk: console [ttyS0] disabled
[    0.174807] f1012000.serial: ttyS0 at MMIO 0xf1012000 (irq = 30, base_baud = 12500000) is a 16550A
[    1.261542] printk: console [ttyS0] enabled
[    1.267647] loop: module loaded
[    1.270811] Loading iSCSI transport class v2.0-870.
[    1.276650] ahci-mvebu f10a8000.sata: supply ahci not found, using dummy regulator
[    1.284331] ahci-mvebu f10a8000.sata: supply phy not found, using dummy regulator
[    1.291879] ahci-mvebu f10a8000.sata: supply target not found, using dummy regulator
[    1.299723] ahci-mvebu f10a8000.sata: AHCI 0001.0000 32 slots 2 ports 6 Gbps 0x3 impl platform mode
[    1.308819] ahci-mvebu f10a8000.sata: flags: 64bit ncq sntf led only pmp fbs pio slum part sxs
[    1.318058] scsi host0: ahci-mvebu
[    1.321753] scsi host1: ahci-mvebu
[    1.325253] ata1: SATA max UDMA/133 mmio [mem 0xf10a8000-0xf10a9fff] port 0x100 irq 49
[    1.333208] ata2: SATA max UDMA/133 mmio [mem 0xf10a8000-0xf10a9fff] port 0x180 irq 49
[    1.341668] nand: device found, Manufacturer ID: 0xef, Chip ID: 0xda
[    1.348065] nand: Winbond W29N02GV
[    1.351480] nand: 256 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[    1.359290] Bad block table found at page 131008, version 0x01
[    1.365475] Bad block table found at page 130944, version 0x01
[    1.371627] 11 fixed-partitions partitions found on MTD device pxa3xx_nand-0
[    1.378720] Creating 11 MTD partitions on "pxa3xx_nand-0":
[    1.384241] 0x000000000000-0x000000200000 : "u-boot"
[    1.389427] 0x000000200000-0x000000220000 : "u_env"
[    1.394512] 0x000000220000-0x000000260000 : "s_env"
[    1.399546] 0x0000007e0000-0x000000820000 : "devinfo"
[    1.404760] 0x000000820000-0x000000a00000 : "sysdiag"
[    1.409980] 0x000000a00000-0x000005a00000 : "kernel1"
[    1.415296] 0x000001000000-0x000005a00000 : "ubi"
[    1.420267] 0x000005a00000-0x00000aa00000 : "kernel2"
[    1.425585] 0x000006000000-0x00000aa00000 : "rootfs2"
[    1.430915] 0x00000aa00000-0x000010000000 : "syscfg"
[    1.436175] 0x000000260000-0x000000820000 : "unused_area"
[    1.444120] mv88e6085 f1072004.mdio-mii:00: switch 0x3520 detected: Marvell 88E6352, revision 1
[    1.463840] hwmon hwmon0: temp1_input not attached to any thermal zone
[    1.483835] hwmon hwmon1: temp1_input not attached to any thermal zone
[    1.503797] hwmon hwmon2: temp1_input not attached to any thermal zone
[    1.523790] hwmon hwmon3: temp1_input not attached to any thermal zone
[    1.542200] hwmon hwmon4: temp1_input not attached to any thermal zone
[    1.664650] ata1: SATA link down (SStatus 0 SControl 300)
[    1.672238] mvneta_bm f10c8000.bm: Buffer Manager for network controller enabled
[    1.679843] ata2: SATA link down (SStatus 0 SControl 300)
[    1.685708] mvneta f1070000.ethernet eth0: Using hardware mac address ...
[    1.693834] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    1.700394] ehci-pci: EHCI PCI platform driver
[    1.704885] ehci-platform: EHCI generic platform driver
[    1.710194] ehci-orion: EHCI orion driver
[    1.714298] orion-ehci f1058000.usb: EHCI Host Controller
[    1.719729] orion-ehci f1058000.usb: new USB bus registered, assigned bus number 1
[    1.727376] orion-ehci f1058000.usb: irq 46, io mem 0xf1058000
[    1.763555] orion-ehci f1058000.usb: USB 2.0 started, EHCI 1.00
[    1.769694] hub 1-0:1.0: USB hub found
[    1.773472] hub 1-0:1.0: 1 port detected
[    1.777805] usbcore: registered new interface driver usb-storage
[    1.783976] i2c_dev: i2c /dev entries driver
[    1.790902] orion_wdt: Initial timeout 171 sec
[    1.795564] sdhci: Secure Digital Host Controller Interface driver
[    1.801773] sdhci: Copyright(c) Pierre Ossman
[    1.806235] sdhci-pltfm: SDHCI platform and OF driver helper
[    1.815549] marvell-cesa f1090000.crypto: CESA device successfully registered
[    1.823238] NET: Registered PF_INET6 protocol family
[    1.828712] Segment Routing with IPv6
[    1.832408] In-situ OAM (IOAM) with IPv6
[    1.836400] NET: Registered PF_PACKET protocol family
[    1.836845] mmc0: SDHCI controller on f10d8000.sdhci [f10d8000.sdhci] using ADMA
[    1.841490] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    1.862098] 8021q: 802.1Q VLAN Support v1.8
[    1.866366] Registering SWP/SWPB emulation handler
[    1.873769] usb_phy_generic usb3_1-phy: dummy supplies not allowed for exclusive requests
[    1.882875] mv88e6085 f1072004.mdio-mii:00: switch 0x3520 detected: Marvell 88E6352, revision 1
[    1.893165] mmc0: new high speed SDIO card at address 0001
[    1.904974] hwmon hwmon2: temp1_input not attached to any thermal zone
[    1.925206] hwmon hwmon3: temp1_input not attached to any thermal zone
[    1.945200] hwmon hwmon4: temp1_input not attached to any thermal zone
[    1.965176] hwmon hwmon5: temp1_input not attached to any thermal zone
[    1.985187] hwmon hwmon6: temp1_input not attached to any thermal zone
[    2.316122] mv88e6085 f1072004.mdio-mii:00: configuring for fixed/ link mode
[    2.328191] mv88e6085 f1072004.mdio-mii:00: Link is Up - 1Gbps/Full - flow control off
[    2.424975] mv88e6085 f1072004.mdio-mii:00 lan4 (uninitialized): PHY [mv88e6xxx-1:00] driver [Marvell 88E1540] (irq=64)
[    2.534968] mv88e6085 f1072004.mdio-mii:00 lan3 (uninitialized): PHY [mv88e6xxx-1:01] driver [Marvell 88E1540] (irq=65)
[    2.642907] mv88e6085 f1072004.mdio-mii:00 lan2 (uninitialized): PHY [mv88e6xxx-1:02] driver [Marvell 88E1540] (irq=66)
[    2.754968] mv88e6085 f1072004.mdio-mii:00 lan1 (uninitialized): PHY [mv88e6xxx-1:03] driver [Marvell 88E1540] (irq=67)
[    2.864968] mv88e6085 f1072004.mdio-mii:00 wan (uninitialized): PHY [mv88e6xxx-1:04] driver [Marvell 88E1540] (irq=68)
[    2.897023] DSA: tree 0 setup
[    2.900163] xhci-hcd f10f8000.usb3: xHCI Host Controller
[    2.905519] xhci-hcd f10f8000.usb3: new USB bus registered, assigned bus number 2
[    2.913096] xhci-hcd f10f8000.usb3: hcc params 0x0a000990 hci version 0x100 quirks 0x0000000000010010
[    2.922388] xhci-hcd f10f8000.usb3: irq 52, io mem 0xf10f8000
[    2.928233] xhci-hcd f10f8000.usb3: xHCI Host Controller
[    2.933578] xhci-hcd f10f8000.usb3: new USB bus registered, assigned bus number 3
[    2.941101] xhci-hcd f10f8000.usb3: Host supports USB 3.0 SuperSpeed
[    2.947682] hub 2-0:1.0: USB hub found
[    2.951461] hub 2-0:1.0: 1 port detected
[    2.955542] usb usb3: We don't know the algorithms for LPM for this host, disabling LPM.
[    2.963834] hub 3-0:1.0: USB hub found
[    2.967610] hub 3-0:1.0: 1 port detected
[    2.971912] UBI: auto-attach mtd6
[    2.975262] ubi0: attaching mtd6
[    3.173265] ubi0: scanning is finished
[    3.181269] ubi0: attached mtd6 (name "ubi", size 74 MiB)
[    3.186701] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[    3.193616] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[    3.200434] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
[    3.207429] ubi0: good PEBs: 592, bad PEBs: 0, corrupted PEBs: 0
[    3.213461] ubi0: user volume: 2, internal volumes: 1, max. volumes count: 128
[    3.220717] ubi0: max/mean erase counter: 1/0, WL threshold: 4096, image sequence number: 1163218859
[    3.229893] ubi0: available PEBs: 0, total reserved PEBs: 592, PEBs reserved for bad PEB handling: 40
[    3.239366] ubi0: background thread "ubi_bgt0d" started, PID 559
[    3.243690] block ubiblock0_0: created from ubi0:0(rootfs)
[    3.250912] ubiblock: device ubiblock0_0 (rootfs) set to be root filesystem
[    3.258143] Waiting 1 sec before mounting root device...
[    4.325589] VFS: Mounted root (squashfs filesystem) readonly on device 254:0.
[    4.333236] Freeing unused kernel image (initmem) memory: 1024K
[    4.373636] Run /sbin/init as init process
[    4.377751]   with arguments:
[    4.377753]     /sbin/init
[    4.377755]     earlyprintk
[    4.377757]   with environment:
[    4.377758]     HOME=/
[    4.377760]     TERM=linux
[    4.377761]     mangled_fs=jffs2
[    4.377763]     mtdparts=armada-nand:2048K(uboot)ro,128K(u_env),256K(s_env),256K@8064K(devinfo),1920K@8320K(sysdiag),80m@10m(kernel),74m@16m(rootfs),80m@90m(alt_kernel),74m@96m(alt_rootfs),160m@10m(ubifs),-@170m(syscfg)
[    4.499097] init: Console is alive
[    4.502600] init: - watchdog -
[    4.841932] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    4.884473] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    4.898201] init: - preinit -
[    5.140845] random: jshn: uninitialized urandom read (4 bytes read)
[    5.162224] random: jshn: uninitialized urandom read (4 bytes read)
[    5.188419] mtdblock: MTD device 'devinfo' is NAND, please consider using UBI block devices instead.
[    5.231995] random: jshn: uninitialized urandom read (4 bytes read)
[    5.299274] mvneta f1070000.ethernet eth0: configuring for fixed/rgmii-id link mode
[    5.307383] mvneta f1070000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[    5.315284] mv88e6085 f1072004.mdio-mii:00 lan1: configuring for phy/gmii link mode
[    5.325524] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[    7.388448] UBIFS (ubi0:1): Mounting in unauthenticated mode
[    7.394215] UBIFS (ubi0:1): background thread "ubifs_bgt0_1" started, PID 677
[    7.415339] UBIFS (ubi0:1): recovery needed
[    7.493949] UBIFS (ubi0:1): recovery completed
[    7.498445] UBIFS (ubi0:1): UBIFS: mounted UBI device 0, volume 1, name "rootfs_data"
[    7.506318] UBIFS (ubi0:1): LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[    7.516285] UBIFS (ubi0:1): FS size: 63614976 bytes (60 MiB, 501 LEBs), max 511 LEBs, journal size 3174400 bytes (3 MiB, 25 LEBs)
[    7.527995] UBIFS (ubi0:1): reserved for root: 3004691 bytes (2934 KiB)
[    7.534640] UBIFS (ubi0:1): media format: w5/r0 (latest is w5/r0), UUID 18F52EF8-4B08-49F7-8D27-E499650BA0B3, small LPT model
[    7.547842] mount_root: switching to ubifs overlay
[    7.591652] ubi1: attaching mtd9
[    7.818466] ubi1: scanning is finished
[    7.826677] ubi1: attached mtd9 (name "syscfg", size 86 MiB)
[    7.832368] ubi1: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[    7.839286] ubi1: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[    7.846110] ubi1: VID header offset: 2048 (aligned 2048), data offset: 4096
[    7.853102] ubi1: good PEBs: 680, bad PEBs: 8, corrupted PEBs: 0
[    7.859137] ubi1: user volume: 1, internal volumes: 1, max. volumes count: 128
[    7.866393] ubi1: max/mean erase counter: 6/3, WL threshold: 4096, image sequence number: 1678395045
[    7.875568] ubi1: available PEBs: 0, total reserved PEBs: 680, PEBs reserved for bad PEB handling: 32
[    7.884834] ubi1: background thread "ubi_bgt1d" started, PID 688
[    7.897634] UBIFS (ubi1:0): Mounting in unauthenticated mode
[    7.903599] UBIFS (ubi1:0): background thread "ubifs_bgt1_0" started, PID 692
[    7.952932] UBIFS (ubi1:0): UBIFS: mounted UBI device 1, volume 0, name "syscfg"
[    7.960373] UBIFS (ubi1:0): LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[    7.970336] UBIFS (ubi1:0): FS size: 80375808 bytes (76 MiB, 633 LEBs), max 644 LEBs, journal size 4063232 bytes (3 MiB, 32 LEBs)
[    7.982044] UBIFS (ubi1:0): reserved for root: 3796347 bytes (3707 KiB)
[    7.988690] UBIFS (ubi1:0): media format: w4/r0 (latest is w5/r0), UUID 97C573FF-7376-48BB-98CD-680FE1C26ADA, small LPT model
[    8.001659] urandom-seed: Seeding with /etc/urandom.seed
[    8.068058] procd: - early -
[    8.070994] procd: - watchdog -
[    8.610807] procd: - watchdog -
[    8.614933] procd: - ubus -
[    8.634944] random: ubusd: uninitialized urandom read (4 bytes read)
[    8.667983] random: ubusd: uninitialized urandom read (4 bytes read)
[    8.675727] random: ubusd: uninitialized urandom read (4 bytes read)
[    8.682757] procd: - init -
[    8.918655] kmodloader: loading kernel modules from /etc/modules.d/*
[    9.005458] Loading modules backported from Linux version v6.1.24-0-g0102425ac76b
[    9.012981] Backport generated by backports.git v5.15.92-1-44-gd6ea70fafd36
[    9.059519] <<Marvell Mac80211 Wireless PCIE Network Driver version 10.3.9.1>>
[    9.066841] pci 0000:00:01.0: enabling device (0140 -> 0142)
[    9.072630] ieee80211 phy0: priv->pcmd_buf = (ptrval)  priv->pphys_cmd_buf = (ptrval)
[    9.128008] ieee80211 phy0: fw download start
[    9.128019] ieee80211 phy0: ddr init: download start
[    9.128398] ieee80211 phy0: ddr init: download complete
[    9.223486] urngd: v1.0.2 started.
[    9.267753] ieee80211 phy0: FwSize = 451040 downloaded Size = 451040 curr_iteration 65521
[    9.437998] random: crng init done
[    9.441415] random: 27 urandom warning(s) missed due to ratelimiting
[   12.139498] ieee80211 phy0: fw download complete
[   12.139535] ieee80211 phy0: device node: pcie@1,0
[   12.154913] ieee80211 phy0: pcmd = cf121a2b
[   12.172514] ieee80211 phy0: firmware version: 0x903020c
[   12.479507] ieee80211 phy0: firmware region code: 30
[   12.520617] ieee80211 phy0: 2G disabled, 5G enabled
[   12.525548] ieee80211 phy0: 4 TX antennas, 4 RX antennas
[   12.531084] pci 0000:00:02.0: enabling device (0140 -> 0142)
[   12.536899] ieee80211 phy1: priv->pcmd_buf = 2f3407a6  priv->pphys_cmd_buf = 4b9cd74a
[   12.543539] ieee80211 phy1: fw download start
[   12.543549] ieee80211 phy1: ddr init: download start
[   12.543931] ieee80211 phy1: ddr init: download complete
[   12.685335] ieee80211 phy1: FwSize = 451040 downloaded Size = 451040 curr_iteration 65526
[   13.879502] ieee80211 phy1: fw download complete
[   13.879538] ieee80211 phy1: device node: pcie@2,0
[   13.894960] ieee80211 phy1: pcmd = 2f3407a6
[   13.912516] ieee80211 phy1: firmware version: 0x903020c
[   14.219508] ieee80211 phy1: firmware region code: 30
[   14.252430] ieee80211 phy1: 2G enabled, 5G disabled
[   14.257355] ieee80211 phy1: 4 TX antennas, 4 RX antennas
[   14.267577] hid: raw HID events driver (C) Jiri Kosina
[   14.279824] Bluetooth: Core ver 2.22
[   14.283481] NET: Registered PF_BLUETOOTH protocol family
[   14.288858] Bluetooth: HCI device and connection manager initialized
[   14.295276] Bluetooth: HCI socket layer initialized
[   14.300188] Bluetooth: L2CAP socket layer initialized
[   14.305308] Bluetooth: SCO socket layer initialized
[   14.310846] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   14.316218] Bluetooth: BNEP filters: protocol multicast
[   14.321474] Bluetooth: BNEP socket layer initialized
[   14.330542] Bluetooth: vendor=0x2df, device=0x9136, class=255, fn=2
[   15.029843] Bluetooth: FW download over, size 616840 bytes
[   15.633526] btmrvl_sdio mmc0:0001:2: sdio device tree data not available
[   15.642203] usbcore: registered new interface driver btusb
[   15.648746] Bluetooth: HCI UART driver ver 2.3
[   15.653222] Bluetooth: HCI UART protocol H4 registered
[   15.658392] Bluetooth: HCI UART protocol BCSP registered
[   15.663735] Bluetooth: HCI UART protocol ATH3K registered
[   15.669813] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
[   15.675779] Bluetooth: HIDP socket layer initialized
[   15.692525] Bluetooth: RFCOMM TTY layer initialized
[   15.697471] Bluetooth: RFCOMM socket layer initialized
[   15.702641] Bluetooth: RFCOMM ver 1.11
[   15.706460] mwifiex_sdio mmc0:0001:1: WLAN FW already running! Skip FW dnld
[   15.713456] mwifiex_sdio mmc0:0001:1: WLAN FW is active
[   15.732784] PPP generic driver version 2.4.2
[   15.737801] NET: Registered PF_PPPOX protocol family
[   15.745183] kmodloader: done loading kernel modules from /etc/modules.d/*
[   15.805456] mwifiex_sdio mmc0:0001:1: info: MWIFIEX VERSION: mwifiex 1.0 (15.68.7.p189)
[   15.813629] mwifiex_sdio mmc0:0001:1: driver_version = mwifiex 1.0 (15.68.7.p189)
[   17.973885] mvneta f1070000.ethernet eth0: Link is Down
[   17.986631] mvneta f1070000.ethernet eth0: configuring for fixed/rgmii-id link mode
[   17.994535] mvneta f1070000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[   18.002423] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   18.090959] mv88e6085 f1072004.mdio-mii:00 lan1: configuring for phy/gmii link mode
[   18.103868] br-lan: port 1(lan1) entered blocking state
[   18.109133] br-lan: port 1(lan1) entered disabled state
[   18.145396] device lan1 entered promiscuous mode
[   18.150048] device eth0 entered promiscuous mode
[   18.234258] mv88e6085 f1072004.mdio-mii:00: port 3 failed to add ... vid 99 to fdb: -95
[   18.293315] mv88e6085 f1072004.mdio-mii:00: port 3 failed to add ... vid 3 to fdb: -95
[   18.384115] mv88e6085 f1072004.mdio-mii:00: port 3 failed to delete ... vid 3 from fdb: -2
[   18.410631] mv88e6085 f1072004.mdio-mii:00: port 3 failed to delete ... vid 99 from fdb: -2
[   18.429138] mv88e6085 f1072004.mdio-mii:00: port 3 failed to add ... vid 99 to fdb: -95
[   18.441129] mv88e6085 f1072004.mdio-mii:00: p3: already a member of VLAN 2
[   18.453780] mv88e6085 f1072004.mdio-mii:00: p3: already a member of VLAN 3
[   18.543666] mv88e6085 f1072004.mdio-mii:00 lan2: configuring for phy/gmii link mode
[   18.595500] br-lan: port 2(lan2) entered blocking state
[   18.600755] br-lan: port 2(lan2) entered disabled state
[   18.633652] device lan2 entered promiscuous mode
[   18.645734] mv88e6085 f1072004.mdio-mii:00: port 2 failed to add ... vid 99 to fdb: -95
[   18.735084] mv88e6085 f1072004.mdio-mii:00 lan3: configuring for phy/gmii link mode
[   18.789596] br-lan: port 3(lan3) entered blocking state
[   18.794853] br-lan: port 3(lan3) entered disabled state
[   18.827299] device lan3 entered promiscuous mode
[   18.843675] mv88e6085 f1072004.mdio-mii:00: port 1 failed to add ... vid 99 to fdb: -95
[   18.930501] mv88e6085 f1072004.mdio-mii:00 lan4: configuring for phy/gmii link mode
[   18.985921] br-lan: port 4(lan4) entered blocking state
[   18.991173] br-lan: port 4(lan4) entered disabled state
[   19.024410] device lan4 entered promiscuous mode
[   19.036648] mv88e6085 f1072004.mdio-mii:00: port 0 failed to add ... vid 99 to fdb: -95
[   19.130516] mv88e6085 f1072004.mdio-mii:00 wan: configuring for phy/gmii link mode
[   19.981577] ieee80211 phy1: change: 0xffffffff
[   20.079176] br-lan: port 5(phy1-ap0) entered blocking state
[   20.084829] br-lan: port 5(phy1-ap0) entered disabled state
[   20.090556] device phy1-ap0 entered promiscuous mode
[   20.095636] br-lan: port 5(phy1-ap0) entered blocking state
[   20.101253] br-lan: port 5(phy1-ap0) entered forwarding state
[   20.108182] br-lan: port 5(phy1-ap0) entered disabled state
[   20.811516] ieee80211 phy0: change: 0xffffffff
[   20.919122] br-lan: port 6(phy0-ap0) entered blocking state
[   20.924734] br-lan: port 6(phy0-ap0) entered disabled state
[   20.930435] device phy0-ap0 entered promiscuous mode
[   20.935486] br-lan: port 6(phy0-ap0) entered blocking state
[   20.941086] br-lan: port 6(phy0-ap0) entered forwarding state
[   20.946903] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   20.956978] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan.1: link becomes ready
[   20.963698] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan.2: link becomes ready
[   20.970390] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan.3: link becomes ready
[   20.977096] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan.99: link becomes ready
[   21.077817] mv88e6085 f1072004.mdio-mii:00 lan1: Link is Up - 1Gbps/Full - flow control off
[   21.086492] br-lan: port 1(lan1) entered blocking state
[   21.091759] br-lan: port 1(lan1) entered forwarding state
[   21.113608] br-lan: port 6(phy0-ap0) entered disabled state
[   22.837728] mv88e6085 f1072004.mdio-mii:00 wan: Link is Up - 1Gbps/Full - flow control off
[   22.846068] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
[   26.759532] IPv6: ADDRCONF(NETDEV_CHANGE): phy0-ap0: link becomes ready
[   26.766256] br-lan: port 6(phy0-ap0) entered blocking state
[   26.771856] br-lan: port 6(phy0-ap0) entered forwarding state

Nothing helpful in there. Just to make it clear, both were copied after the reboot?

@trendy I confirm it was taken after a reboot

Try to remove the force link option. It shouldn't be needed and might be the reason that the initialization is not taking place.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.