Internet connection issues with initial settings

Hi there,

I'm totally new to OpenWrt. :slight_smile: I'm trying to configure an Armor 2 as router (LAN/Wifi) behind my ISP's cable modem, which is a (very limited) Vodafone Station.

Here's what I did:

  1. Connected the Armor 2's WAN port to one of the Modem's LAN ports.
  2. Flashed OpenWrt 21.02.0 through Armor 2's OEM web UI.
  3. Connected my notebook via ethernet to the Armor 2
  4. Ssh'd into OpenWrt and changed the root password
  5. Visited OpenWrt's Web-UI (Luci), and to me the out-of-the-box setup seems reasonable and working.

I experience the following connectivity issue without doing any changes to the initial setting:

  • Out of ~5 subsequent tries to open any internet website, ~3 times it will fail (Browser reports "We're having trouble finding that site" after ~2-3s), 2 times it will load (the initial lookup phase still seems to be slow, it takes ~1 sec until the page starts loading)
  • If I go to "Network" -> "Diagnosis" and try subsequent IPv4 Pings to, ~half the time it works (0% packet loss, ~10ms), half the time it won't work (100% packet loss).

Did I miss something important? Can someone please help me to solve this?

Thanks! Holgi

PS: Here's how my interfaces and devices look like:

Looks like your cable model and your openwrt modem use the same subnet.

Change openwrt to (or something)

1 Like

Alternatively, can the modem actually be just a modem? i.e. does it have a "bridged mode" - because, at the moment it's a router too

... double NAT ... don't do it

Not ideal indeed, but well, if you bridge it then the security/firewall is managed by the other router, also not ideal. What I did on my setup was to put the openwrt router in the DMZ of the ISP router. For me that works good enough and Id rather trust OpenWrt than a router which i have very limited control over...

Maybe I used the wrong terminology ... a modem/router (like the thing you don't trust is) in bridged mode, basically means it's now just a modem ... and YOUR router does all the security/firewall stuff

Of course, this may not be possible if you rely on the modem for say a landline - all I know is, whenever I've had to use an ISP supplied "modem" that is actually a router as well, the first thing I've always done is disable the router part of it - and, I'm sure it's called "bridged" mode

edit: nevermind - I don't beleive that device can be just a dumb modem after all

Oh, that's true! That's probably problematic! :slight_smile:
Where should I change the IP? In the OpenWrt LAN-interface setting?

PS: The ISP modem is sadly not capable of bridge mode. I've read, that "Host Exposure" might be an alternative, but it seem like the Modem not even can do that.

click on the edit button on the LAN in the screen where you took the screenshot.
There should be a "IPv4 address" edit box. Then save the changes.

Then you can "save and apply" or probably better "Apply unchecked" (from the pulldown menu). If you do the "Save and apply" it may revert back to the old settings if you do not reach the router in time. Once settings are applied you do need to renew your IP address on your computer e.g. with "ipconfig /renew" on windows or maybe just disconnect and reconnect.

I would not bridge it, indeed "Host exposure" or "DMZ" may be an alternative (im using that), but if it cant then you have to live with double NAT

Super nice, that did it! Especially the hint with the "Apply unchecked" was helpful. I tried messing with the IP setting before, but got confused as OpenWrt couldn't connect back and reverted the changes... :slight_smile:

Thanks a lot for your help, that solved the connectivity issue!

One more question regarding the "Host Exposure" to avoid double NATting: My modem has the options shown in the screenshots below. There are only settings for IPv6 available. I read somewhere in old forum thread, that this is not a "full" host exposure and therefore won't help in a setup like mine.

Do you think that's true, or might it be worth a try?

And if so, what should I set as port range? Would I have to adjust settings in OpenWrt, too?


IPv4 may be the more useful part, but alas if that is not possible, then IPv6 may be better than nothing.
I would try the full port range. But to be honest I have no experience with that, so you can try, if it does not work you can always switch it off again.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.