Intermittent packet loss on WRT1900AC v1

Main Issues:
After setting up and implementing openwrt on my WRT1900AC I am getting seemingly random packet drops. I get about 90% success with ping from my devices to a variety of places (Im monitoring with telegraf pinging) and playing online games seems to work fine other than occasional drops in all traffic for 5-10 seconds. I have tried with both software and hardware offloading off or on but the same issue happens. I also have a question of throughput as it is not stable (this might just be the router hardware) where it is jumping around from about 600 mbps to 800 mbps (Im on a FTTH 1gig/1gig) and with other routers I have gotten around 800-900 consistently. The speed issue is not my concern as even at 600 I never run into issues with speed only breif internet dropouts.

Important information:

  • The ping drops are also to the router itself from my network which I have tried a number of cables all known to be good as they have been used in other places and some are brand new.
  • Pinging from the router to the external sites is reliable and pinging into my network from the router is reliable
  • I have some vlans set up and in use
  • I am testing all of this from a wired network
  • I have tried running on a number of versions from 19.07, 21.02, and now 22.03
  • The Fiber is terminated in a ONT/Router that is in passthrough mode.

Im not sure what else to do here. I have seen demonstrations with the router where it is able to pass through 900 mbps with ease but in my case it just doesn't seem to cut it. Im fine with the lower speed I really just want to figure out why the internet drops are occurring, as its quite frustrating going from fine low latency to no responses for 5-10 seconds then back to what it was.

Any help would be appreciated. I have tried searching for a solution but I can't find anything that works or relates to my issues so I figured I would reach out myself.

Solved my issue. Just another case of eee causing problems I turned off eee on lan and wan and all packet loss is gone.

I have the same router. How to you turn off eee?

To see eee settings you can use:

ethtool --show-eee <port>

And to turn it off per port it is:

ethtool --set-eee <port> eee off

In my case I turned off the eee for the wan and all lan ports (lan1-4)

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.