Intel XL710 PCIe card with 4x SFP... help needed

I have a x86 running openwrt with mwan3,SQM,wireguard,openvpn,and 4 different LANs with an average of 250 clients active and 300GB traffic passing through each day. Everything works amazingly well together. It is much better, faster, and more intutive to configure (in my opinion) than sonic wall or some of the other commercial products.

At first I had a PCIe ethernet card with 4 ports and 2Gbit bandwidth shared between all 4. This wokred pretty well but with with the increased traffic recently I decided to find a PCIe ethernet card that had more bandwidth available and also room to grow in the future. I got a StarTech PCIe x2 10G NIC with Intel 82599 XL710 Chip. At first the card was not recognized but after rebuilding the kernel with "Intel(R) Ethernet Controller XL710 Family" enabled it works... sort of. All the interfaces are now recognized (eth0-eth3) and 2 of the ports that have SFP to RJ45 adapters in work perfectly. However, one of the ports I have tried to plug in a multimode fiber SFP jack into, it does not recognize it at all.

Does anyone know of some tools I can use to try and debug this or any other ideas?

Seems that all four ports are recognized but not the SFP module that is plugged into that port.

Is there nothing pertinent in the logs?

Maybe this as starting point [1]?

There has been recent influx of SFP backports into the OpenWrt Master branch [2] that may (or may not) remedy the issue. Not sure whether/when those patches may ride the trains into the 19.07.x branch

[1] Support for GPON SFP FGS202

Is there nothing pertinent in the logs?

kern.err kernel: [369095.613354] i40e 0000:01:00.0: The driver failed to link because an unqualified module was detected.

When i look in kernel_menuconfig i cant find where to select SFP support even though it is listed here:

This seems being printed by the i40e driver and thus implies the SFP module not being supported (aka unqualified) [3 | 4]

It is mentioned

select MDIO_I2C


1 Like

You were correct, thanks. I ordered a brand name Intel SFP module and everything worked perfectly.

On a side note, i didn't even have to enable SFP support in the kernel. Enabling the X710 in kernel_menuconfig was all that was needed. I did not see the MDIO_I2C package I think because because at the time I built the image, 18.06 was the latest stable version and since this is in a production environment I used that.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.