Intel I210 NIC problem

Hello Everyone!

Previously I created thread in category installing and using Openwrt due to not operational WAN port when router is connected to modem. Teoubleshooting leads to hardware issue.

So the board is SECO A44 with 2xI210 Gigabit interface. This hardware is running x86 openwrt distro. Problem is with eth1 interface - when connected to modem, there is no Network connection (interface gets ipv4 address from modem, in normal conditions it should work right now) the solution is to connect eth1 to modem via different router.... But I am not interested in it.

For test there was installed ubuntu 18 lts in that board with same result as in Openwrt - eth1 still does not work with modem - eht0 works fine.

I have readed about I210 issues and also find one thread in Intel forum related to SECO A44 eth1 not working interface but with no solutions.

Does anyone know what can be done with this board?

Regards! :slight_smile:

What happens with a more current (non-lts) linux distribution (kernel v6.x)? 5 years of kernel development are a lot.

I have to try it, there is also prepared ready Linux image from manufacturer which is pretty old but should work the Best, right?

Worth a try, but Debian (bookworm dailies), Fedora and friends would be more interesting and representative (the kernel version matters, >=6.0).

Yep, same issue as in all cases that I tried.

Looks like that board is in weird Network configuration (hardware) which alows eth0 to behave as usual Network card but eth1 needs router/switch to work. There is explaintation in user manual for it => page 24 but i don't really understad purpouse to for that configuration and honestly first time see something like this....