Instruction on inadyn

Hello! Is there any instruction on setting up inadyn on openwrt? On the Internet, I read everything, but I never knew how to set it up for openwrt. On github the instruction from troglobit does not work outputs an error
/etc/inadyn.conf:20: Invalid DDNS provider Help, please.

Configured /etc/inadyn.conf with the following settings:

# In-A-Dyn v2.0 configuration file format
period          = 300

custom {
    ssl      = true
    username = user
    password = pass
    hostname = { }
      checkip-ssl = true
    checkip-server =
    ddns-server =
    ddns-path = "/nic/update?hostname=%h&myip=%i&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"

Inadyn --check-config worked normally.
Looked at ip updated. But what to do next is unclear.

dnsomatic is supported in ddns from what I see. Any special reason you prefer inadyn?

I tried ddns-script, but somehow when using the definition ip by url cannot update ip on the site dnsomatic, and if you use wan then ip is updated, but gets ip from the provider rather than external ip from wireguard set on vps. If you have recommendations on how to get around this, please and I will then stop configuring inadyn.

There are some remarks in the page regarding secure communication, I hope you took them into consideration.
Do you have the ddns configuration handy to post it?

I did everything according to ssl instructions, there are no mistakes.
I lay out my configuration and log:

config service 'myddns_ipv4'
	option interface 'wan'
	option service_name ''
	option enabled '1'
	option username 'username'
	option password 'pass'
	option ip_source 'web'
	option check_interval '5'
	option lookup_host 'sate'

204321  note : PID '5544' started at 2020-04-05 20:43
 204321       : ddns version  : 2.7.8-12
 204321       : uci configuration:
 204321       : verbose mode  : 0 - run normal, NO console output
 204321       : check interval: 300 seconds
 204321       : force interval: 259200 seconds
 204321       : retry interval: 60 seconds
 204321       : retry counter : 0 times
 204321       : No old process
 204321       : last update: 2020-04-05 20:43
 204321       : Detect registered/public IP
 204321       : #> /usr/bin/nslookup sate >/var/run/ddns/myddns_ipv4.dat 2>/var/run/ddns/myddns_ipv4.err
 204321       : Registered IP 'a.b.c.d' detected
 204321  info : Starting main loop at 2020-04-05 20:43
 204321       : Detect local IP on 'web'
 204321       : #> /usr/bin/wget-ssl --hsts-file=/tmp/.wget-hsts -nv -t 1 -O /var/run/ddns/myddns_ipv4.dat -o /var/run/ddns/myddns_ipv4.err --ca-directory=/etc/ssl/certs --no-proxy ''
 204322       : Local IP 'a.b.c.d' detected on web at ''
 204322       : Waiting 300 seconds (Check Interval)

Okay, I suppose that
204321 : Registered IP 'a.b.c.d' detected
204322 : Local IP 'a.b.c.d' detected on web at 'http://checkip.dyndns[.]com'
were the same and no action was needed, right?

I agree, after reinstalling ddns-scripts ip on the dnsomatic[.]com began to update, but ddns on router for some reason still does not work.

But if ddns script detects that your current IP is the same as the one registered in sate.dnsomatic[.]com it will exit without doing anything.
So what is not working on the router exactly?

I can 't go to the router by ddns name.

Does the ddns name resolve correctly to the IP?
Can you connect to the router by IP?

Understood, thank you for your valuable instructions - 443 port in firewall were not opened. Now comes by ddns name.

But I have another question. Can I connect my certificates to ddns and how?

I hope you didn't open 443 on the router but forwarded it to some server in the lan.

You can, but this doesn't have to do with OpenWrt. You'll have to create the certificates, have them signed and install them on the https configuration.

Is this done in/etc/config/uhttpd? I have my own certificates for the domain.

I advise you not to open the uhttpd on the internet, as it is not hardened for attacks.
That being said and if you understand the dangers of such a thing, the certificates are configured in config/uhttpd

Thank you, for your help. The issue is resolved.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.