Installing wifi drivers without internet

I've installed OpenWRT to a usb stick, and I'm just having a play around by booting it from USB on a spare x86 laptop I have around.

It seems it comes with no wifi drivers installed so I need to either somehow copy the drivers into the USB stick manually on another computer that has internet access, or somehow connect my laptop running OpenWRT to the internet.

I could run an ethernet cable from my laptop to my router, but how do I then configure it to connect to the internet?

yes you could
is your ethernet port detected, and do you get an IP ?

I can see when I connect my openwrt laptop to the router it sets the eth0 into blocking/forwarding state. My router doesn't show that there is any device connected however.

try editing /etc/config/network, change the lan section as below

config interface 'lan'
        option device 'br-lan'
        option proto 'dhcp'

do /etc/init.d/network restart afterwards

is there a wan section too ?

there is no wan section.
after doing that now nothing seems to work.

I'm not sure if this is useful...
ifstatus lan gives:
up: false
pending: false
autostart: true
dynamic: false
proto: dhcp

I may have disable the dhcp service earlier, is that a possibility why this might not be working?
I ran (From here:, from step 3 and 4) :
/etc/init.d/dnsmasq disable
/etc/init.d/dnsmasq stop

/etc/init.d/odhcpd disable
/etc/init.d/odhcpd stop

you don't need dnsmasq, unless you have devices connecting to you,
but you want the odhcp.

I tried running "enable" then "start" on both dnsmasq and odhcpd, but I still seem to have nothing.
I'm not sure what commands I should run to try to diagnose the problem.

pull the ethernet cable.

reinsert it, and run dmesg, to see if there's anything in the end of the log,
if not post the complete dmesg output.

run ifconfig, to check if you've got an IP assigned

try to run lspci, not sure it's available in the stock image.

if you know which additional modules you need, you could add them to an image using the image builder.

I tried dumping mesg to a file in both the home directory and the /www/ directory but it doesnt show up when I pop my USB stick in another linux machine so getting access to the logs is too much to type out manually.

That link might help me get up and running! I'll give that a shot when I get more time.

yeah, it's harder to get them if you use the squashfs, you could try the ext4 image instead.

if you make the swap, you could also put the packages you think you need, on the drive, and
manually install them using opkg install package.ipk from within openwrt.

or create an additional partition on the flash drive, the default partition size of openwrt is just 100mb, you should have plenty of extra disk space available.