Installing via SSH on ASUS RT-AX1800U failed. Noob questions

Hi there!

Trying to install openwrt per the instructions and failing. Can you help? Total noob in ssh here.

Managed to set up everything and get SSH access. But I get my internet from a different router for now. I tired pasting this command:

wget https://downloads.openwrt.org/releases/22.03.6/targets/ramips/mt7621/openwrt-22.03.6-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin

And getting:

Resolving downloads.openwrt.org... failed: Try again.
wget: unable to resolve host address 'downloads.openwrt.org'

There is an alternative in the instructions:
https://openwrt.org/toh/asus/rt-ax53u

To do:

cat openwrt-22.03.6-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin | ssh admin@device "cat > /root/openwrt-22.03.6-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin"

But it doesn't work for me. What am I missing? Again, total noob here.

Just to make sure we're on the same page, can you confirm that:

  • you ran that command on the PC that downloaded the image, not on the router?
  • you didn't literally use admin@device, but substituted device with the actual IP address or host name of your router?

I would try using scp on the PC with something like this:

scp <downloaded_image> admin@<device IP or host name>:/root

Substitute the names in the angle brackets as appropriate. Then, SSH into the router and type:

ls /root

and check that a copy of your downloaded image is now on the router.

1 Like

connect the AX1800 to the different router via it's WAN port ?

Unfortunately this is not a possibility for me. The router is the land owners and beyond my access. That would make my life easier. Right now, the PC has internet connection (via my phone) and the router does not.

then DL the image you're supposed to install to your computer, from there scp it to the router, instead of wget:ting it directly from the AX1800.

Thanks for all the help.

Here are my exact steps according to the instructions over here: https://openwrt.org/toh/asus/rt-ax53u

1.1:ssh hhfd@192.168.50.1
1.2: entered password
1.3: Here is the result: hhfd@RT-AX1800U-6CC0:/tmp/home/root# - it means I have ssh access to the router right?

2.1: Tried this command:

wget https://downloads.openwrt.org/releases/22.03.6/targets/ramips/mt7621/openwrt-22.03.6-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin

Result:
wget: unable to resolve host address 'downloads.openwrt.org'

No internet connection with the router, so makes sense.

3.1: Tried this command:

cat openwrt-22.03.6-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin | ssh hhfd@192.168.50.1 "cat > /root/openwrt-22.03.6-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin"

Result: hhfd@192.168.50.1's password: I enter the password and I get this thing:

hhfd@RT-AX1800U-6CC0:/tmp/home/root#

This following command gets the same result:

mtd-write -i openwrt-22.03.6-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin -d Kernel

What am I doing wrong here?
Thanks for all the help

expected, since you just said your AX1800 doesn't have internet access ?

there's really no point in running the remaining commands, if this fails, right ?

you were also told how to get around the issue.

Yep, I can't physically connect it to the lan port of another router

Ok so here is the result of elbertmai fix for me:

1: scp C:\Users\MYUSERNAME\Desktop\openwrt-22.03.6-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin hhfd@192.168.50.1:/root

1.2: hhfd@192.168.50.1's password:
1.3: I enter the password
1.4: Result:

sh: scp: not found
lost connection

Any suggestions?
+

winscp, in scp but you might need to force scp usage, I think it's -O.

Got you, on it right now will post shortly

Can't connect, How do I force sftp?

The only option I see in the asus UI is to enable telnet

where are you ?

post screenshots or C&Ps, instead of "it doesn't work"

ok,

that would probably mean you can't transfer it over like that :frowning:

try putting the openwrt file on an USB flash drive, insert it in the USB post of the router.

Great idea.

I have done just that, how do I initiate the flashing?

when ssh:ed to the router, locate and copy the file from the flash drive to /root, then run the mtd-write command.

Like that?

cat openwrt-22.03.6-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin | ssh hhfd@192.168.50.1 "cat > /root/openwrt-22.03.6-ramips-mt7621-asus_rt-ax53u-squashfs-factory.bin"

there is no confirmation for the transfer, did it worked?

My bad: I DID got this message:

Host '192.168.50.1' is not in the trusted hosts file.
(ssh-ed25519 fingerprint sha1!! 86:76:d0:c3:65:51:29:76:21:08:52:c7:3b:34:72:80:b4:65:37:14)
Do you want to continue connecting? (y/n) y
hhfd@192.168.50.1's password: