Installing unbound stops DNS

I don't see anything new on the unbound front since the push that added unbound-daemon or unbound-heavy. Maybe you have gone back to a tagged version.

1 Like

I don't know.
All I know is I downloaded the latest snapshot, built again without unbound.
Then, I updated my packages using opkg update then tried to install unbound-daemon which no longer exists. I then changed that to unbound and not only did it install but it runs as it always did before this thread was posted.

No changes what so ever to anything, it simply worked as it always has since the repo started working again earlier today.

I would hazard a guess to say, it never did (edit: as of the time of your building/posting):

https://openwrt.org/packages/table/start?dataflt[Name_pkg-dependencies*~]=unbound

I don't think the developers are hiding the package from you.

I'm sure you already know this; but you have to build your own firmware to have unbound included.

Incorrect, no such prompting occurs. The key is created in the background - during a "reset to defaults" reboot. Trying to connect should have presented to you a changed key warning at the client terminal used (unless you somehow kept that config).

  • Can you provide those search results?
  • Do you think the Wiki is insufficient, given you missed it - should it be updated?

:+1:

Glad it's working!

We've definitely eliminated unbound's crash looping being due to OpenWrt - you must work on your building.

unbound was split by commit e6812324c6, on May 28, 2019 to master. That commit may not be present on the feeds associated with the "release" branches at this time.

1 Like

It's not in 18.06 but it's present in the 19.07 branch.

1 Like

I don't want to quote your entire reply lleachii but to clarify some things.

I'm not sure what you mean by no one is hiding packages from me. Yes, unbound-daemon did install but it would not start and I showed the error. That is specifically why I started the thread since once installed,not even started, it stopped local DNS resolves by changing the /etc/resolv.conf.

I explained things as I was doing them so yes, there was a problem with the repo and packages and initially unbound was no longer there, I was told to use unbound-daemon then unbound re-appeared again yesterday. It was not in the repo when I looked for it.

First posted here; Where did unbound go?

No, I did not know you had to build your own to get unbound but it's why I found out there was a problem since my new build using the newer snapshot suddenly stopped working.

It does prompt with a changed RSA key every time I write a new sysupgrade file so wrong word used. Not sure why you focused on that but yes, changed key.

Wrong password, just Google 'openwrt ssh password' and look for new builds and you'll find plenty of folks asking how to log in.

I don't see how we've eliminated anything really. I changed nothing what so ever and two days ago builds would not build, specifically, ramips-mt76x8. I tried an ar71xx build and that worked. I think I posted that.
When I used an older build without unbound, I was told to use unbound-daemon which was broken somehow because of the repo. Two days later, it simply started working again when I downloaded that days image builder and tried again.

Definitely something was broken with either unbound-daemon or the repo perhaps causing a dependent package to not be included or something. I don't know but I posted every single detail as I found them.

When my builds started working again, I had changed nothing what so ever so there was nothing wrong at my end through all of this. I want this to be clear because while I was told I don't know what I'm doing I changed nothing and everything is working again. This is important and should be to elders around here because something happened and you should all care I would think.

OK, far enough. That's why I'm assisting. You noted/revealed a few things that are most helpful:

  • You were unaware you had to build a firmware to have unbound included
  • I was searching the thread and Wiki, thanks for clarifying you used Google
  • I also noted I'm getting crashing like this with snmpd occasionally - in fact I identified LuCI web GUI today (could be different issue though) so yes, I'm definitely concerned

Nontheless, if you are you able to install and use snapshot properly today, unbound itself cannot be the sole issue. That has been eliminated.

In fact, unbound was not the sole issue because once I found the problem, I started trying to build a base after it was suggested here. That base was simply 'make install' without specific packages and that is when I confirmed it was not anything I was doing.
I do not install any web or wifi services when I build, I just don't need those so my problem was not related to those packages if this helps at all.

Oh, and I think it is important that I pointed out this was specific(at least seemed to be based on my test) to the ramips version since the other that I tried did work.

It's happening again today. I've built this several times since we finalized this thread but now it's doing the same again. I've changed nothing on my end.

Downloading http://downloads.openwrt.org/releases/18.06.2/packages/mipsel_24kc/packages/libjpeg_9a-1_mipsel_24kc.ipk
Installing netcat (0.7.1-1) to root...
Downloading http://downloads.openwrt.org/releases/18.06.2/packages/mipsel_24kc/packages/netcat_0.7.1-1_mipsel_24kc.ipk
Unknown package 'openvpn-openssl'.
Unknown package 'unbound'.
Unknown package 'usbreset'.
Unknown package 'usbutils'.
Unknown package 'wget'.
Installing base-files (194.2-r7676-cddd7b4c77) to root...
Downloading http://downloads.openwrt.org/releases/18.06.2/targets/ramips/mt76x8/packages/base-files_194.2-r7676-cddd7b4c77_mipsel_24kc.ipk
Unknown package 'busybox'.
Unknown package 'dropbear'.
Installing fstools (2018-12-28-af93f4b8-3) to root...
Downloading http://downloads.openwrt.org/releases/18.06.2/targets/ramips/mt76x8/packages/fstools_2018-12-28-af93f4b8-3_mipsel_24kc.ipk
Installing ip6tables (1.6.2-1) to root...

**SNIP**

As announced, 18.06.3 is being built today. With so much to build, the repos will not be complete for some time yet.

1 Like

I was just about to ask, should I download the new snapshot? Also, where is this annouced? There are so many things to try and keep track of.

A better question is,

Is there a way to have the packages downloaded once so that they don't have to be downloaded each time? My requirements are fairly static and would prefer not using up the repo bandwidth if I don't need to.

Each time you do what?

If you're resetting your router constantly...the only method (as noted before) is to build a firmware with all your custom packages added.

Mirroring the complete package repo is probably more of a load than a handful of multiple downloads of the couple dozen packages you use.

Locally “frozen in time” builds are perhaps best from source using good discipline with git and tagging/branching.

1 Like

The thread started with my asking about building my own firmware using the image generator so this is what I am talking about when I say 'each time', meaning, each time I build.

What I need is pretty static, I don't need to add/change packages all that often, even if they get updated. I can use the same build for quite some time. I wondered it there is an option using image generator to keep all of the packages which were previously downloaded when I build a new fw.

Every now and then, I could refrain from using that option in order to get the latest packages.
Yes, I could also download the entire repo but as you said, it doesn't seem worth doing. However, it would be good to not use the openwrt repo bandwidth every single time I build something.

Anyhow, it's fine, I can just wait. How long does this rebuilding of the packages take? I can just try again later.

I’d give it a day, lots to build. “The hamsters are running as fast as they can.”

You can check the download site using a browser.

1 Like

@JoshGrant Please use "Preformatted text </>" for logs, scripts, configs and general console output.
grafik

Please edit your postings accordingly.

1 Like

I am wondering however, is there a way to save the downloads to prevent needing to download the next time I build?

Sure, manually download all prerequisites to your computer for future use.

Be advised though, snapshots and their packages update almost daily. So you must keep the firmware and packages sorted together.

I realized you said "next time I build"...not easilly.

Right, I would update every so often but just to build something, I don't need to download everything all the time.

I'm not sure what you mean by downloading to the computer. Do I just put the downloaded packages somewhere in the build tree and that prevents them from being downloaded again?