Installing package from postinst script

Hi All,

Does opkg support installing package in postinst script? I am currently getting following locking errors while attempting package installation in postinst script.

 * opkg_lock: Could not lock /var/run/opkg.lock: Resource temporarily unavailable.
 * opkg_cmd_exec: Command failed to capture privilege lock: Resource temporarily unavailable.

Regards,
Abhishek

No, even much more sophisticated package managers usually don't, and doing that would be pretty close to malware behaviour anyways (there are proper package dependencies, use them).

Thanks for quick suggestion. Actually, somehow it used to work with ipkg.
Sure, we will use package dependencies. Do you mean to use dependencies like mentioned in this link https://openwrt.org/docs/guide-developer/dependencies.

Yes.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.