Installing or compiling old packages on 19.7.3 (x86)

The closest applicable router hardware:

  • PC Engines Alix 2d2 router motherboard.
  • CPU: 500 MHz AMD Geode LX800 CPU. (x86)
  • 2 x AR9220 Mini-pci wireless cards
  • Storage: Operating system and applications stored on CF card (1GB +90% free)
  • Is running OpenWrt 19.07.3 r11063-85e04e9f46 ( geode target )

The Problem:

Visiting this page gives the impression that you can install any of these packages through LuCI , or an ssh terminal with opkg .

wireless packages

A while back, 14.x.x this was definitely the case, although the router I was able to install these packages on was not x86 based. Unfortunately this is not the case here. terminal
Same results for each package I have tried to install from this list. I then tried to manually download the packages and manually install them locally from the device. I couldn't seem to find them anywhere for this CPU target. (the package lists also only go back to 17.01.x) in between asking this on and coming here I found some of the packages here

When I looked here I didn't find any of the packages I am looking for listed for this version/target.

So my question basically comes down to these points.

  • Are there alternative targets outside of the geode packages for running on x86 architecture that might work? The thought here is I might be able to grab the package from another x86 based target and use it.
  • Does anyone know of an alternative method to download/install these packages manually?
  • Is it possible to just compile some of the packages on the device itself?
  • would it be easier to just go back to a barrier_breaker image to use these? or will i then have issues to work out with my ar9220 cards?

Thank you in advance for any suggestions.

i386_pentium should be the correct architecture, the newer ones won't be supported by your Geode LX800 (I think).

No, OpenWrt is not self-hosting. While there is gcc in the package feeds, it won't be able to build much more than a hello_world.c type program (no -dev packages available).

Anything below 18.06.x no longer has any kind of security support, which is crucial for a device with wireless connectivity (e.g. KRACK and multiple other vulnerabilities to choose from) and basic security in general.

If a package is no longer available, there must be a reason for this - it might have been abandoned upstream or by its OpenWrt maintainer, it probably fails to build in a recent environment or it has other problems.

1 Like

Thanks for the response. security isn't an issue here, this is setup as a "dumb ap" to play around with the radios in monitor-mode (essentially a poor mans spectrum analyzer with ethernet.)

Thanks for the suggestions, ill try a i386_pentium package out and report back. if they don't work, I don't see it as a problem to switch back to a lower version, as long as my ar9920's work with said image. (The alix 2d is on its own vlan behind a hardened firewall)

Oldpackages was a repo for abandonware, packages that nobody was interested to maintain and bring to the current GitHub packages repo.

My guess is that the wiki page is hugely outdated and most of those packages have died quietly. The packages might also have been targeting the ancient madwifi drivers etc.

Your best bet is likely applying an ancient firmware and manually downloading and then installing the package ipk files. Note that opkg update does not point to the archive site...

Compiling oldpackages was disabled before 15.05, so bb14.07 is likely the last possible release.

1 Like

Thank you both, didn't have to do anything crazy, they came right up when I downgraded to 14.07

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.