Installing OpenWRT on newer Mikrotik devices with "too-new-firmware" out of the box?

Hi all,

I bought a Mikrotik wAP AC and wanted to install OpenWRT on it. Seems like newer devices come with a firmware that is "too new" for OpenWRT. At least according to the wiki:

I guess this the firmware version limitation is still valid, as I had no success on getting OpenWRT installed.

Is anyone working on overcoming the limitation? Is there a snapshot build I could test to get it installed?

Or am I stuck with RouterOS for the time being?

Have a nice day,
Johannes

OK, as usual, as soon as one asks for help, suddenly everything works.

In other words: I have OpenWRT running via Netinstall on a MikroTik wAP that came with 6.49.7 preinstalled...

Just to be clear - exactly which mtik model is this ?
I have RBwAPG-5HacD2HnD, but OWRT modem/familiy is MikroTik hAP ac2 .

AFAICT it is a MikroTik RBwAPG-5HacD2HnD (wAP ac).

I followed the instructions here:

Hi
@johnth have made a patch
you could see from here
but you need to compile your own image
it is working well on few mikrotik devices i have ATM

As I wrote above the warning seems to be obsolete. I could successfully install OpenWRT on my Mikrotik wAP AC, even though it had 6.49 firmware already.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.