Installing OpenWrt on Netgear r6220

Hello, I was wondering if anyone can help me. I am completely new to openwrt, and I tried flashing using instructions Using PutTTy after the last step I rebooted router via command. Now the router only has 2 lights on, the lan and usb. What have I done and can this be fixed?

Are you saying that you cannot reach the router by cable? Because WiFi is off in OpenWrt by default

I am connected to the router with cable. Seems like the Router wont start up. power light is off only lan1 light is on.

The device page, under Debricking, references this page

can you explain to me how to run nmrpflash? I am completely lost. when I try to run it it tells me press any key to exit.

I don't own a Netgear so I don't really know other than what's written in the page.

You need to provide more info such as what OS you have on PC and how you ran nmrpflash.

I tried using puTTY. But I cant connect to the router. I don't know another way of doing it. Im a complete noob.

Try to merge the 3 answers above into 1, by editing the first reply and erase the other 2.

Other than that, does your PC take IP and other settings from router's DHCP server?

no it will not

@vasili333 Be aware that there is a limit on the number of posts a new user can make. So avoid making short posts and try to combine your answers in a thorough long post.

Anyway, I understand that you were flashing OpenWrt, and presumably you didn't notice any error, though it's not booting now.

Things to try:

  • Connect via cable. See if you can access the router.
  • Set your PC Ethernet card to static IP in OpenWrt default IP subnet (e.g. and try to ping the router (
  • If in doubt that flashing might have not completed, try setting the IP of your PC to stock firmware IP subnet and ping stock IP.
    If none of the previous works, then it would appear that the router was bricked.

The router page on the Wiki mentions debricking using nmrpflash. If you say you tried it but it didn't work, could you elaborate abit about what exactly you did, and also you computer operating system (Windows, I presume?).

The idea would be to revert to stock using nmrpflash as per the page, then flash OpenWrt again. I don't know if you could flash OpenWrt directly from nmrpflash.

Also, to unerstand why flashing for the first time went wronig, you may liek to read through this
Support for Netgear R6220 by @rsterz (and you could also send him a message to see if he can help, since he unbricked his router before).

1 Like
Usage: nmrpflash [OPTIONS...]

Options (-i, -f and/or -c are mandatory):
 -a <ipaddr>     IP address to assign to target device
 -A <ipaddr>     IP address to assign to seleted interface
 -c <command>    Command to run before (or instead of) TFTP upload
 -f <firmware>   Firmware file
 -F <filename>   Remote filename to use during TFTP upload
 -i <interface>  Network interface directly connected to device
 -m <mac>        MAC address of target device (xx:xx:xx:xx:xx:xx)
 -M <netmask>    Subnet mask to assign to target device
 -t <timeout>    Timeout (in milliseconds) for regular messages
 -T <timeout>    Time (seconds) to wait after successfull TFTP upload
 -p <port>       Port to use for TFTP upload
 -R <region>     Set device region (NA, WW, GR, PR, RU, BZ, IN, KO, JP)
 -v              Be verbose
 -V              Print version and exit
 -L              List network interfaces
 -h              Show this screen

Example: (run as administrator)

C:\> nmrpflash.exe -i net0 -f firmware.bin

When using -c, the environment variables IP, PORT, NETMASK
and MAC are set to the device IP address, TFTP port, subnet
mask and MAC address, respectively.

nmrpflash 0.9.13, Copyright (C) 2016 Joseph C. Lehner
nmrpflash is free software, licensed under the GNU GPLv3.
Source code at

Press any key to exit

I am unable to connect to the router at all. no ip nothing. I need someone to hold my hand on running this mnrpflash.

OK, I don't have this device so this is a shot in the dark:

1- Did you install WinPcap as the debricking page said?
2- Did you have static IP set for your computer network card?
3- I see you run nmrpflash form the root of the C:\ drive. I would suggest that you out it somewhere else (e.g. a subfolder) to avoid any possible permission issues with the drive root.
4- Where did you have the image file? I presume it should be in the same location as nmrpflash.exe.
5- I see the stock firmware in is in .IMG format. So it appears to me that you tried to flash OpenWrt. I think it's safer, and probably likely to succeed, to flash stock image using their procedure, then you can retry flashing OpenWrt form the GUI like you did before. The important thing is to get your router debricked first.

So if you put both nmrpflash.exe and firmware.img in, say, C:\debrick, and then change directory to that folder, and flash from there.

So, for example:

C:\> cd debrick
C:\debrick> nmrpflash.exe -i net0 -f firmware.img

If that doesn't work, try giving the full image filename as a parameter
C:\debrick> nmrpflash.exe -i net0 -f C:\debrick\firmware.img

1 Like

As mentioned by mhegab, it is important to install the correct version of Winpcap. Please follow the manual on the nmrpflash page.

Did you check that you are running nmrpflash against the correct network interface? Use the "-L" option to identify the correct interface. Set the IP address of your network card to a fixed IPv4 address using the Windows tools - it can be any address, it should just prevent the interface from using DHCP.

Unzip Netgear's image file and use the flash file in your command (rename the file to firmware.bin if you want to prevent tagging of dashes with backspaces).

Now comes the fun part as it requires some trial and error with the device timing during boot up and the timeout of the nmrpflash tool.

Start a cmd as administrator. Run nmrpflash -L to identify your network card (e.g. net1). Turn off your R6220. Run nmrpflash -i net1 -f firmware.bin (and replace net1/firmware.bin accordingly). Turn on your R6220 and wait.

If the timeout of nmrpflash occurs before there is a connect to the R6220, immediately restart nmrpflash with the same command (just use the "up" button on your keyboard for the last command and press return).

As said it may require a few tries until nmrpflash listens at the correct time for your R6220. But it worked for me everytime after bricking my R6220 - and I bricked it quite often as I tried new firmware on it.

Good luck! Looking forward to your feedback.


is there any solution to the initial problem? Flashing per telnet rootfs and kernel, reboot, the router only has 2 lights on, the lan and usb. Tried power-cycling, reset button short/long hold.
I have tried flashing different versions (18.06.1/2) from different stock versions with no success. Re-flashing stock Firmware with nmrpflash works fine.
Devices are brand new (April 2019).
What can i do?
Thanks in advance!

Try 19.07.0-rc2!
I experienced problems with 18.06.4, looked like a boot loop, with no response on IP. After debricking and flashing 19.07, it booted and seems to work fairly well (some minor drops on ethernet).

FYI: As reported in OpenWrt 19.07.0 first stable release, I had similar problems upgrading ar6220 via LuCi. I've upgraded another via cli and all went well.

I used the same file for upgrade, checked for SHA256.

I don't know if there are problems with luci vs. cli upgrade, or if the 1st r6220 has other troubles.

oh brother you said a mouth full. had the same problem. winpcap says its not for windows 10, or something, so i installed another program (the one that makes wireshark work, idk) its basically the same the same thing but under a different name. some reason im thinking minicap but thats from too many package installs under openwrt i think (everything is mini).

but anyway after uninstalling that prog and installing the right app i got nmrp to actually return somthing on the cli. then after 20 minutes of fiddling got the interface option figured out.

im not a networking guy but i can google and i have the ability to beat my head against a wall for many hours, which has gotten me pretty far in the openwrt world. id rather be smart, but tenacity has its place too. dont give up