Installing OpenWrt on Linksys EA6350 v3

Hello All,

I am a first time user, so pardon me for silly questions.

I would like to use OpenWRT for my router Linksys EA 6350 v3.

As per the thread, current build is snapshot.

I am not very much familiar with linux commands.

In general installation it is mentioned that snapshot does not contain GUI and i may have to install it manually.
Any idea when a stable build for this build will be available?
Should i wait till a stable build is available?

Another question is how much difference does it make for PPPoE connection.
Reason being, the stock firmware is taking atleast 3-5 minutes to connect to PPPoE after a reboot. Mostly I have to keep refreshing page on one of my device to get it started.

You can install 19.07 snapshot. It contains GUI and it is recommended for normal use, because it is much more stable branch.

It is 99% stable now and should be released soon.

Thanks a lot Pilot6, will try it out.
By chance are you aware if it supports both 2.4GHz and 5 GHz bands?

All firmware support both bands.

1 Like

Hey Pilot6,

I have installed the snapshot, and after that i am not able to connect to
It says " refused to connect."

I am able to connect to ssh with putty.
My ISP works on PPPoE, i cannot use internet without configuring the router.

I have tried using
method. but so far no success.

Do you have any suggestions?

Did you install 19.07 snapshot or master snapshot?
If you installed an image that doesn't contain luci, you'll have to configure pppoe using CLI.

fwiw, I would suggest you use web UI to manage OpenWrt.

Here are some suggestions.

If you installed development snapshot, there is no web UI. You have to download and install LuCI web UI package by connecting WAN port of ea6350v3 to LAN port of your existing internet connected router. This could be tricky given you have edited /etc/config/network file. There are a number of methods to reset OpenWrt to restore the /etc/config/network file to original DHCP on WAN configuration.

Once ea6350v3 has internet connection via your main router, you can SSH and execute these commands:

opkg update
opkg install luci

Alternatively, install OpenWrt 19.07 snapshot because this includes web UI. if you are a Windows user, you can use winscp to transfer OpenWrt 19.07 sysupgrade file to the /tmp folder on the ea6350v3. Then SSH into the ea6350v3 and execute the command to install the upgrade.


sysupgrade -n -F /tmp/linksys_ea6350v3-squashfs-sysupgrade.bin

19.07 snapshot for ea6350v3 is here
(Important: Use 'sysupgrade' and Not 'factory' file because OpenWrt is already installed in your case) This method is a bit more risky and can brick router especially if you install the wrong file !

@Pilot6 fwiw, I've added a 'temporary' download link to OpenWrt 19.07 snapshot in the instructions for ea6350v3 in the openwrt wiki. Seems like newbies likely to blindly install development snapshot without realising there is no LuCI.

1 Like

@niravbhattsai managed to install luci to a snapshot. See hes new topic.

1 Like

There is no need to -F when sysupgrade from master to 19.07.

I always revert back to stock before upgrading with factory image. To revert back, switch on/off 3 times with 10 secs interval for 'on'.

This makes no sense at all. Reverting to stock either.
You may jump 3 times with the same result.

I'm no expert but are you sure?

Reverting to earlier kernel version never worked for me other routers such as HH5A without '-F' for force the sysupgrade. eg. 4.14 to 4.9, or 4.9 to 4.4, for HH5A.

It should work. Anyway it's worth trying. I see no reason why it won't work.
It doesn't work in case board name changes.

I have downloaded sysupgrade file from

Waited for 15 minutes.

After that router is not starting up. So I restared, still same.

When I start, LED lights starts to blink. After a while it goes away.

Was able to bring it up. but it seems that the sysupgrade did not work.

What method did you use to install the sysupgrade file earlier?

I used LUCI -> Backup/ Flash Firmware -> Flash new firmware image -> used the new file downloaded.

Now trying again with ssh.

Normally when I try to use LuCI to downgrade to an older kernel version (eg. 4.14 to 4.9), LuCI will always show an error message, and refuse to complete the request on other routers I own. I therefore have to use SSH and 'sysupgrade -n -F' command.

I admit I have not yet personally tried to use LuCI or sysupgrade via SSH on my ea6350v3 to install a different release.

1 Like

You probably forgot to press "Proceed".