Installing OpenWrt on Fritz!Repeater 3000

Hi,
first, excuse my very bad english.

Problem:
I want to install OpenWRT on my fritz.repeater 3000.

I read this:

I have the problem, that I can't connect the ftp-server during boot.
Surely, I set a static IPv4 address.

I don't know, if the eva_ramboot.py script is different?
The link in the treat above is down ...

Thanks for your help

This is usually because the notebook network card takes too long to detect "link up". I had the same problem with my MacBook with usb-c network card. So I just took my raspberry pi. Hanging a switch in between might help, too.

I have been using the avm 3000 for a while now without any problems, with several VLANs and ssids on three radios.

Some more information about the AVM 3000.

a very good translator: https://www.deepl.com/translator

Thanks for your answer and for the tip with the translator :slight_smile:

I have a switch between the repeater and my computer.

The link to download the eva_ramboot.py script does not work. Can you send it to me again?
I would be very grateful for that.

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=148d29d47b1d555d0058dcc5dda450b74c4628ec

1 Like

Great, thanks a lot :slight_smile:
Basically I had understood that correctly:
The default IP of the repeater is 192.168.178.2, you haven't changed anything, right?

I use Linux Mint on a desktop computer. I use the Network Manager to set a fixed IP for my computer: 192.168.178.10.

All the files from your post, I have downloaded.
The folder they are in doesn't have to be in a specific location, right?

How to install the TFTP server is very well described, it worked.
Is there anything else I need to consider?

scrip

You will need serial for parts of this process, that isn't really clear from the instructions.

I'm sorry, I don't understand: "You will need serial"?

My result is always the same:

root@desktop: ./eva_ramboot.py --offset 0x85000000 192.168.178.1 uboot-fritz3000.bin

Traceback (most recent call last):
  File "./eva_ramboot.py", line 29, in <module>
    ftp = FTP(args.ip, 'adam2', 'adam2')
  File "/usr/lib/python3.6/ftplib.py", line 117, in __init__
    self.connect(host)
  File "/usr/lib/python3.6/ftplib.py", line 152, in connect
    source_address=self.source_address)
  File "/usr/lib/python3.6/socket.py", line 724, in create_connection
    raise err
  File "/usr/lib/python3.6/socket.py", line 713, in create_connection
    sock.connect(sa)
OSError: [Errno 113] No route to host

...it's very frustrating.
I have been trying for several hours now - without any result.
Probably I can't see the "forest for the trees" :slight_smile:

Wrong router IP (some question whether it is .1 or .2), wrong netmask in the PC (should be 255.255.255.0 or /24) or starting the FTP script too early or too late.

1 Like

Thank you for your patience.
As you may have noticed, I'm quite a novice in the field.

So the router should have a fixed IP 192.168.178.1, so ..:
./eva_ramboot.py --offset 0x85000000 192.168.178.1 uboot-fritz3000.bin
...gets to the target?

255.255.255.0 I have set.

What is the best way to start the script? I ping the router at boot time and watch out for the lights on the switch. As soon as something happens, I send the command ...

Now I get a different error message so above:

[root@desktop](mailto:root@desktop): ./eva_ramboot.py --offset 0x85000000 192.168.178.1 uboot-fritz3000.bin
Traceback (most recent call last):
File "./eva_ramboot.py", line 29, in <module>
ftp = FTP(args.ip, 'adam2', 'adam2')
File "/usr/lib/python3.6/ftplib.py", line 117, in __init__
self.connect(host)
File "/usr/lib/python3.6/ftplib.py", line 152, in connect
source_address=self.source_address)
File "/usr/lib/python3.6/socket.py", line 724, in create_connection
raise err
File "/usr/lib/python3.6/socket.py", line 713, in create_connection
sock.connect(sa)
ConnectionRefusedError: [Errno 111] Connection refused

Connection refused means that there is a device at that IP address but its FTP port is not open. As I understand it the FTP server is only open for a short time during the boot.

Okay, thanks.
Of course, I tried a few "windows of opportunity" over the afternoon. Sometimes the process seems to "hang", then an error message appears again. Sometimes the error message comes immediately.
I'm beginning to doubt whether the moment is right...

It is best to open two terminal windows, ping 192.168.178.1 in one window and prepare the command "eva_ramboot.py" in the other window. The problem is that the FTP server is only available for a very short time.
So you should use a fixed network card (no usb adapter) and test with a static IP address (dhcp must be deactivated), otherwise you will miss the ftp server.
With my MacBook I didn't do it with me either, only with the Raspi and only after I set a static ip in /etc/dhcpcd.conf.

That's how I do it: two windows open.
In one, the ping command. In the other the command for the script. As soon as the ping comes through once or twice, I send the command for the script.

I have turned off DHCP as well as IPv6.
The IPv4 address is static.

Unfortunately I have no Raspi. With Linux Mint there is no /etc/dhcpcd.conf.
I make the settings via the Network Manager.

I have a normal network card with LAN cable - so no connection via USB or similar.

Vielen Dank für die Hilfsbereitschaft.
Aber das scheint wirklich was für absolute Experten zu sein :slight_smile: Ich komme hier keinen Schritt weiter ...

Hello,
I have now taken a few steps further:
I could go with you:
./eva_ramboot.py --offset 0x85000000 192.168.178.1 uboot-fritz3000.bin
... access the fritz.repeater.

The next steps of the manual:


... I followed.

Which is the problem:
After changing the IPv4 of my computer (192.168.1.70) I can also ping the fritz.repeater (192.168.1.1)
But I cannot access the fritz.repeater via ssh, so the scp commands do not work.

Can anyone else give me a hint here?
I would be grateful for it.

I've done it!
Man, was that an act.

I could not reach the ftp server at first because I rebooted from the fritzbox. You actually have to pull the plug, then it is easy to catch the right moment.

Then I did not realize that I had to start the ftpd server manually.

Once that was clear, it also worked according to the instructions.
Thank you so much for that.
After the ordeal, this is really fun now!!

Glückwunsch, siehste geht doch :slight_smile:

The following things you should do now

## This file contains files and directories that should
## be preserved during an upgrade.

##Install TLS for HTTPS
# opkg update && opkg install luci-ssl-openssl

##Install WPA3
# opkg update && opkg remove wpad-basic && opkg install wpad-openssl hostapd-utils

##Install Wiregard
# opkg install kmod-wireguard luci-app-wireguard luci-proto-wireguard wireguard wireguard-tools qrencode

# RESTORE using:
# opkg update
# opkg list-installed | cut -f 1 -d ' ' | sort -u > /tmp/currentpkg && cat /etc/config/installed.packages | cut -f 1 -d ' ' | sort -u > /tmp/oldpkg
# grep -v -F -x -f /tmp/currentpkg /tmp/oldpkg > /tmp/inst
# opkg install $(cat /tmp/inst | sort -u)
# rm /tmp/currentpkg /tmp/oldpkg /tmp/inst"


## FOLDERS
/etc/wireguard/*
/etc/crontabs/*
/etc/dropbear/*
/etc/profile/*
/root/*

## FILES
/etc/sysupgrade.conf
/etc/TZ
/etc/banner
/etc/config/installed.packages

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.