Installing OpenWrt on fresh WRT32X

I am super new to this, so apologies for the basic nature of the questions.

I have a Linksys WRT32X, and would like to install OpenWRT. If you go to the device page ( it looks very easy/straightforward, however using the Web GUI to install the firmware yields an error "invalid firmware". This seems to be a well-discussed issue in chats, so I wonder whether it is worth updating the web page.

From what I gather from these forums, @davidc502 provides the easiest way to install by downloading the firmware from his web page ( have downloaded the factory image (openwrt-mvebu-cortexa9-linksys_wrt32x-squashfs-factory.img), but wanted to check on next steps before proceeding - as I really do not want to brick my router.

Is it as simple as using the Linksys Web Gui (Router administrator->firmware->manual firmware update->select downloaded firmware) to update...and then acessing the rebooted router at I was a little concerned at the warning on that said "this will soft brick anyone who is not already using DSA"...I assume that this is not relevant for people upgrading from the default Linksys build - is that correct?

Thanks in advance for your help!

Just an update: With @davidc502 image as well the factory web gui says "invalid firmware".

Is it possible that the newer GUI firmware from linksys is more restrictive than previously? Would upgrading from the CLI (Sysupgrade -n -v -F) be a potential workaround?

I know a bunch of people have faced this issue, and then managed to resolve it. Can anyone point me in the right direction?

Apologies, I think I solved my problem. For those who might be facing the same problem, it appears at some point the web GUI is not checking the firmware anyore, and is just throwing up the invalid message indiscriminately. Some combination of rebooting the rooter and using a new browser/clearing cookies seemed to work.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.