Installing OpenWrt Issue on WE1326-BKC

I bought this router from here, AliExpress

As I saw this router support OpenWRT. When I got it I saw they installed their OpenWRT images which is pretty nice but they have some tracking link in the router so I decided to install clean OpenWRT firmware.

As preinstalled firmware it not allowing me to install OpenWRT firmware I have to start it on failsafe mode aka U-boot loader. I found that is Chinese, with the help of Google Chrome I flushed Official OpenWRT Images as from this link.

https://openwrt.org/toh/hwdata/zbt/zbt_we1326

But when a router restarts back, it not working at all. I tried every possible way to check if it boot properly. I saw lights are normal, but I didn't get any DHCP even I set my PC as static, Still no access.

Asking here, how can I install OpenWRT firmware on it?

The page you linked says see the Git commit for install instructions:

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=ff258effd508fc75edfb08ba709b333619d3f1e8

There is a new version for this Router v5. Which got 256mb RAM. and it doesn't support that firmware.

Does the model sticker behind say WE1326-BKC?
Install sellers firmware and check your memory amount in the device. If there is 256MB then open a dispute on AliExpress and ask for refund as the item you bought says 512MB memory.
If the memory amount is the problem, you should leave info on your feedback so others can figure out also if they received a different device than what they ordered.

That said, there is a zbt we1326 thread discussing this here ZBT WE1326 crashing with 18.06 image you can modify sources and compile a working image.

I made dispute already, in Sticker it says ZBT WE1326, but in product page it says ZBT WE1326 BKC.

And I tried that method to modify memory, but that doesn't work.

Funny thing is I found two bloated firmware from other website which use OpenWRT.
One comes with 512mb RAM
Another comes with 256mb RAM
and both of them works. That made me confused, I talked with ZBT official and they confirmed me that Hardware is probably 256mb as they released v5 of that router. So I need a clean OpenWRT firmware that support on this Router.

How can you have a 256Mb version of the router and a firmware for 512Mb version can work?
It is impossible.

I think you should rest, because you seem to be confusing stuff. You also wrote "in Sticker it says ZBT WE1326, but in product page it says ZBT WE1326.". So it says ZBT WE1326 on both ? :smiley:

Sorry, it should be ZBT WE1326 BKC in Product Page.

Try this, 256mb BB 14.04 Firmware

512mb OpenWRT 18.06 Firmware

Yes, but what amount of RAM is usable once you login to the device? Mine says total memory 513260 kB.
If you have 256mb and OpenWRT tries to use 512mb. I would expect it would crash!

I guess so. Fact is I need working 256mb or 512mb clean firmware.
I tried to build using image builder but no luck.

I am expecting that you have 256mb version. But it is difficult to confirm as you said you installed 512mb rom but you don't know how much memory it showed. (was it really a 512mb rom? who knows?!)

I am also expecting that you did something wrong when building image. Did you remember to modify the code before build? Then made a clean build?

Check this link first,

I followed that

I'm not that technical, can you elaborate how can I build an image for that router?

Using current master/ HEAD, you can just build it - and it should do the right thing, without any manual changes.

Never mind, I it just like normal openwrt image builder?
can you just give some information where to start? Rest I'll try myself. And Thanks

https://openwrt.org/docs/guide-developer/quickstart-build-images

…or you wait for tomorrrow's (master-) snapshot builds (make sure that the build dates are stamped with tomorrow's date, so they'll actually contain today's changes).

1 Like