Installing OpenWrt 21.02 on Ubiquity Edge Router X

Hello everybody,

I tried yesterday to flash my Ubiquiti Edge Router X with 21.02, following the instruction of post Step by step install openwrt onto edgerouter x?.

Everything worked fine, and I was able to flash the router with the image:
The router reboot correctly and I was able to connect on with SSH.

After this temporary success, too early I wanted to sysupgrade the image "openwrt-21.02.0-ramips-mt7621-ubnt_edgerouter-x-initramfs-kernel.bin" with option -F and the result was a bricked router... Not possible to connect on ethernet port or enter in a recovery mode... I will try tomorrow to recover from serial port.

Can somebody explain me where I did the mistake?

Thanks in advance

Start in failsafe mode. Look it up in the wiki.

Don't flash the initramfs file for an upgrade between versions of OpenWrt. Use the sysupgrade.

The -F option, though necessary here, is dangerous because it will flash any file regardless of if it is a useful one.

1 Like

Hi @cervenka,

I just wrote about upgrading from 19.07 to 21.02 here: Update for UBNT-ERX from 19.07 to 21.02 - #2 by rogerpueyo

Once OpenWrt is installed, the sysupgrade image should be used to upgrade the system (e.g., to a newer version), and not the initramfs nor the factory ones. The sysupgrade image is built specifically for upgrading the system, keeping previous settings over the process if needed, and leaving it operational. Instead, the initramfs image is to be used as a temporal OpenWrt "tool" image that you can boot and, from there, install the sysupgrade image.

If you're lucky enough, you'll be able to enter in OpenWrt's recovery mode without needing the serial port. From there you should flash the sysupgrade image. Otherwise, you'll need to recover your device using the TFTP method.



Thanks to everybody for the support. Actually I'm at an hard stop because I'm not able to recover the device. Serial + TFTP method recovering method requires the upload of a recovery image from Ubiquiti ( I tried both the images proposed in the article but the loader is refusing them with a checksum error (I tried with several files, including OpenWrt but always with the same error). Looking in a Ubiquiti support forum I'd find a similar issue example, but apparently without a solution. I would be glad is somebody can suggest me some alternative solution.
I suggest to update the device page in the portal with adeguate disclaimers about the recovery method, because it's not totally free of risks.

I bricked mine attempting to upgrade to 21.02 and had to recover via Serial + TFTP. All I did was start from scratch by serving the factory 21.02 .bin over TFTP. The rest is history...

1 Like

Hi d4rk3,

I tried again with Serial + TFTP. I wanted to make it simple uploading an older OpenWrt version (18.7). When I'm going to upload this is the result:

More explicitly, using the 'r' option of loader the message is:

The same with any kind of image I tried to upload since now.

Any suggestion based on your experience?

In the first case, your TFTP server is not responding, though an ARP of the server did work. This is probably due to a firewall on the server PC. Once you get TFTP server working, pull the initramfs OpenWrt and boot it from RAM.

Which program/command are you using to serve the firmware to TFTP clients?

Here's the exact code I used to fix mine:

atftp --trace --option "timeout 1" --option "mode octet" --put --local-file firmware.bin

Maybe run: sudo apt install -y atftp and then try serving the file with atftp...keep us posted

I'm using the standard TFTP in Ubuntu 12.04. The command I'm using is:

sudo tftp 192.168.1.x
put openwrt.bin

ufw is disabled
What is concerning me is that the file it's beeing uploaded... but I didn't specified "mode octet"... I will follow your suggestion about atftp and will let you know.

Thanks for now

The "thing" is live again! Thank you d4rk3 and thanks everybody for the useful suggestions.
The only file that worked was the recovery image from Ubiquiti recovery page. Now I will start again the basic flashing process for OpenWrt.
Hopefully I will avoid a re-brick.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.