Installing openvpn server connection but no internet

I am using LEDE Reboot 17.01.4
Trying to install openvpn server with guide Went smooth.
But at the end of the process my android can connect with the vpn server (myvpn), but there is no internet.
Two warnings and one error (failed), see log.
What did I wrong and how to correct?

My log on the android client:
Verbonden: SUCCESS,,xx.ip-nr.xx,1194
13:25 NOTE: --mute triggered...
13:25 160 variation(s) on previous 20 message(s) suppressed by --mute
13:25 OpenVPN 2.5-icsopenvpn [git:icsopenvpn-d51333c645c12713+] android-14-armeabi-v7a [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Jun 26 2017
13:25 library versions: OpenSSL 1.1.0f 25 May 2017, LZO 2.10
13:25 WARNING: --ns-cert-type is DEPRECATED. Use --remote-cert-tls instead.
13:25 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
13:25 TCP/UDP: Preserving recently used remote address: [AF_INET]xx.ip-nr.xx:1194
13:25 UDP link local: (not bound)
13:25 UDP link remote: [AF_INET]xx.ip-nr.xx:1194
13:25 [myvpn] Peer Connection Initiated with [AF_INET]xx.ip-nr.xx:1194
13:25 GDG: SIOCGIFHWADDR(lo) failed
13:25 do_ifconfig, tt->did_ifconfig_ipv6_setup=0
13:25 Initialization Sequence Completed

I successfully set it up for nordvpn following the instructions at:

I hope this is of help to you!

I followed the same guide and it worked. I haven't tried using Android, but when I connect using Windows there are 4 or 5 lines about setting up the interface and DHCP after the line
[myvpn] Peer Connection Initiated with [AF_INET]...

Maybe you could try setting up openvpn on a PC to see if it still fails? Also, check /tmp/openvpn.log on the router.

... I'm using NordVPN, but the steps are similar with other providers. Install needed modules:...

Thanks you for the reply.
I will try it. It can be a nice alternative for my ip adress.
But I think that this is not the solution I'm looking for.
I also really want to solve the problem I've mentioned above.
Regards, Lucas

I have find the solution of my problem.
I've tried a lot of possibilities, at fin I've changed the DNS, that was the problem. Now my vpn is running beautiful on my LEDE-router as server. My android is the client.
So in file
list push 'dhcp-option DNS'
change ipnr with ipnr for DNS 1 and add a line with DNS 2
I've also added the line
list push 'block-outside-dns'
The ipnrs for DNS 1 and DNS 2 you can find in LEDE GUI status (overview)
Problem is solved. Maybe it is possible to make a remark by the vpn-guide.
Regards, Lucas

By default you would run dnsmasq on the router, which would provide a DNS server on Maybe you've changed the configuration?

Hi Per,
I did not change the configuration consciously.
I used a new os LEDE from scratch en did not change settings, I think.
First a password and "opkg update" and then step by step executing the guide.
I use port 5060 in stead of port 1194, thats the only difference.
Regards, Lucas

Other people have had problems with OpenVPN and DNS as well, particularly Android:

I have it installed and working but I do not know how to change the server

Thanks, I have this same issue, however I don't understand your line:

change ipnr with ipnr for DNS 1 and add a line with DNS 2

Can you clarify? I had to add pull-filter ignore "block-outside-dns" to my .ovpn file since MacOS has an error if you don't have that line.

I had the same problem. I checked I have dnsmasq running in my OpenWRT device, but its "DNS forwardings"
field is empty. I just put some public DNS servers there ( and and now my Android device has Internet access :slight_smile: