Installing on TP-Link TL-WR841N V13

Thx ralaud for the fast reply... I decided to go ahead and try the luci install via WinSCP as shown in the YouTube video and that fixed it so I am thinking that the official release does not include it after all? Anyway I am in my route now! So glad to be off that original.. bug ridden TP-Link firmware!!!

Anyway thanks again for all the help and to everyone else here on this forum! Also anyone one else out there with the Spanish model in Colombia (and probably anywhere else in South America) you are safe to install this and you really should install this to be free of the VPNFilter malware. And while mi espanol es bueno... I am happy to be back to a router in English :wink:

1 Like

When a new update of OpenWrt comes out can I just update through the Luci GUI?

You can upgrade with sysupgrade.bin(my posted link, is openwrt-17.04 snapshot, for openwrt-18.06.0-rc1 there are no daily updates at the moment) file through Luci GUI, but if you upgrade to another snapshot/developer version, then you need to install Luci GUI again. Only Official release contain Luci GUI, so soon with official release you could just update without the hassle of installing Luci GUI again.

2 Likes

Thank you again... I think I will roll back from 18.06.0 to 17 as I seem to have WiFi issues with the 18 and I am not sure if it is the Firmware or the fact I have a ES version of the TL-WR841N V13... but hopefully the version you have will be more stable.

Screenshot%20(147)

So as you can see from this photo the wifi for some reason disables itself when I change the SSID name or enable encryption. I got it to enable by changing the Channel from auto to 10 and the Width to 40 but not sure if both or just one of them changed would have fixed it... Have you seen or heard of this happening before?

Looks like it is the "auto" channel causing my wifi to disable. I set back Width to 20 since that is the recommended setting and channel number to 1 and it re-enabled the wifi. It is only when I set it to Auto that the wifi disables itself even though it shows it as "Wireless network is enabled" and the Wifi LED is lit.

I don't know, I never had problems like these. So openwrt-18.06.0-rc1 has some bugs, also I do not wonder if there are more bugs than in openwrt-17.04 because openwrt-18.06.0-rc1 is a beta release for official openwrt-18.06.0.

1 Like

@ralaud and @digitalknight

Here is release 18.06.0-rc2. I did not flash it yet using tftfp.

I have a problem is that my Dell inspiron N 4010 has a Intel centrino N 1000 device and it's unable to connect to router while using openwrt but when i am using TP-Link firmware it works ok.

I am getting: "The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform." when I try and flash the 18.06.0-rc2 img file

On a side note... by Lenovo T520 seems to work fine with the wifi on 17.04 but my LG G5 does not seem to like the wifi... but then again on my LG G5 I am running a unoffical 8.1.0 ROM that messed up my wifi MAC address so....

On another side, side note.. I also found openwrt firmware for my other router, an old Linksys E3000, and thought it would be cool to install it on it... well it also disable both wifi's (2.4 and 5.0) and when I enable them it bricked my E3000... took a lot of digging around the internet and Youtube videos to find a way to recover it and put stock firmware back on it. Life as a beta tester :roll_eyes::roll_eyes:

They look the same.

1 Like

RC1 and RC2 have luci included.

1 Like

Thanks for sharing, but you got it working on openwrt 17.0.1, did you?

To upgrade openwrt through openwrt-web-updater you need this file openwrt-18.06.0-rc2_sysupgrade.bin, openwrt-18.06.0-rc2_tftp-recovery.bin is only for tftp installation.

Off-Topic:
I would recommend you to install official LineageOS 14.1(Android 7.1.2) with LineageOS 15.1 Launcher (so that you will not miss the launcher style) on your LG G5.

1 Like

Thanks Raluad.

I did end up installing it using tftp and it seems to be more stable than rc1 and 17.04 so I think I will stick with it.

Off-Topic:
Tried LOS 14.1 and it was more buggy than LOS 15.1 .. but I am waiting on my Essentials phone from Amazon prime day for $250 to arrive and hopefully by the time it gets here to Jardin Colombia they will have released the official android "P" version and life will be good. :slight_smile:

1 Like

Hello everybody first of all!!

So, digitalknight, could you please try and let know about official openwrt-18.06.0?
official openwrt-18.06.0 sysupgrade

And for those who wants to try it and doesn't have any openwrt-rc's already installed, tftp link:
official openwrt-18.06.0 tftp

Hi, is there any progress with mt7628 wifi driver, or it the wifi is still unstable? Thanks.

Hello everyone. I just tested the latest official release (OpenWRT 18.06.0) on my TP-Link WR841N v13:

Here are the overall results:

#LAN:
--- LAN Speeds are OK (99/99 Mbps);
--- There's no packet loss on LAN;

#WLAN:
--- Configured 3 Wireless networks on it, isolated from each other, all using WPA2;
--- Wireless was set to HT40, however it only worked at HT20 speeds (no device would connect at HT40 against it);
--- Wireless speeds where around 50 Mbps Upload and Download (from a local server);
--- Wireless is NOT stable: It will work for a while and well close to the Router, but as soon as you distance yourself from the router (10~15m in open area), packages will start to drop and the connection will drop some times.
--- A lot of devices, especialy Intel based wireless chips will refuse to connect to the AP.

Hoping this was usefull somehow!

Both of these conditions sound like interference or a congested band...also, did you try setting "force 40 MHz" and/or tweaking the distance and CTS/RTS?

The 40 MHz setting is a new option on the web GUI under Advanced.

Hello lleachii.

I did not use the Luci GUI to configure the router, i did everything by editing the files present at /etc/config via SSH.

Even using the option "HT20" the devices will lose signal and stop working properly frequently. This agravates the more time the router is turned on for some reason.

I did some further testing and on my laptop, sitting very close to the router, pinging the router sometimes will give a Timeout. Again, the further away the router is the more timeouts it gives.

I can share the configurations i used if needed.

1 Like

Installed official 18.06.0 (thx Yankes for the link) through the GUI and the install went very smooth. As far as wifi goes.. I never liked the wifi signal even back on stock ES (spanish) firmware. But I really only use the built in wifi for my two wifi security cameras and use a E3000 (linksys) router for my main wifi connection to all my other devices. I will do more testing with this latest "official" build with my Laptop and iPad and LG G5 and will report back on my findings but so far with my security cameras it seems to be working just fine.

1 Like

Confirming everything of @blacklionpt report.
In my env only one wirerless network configured using WPA and all configurations was made via web gui.

So, after ~5 days of wireless drops inside ~70 sq.m. apartments I try to change the Transmit Power setting for Wireless config to maximum value 20 dbm (was auto) and set a Channel config to Mode: N, Channel: 7 (was auto, just select 7 to not interference with neighborhood points), Width: 20 MHz (was 40). Average signal power measured by wireless monitor on my laptop and smartphone was increased from -54dbm to -41dbm (routhly).

As result -- one day of "almost stable" WIFI connection (working whole day via RDP and everything goes quite good in compare with prev days).

1 Like

Well I have been using for over a month and while it works it is not perfect... Something locks up and the router has to be rebooted.... not sure if it is hardware on the ES version here in Colombia... but that is what I am leaning towards.... I can power cycle the router and everything comes back online just fine... but it is kind of a pain... I think it is time to retire this router and buy something a little more stable.

1 Like

I do not find this router reliable enough to use with OpenWRT. There is a full thread about this at TL-WR841N v13 WiFi not stable?