Installing on TP-Link TL-WR841N V13

alright. THank you


1 Like

Post them here please

1 Like

You could also upload the v13 pictures to the wiki at

1 Like


Removed photo

We just got official openwrt-18.06.0-rc1 release for tl-wr841n-v13 :smiley: I WILL TEST IT! Thanks for your hint.

I took some photos (photo1 photo2), from my tl-wr841n(EU)-v13.1 (13.x , that x stands only for the software version installed)

And here are pictures from another tl-wr841n(TPD)-v13.0.

You could compare these with yours.


Thx. Looks like the EU version has a ESMT chip where mine has a Winbond chip. So I guess the hardware inside is not the same. :frowning:

Your processor is the same, I think the ESMT chip on EU version is just Ram ( If your Winbond chip has the same specification, then it should work (, they are saying 8.388.608 words (8M) x 4 banks x 16 bits. So Ram specification looking same.

But I can not find the 8MiB Flash chip, so I can not compare them.
Is Flash integrated in Ram chip? Maybe 8.388.608 words (= 8MiB Flash) x 4 banks x 16 bits (= 64MiB Ram), but I am not sure.

1 Like

Help usb mid wr841n v13 dts file

Flash chip on bottom side, it is GigaDevice 25q64xxxx.


Maybe I will try and flash the EU firmware first and see if it does not brick the router.

But remember..

:warning: Important information:
Guys I do not recommend you to revert to stock firmware, Tp-link TL-WR841N stock firmware is infected with a VPNFilter malware, like all other devices on this list. So if openwrt is working well for you, do NOT revert to stock firmware.

1 Like

Going to try and install on my 841N V13 ES model and hope for the best... I would never want to go back to stock... I installed DD-WRT on my Linksys router but that was a lot easier as it comes with a GUI where this looks like you have to install the Luci GUI but hey... the video listed above makes it look easy enough to install... just hoping I do not brick my Colombian version of the unit.... will post my results if I get back online. :slight_smile:

you don't need to install the old way as there is a official release now. Just download and install it. Luci will be installed already. Here is the download link.

1 Like

Thanks... I get the same error that I get when I try to install firmware updates that TP-Link told me to try and install:

Código de Error: 4503

El archivo cargado no fue aceptado por el dispositivo.

But I can still try and force install it using the tftp method???

Could you explain your steps?
Would be much easier for us to help you and to understand what happened wrong.
If you want to upgrade from original firmware you need to visit this website , you can only flash my changed EU firmware with tftp method not with build in updater from tplink firmware (so you can flash firmware from another region with tftp only, because tplink do not allow with updater). You have to flash Openwrt/LEDE firmware with tftp method too, there is no other easier way to flash it.

I did not flash openwrt-18.06.0-rc1 yet. So Luci is included now?
Thats listening really nice :slight_smile:

1 Like

I have not tried any steps as of yet... as I have only spoken to TP-Link and they said the ES version hardware is different and will only except ES firmware so I did not want to brick the router trying the tftp method. But looking at the insides of mine and the EU model insides thanks to your photos I am going to try the tftp method as soon as I get up the nerve. :fearful:

Ok, so I installed openwrt-18.06.0-rc1 and that went smoother than I had hoped! And my router seams to be working.. only problem is that I can not access it at I am able to reach the internet obviously and I now have a wifi SSID of OpenWrt but I get :slight_smile:
This site can’t be reached refused to connect.

Checking the connection
Checking the proxy and the firewall

Tp-Link do not allow flashing firmware from another region. Because they do not allow, you need to flash EU stock firmware with tftp too.. just in case if you want to revert.

Are you connected with Wifi or Lan?
I can not tell something about openwrt-18.06.0-rc1 at the moment. I had no time for installing openwrt-18.06.0-rc1.. so I have openwrt-17.04 for now. Maybe web server is turned off, try these commands in scp;

/etc/init.d/uhttpd start
/etc/init.d/uhttpd enable