Installing on Pentium3 directly to hdd

I have Pentium 3 box with 128mb RAM and i was trying to install OpenWRT to 16gb sata2 ssd (via converter (sata-to-miniide board on jm20330 ic), bios correctly recognize drive, but looks like it does not support booting from any usb).
x86-legacy image copied to ssd with "gnome disk utility" gives just "LOADING GRUB.." and then just blinking cursor.
What i'm doing wrong?

  • From the link you provided, the device only has an IDE disk drive capability
  • Can you explain how you managed to connect a SATA drive?

(via converter (sata-to-miniide board on jm20330 ic)
https://photos.app.goo.gl/nEYe5ZgfTRjQhNXu9

I would say the solution to your issue is to purchase a standard, circa 1990's IDE drive, contemporary with the computing era of the device in question.

Are you sure it's fully powered?

Yes, i think shassis psu is powerfull enough for (3.3v@5a, 5.1v@10a, 12v@1a) for one cpu card.

Pata-to-sata converter chip seems to be commonly used, and ssd correctly recognised by bios, so i dont think it is a source of a problem

OK...how did you transfer the image to the SSD, create partition, etc.?

"Restore partition image" on the utility?

If there is not a serial port in the machine, GRUB will stall trying to open its serial console, but I think that happens at the GRUB menu.

I've always used dd of=/dev/sdb ... to copy the disk image. You may need to write using PATA through the adapter to have it on the disk in the same format.

1 Like

Yes, and result looks correct

So, spend some time plaing with grub config file

terminal console

set pager=1
set debug=all

gives me "GRUB Loading.....", then "Welcome to GRUB", and then just back screen with blinking cursor.
When i add set root=(hd0,msods1) to /boot/grub/grub.cfg, i get just "GRUB Loading....."
So I think source of problem is definetly not waiting for a serial port.

So seems like grub cant load config. Hmmm...

Are you using legacy or x86_64?

You should be using legacy.

Yes, legacy. Tried both - ready image downloaded from openwrt site and builded from sources (with p3 (coppermine) selected in kernel_menuconfig), same result.