Installing LuCi on QNAP QHora-301W

Hoping someone can point me in the right direction.

I am trying to upgrade my Netgear Nighthawk X4 D7800 running OpenWRT to the QNAP. I followed the instructions here and that has been successful. I had assumed it was then a case of following the instructions here to complete the LuCi install to restore the web GUI.

When using the Netgear, I can connect to http://192.168.100.1/ to access the internal page for the cable modem. I had assumed that this would be the IP address for the modem which is referred to as 192.168.2.1 in the page above. Despite being able to ping the IP address, any attempt to use opkg update results in failure to download packages, for example

root@OpenWrt:~# opkg update
Downloading https://feed.robimarko.eu/packages/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://feed.robimarko.eu/packages/Packages.gz
...

I used the following command on the QNAP

uci set network.lan.ipaddr="192.168.100.2"
uci set network.lan.gateway="192.168.100.1"
uci set network.lan.dns="192.168.100.1"
uci commit
/etc/init.d/network restart

When using the Netgear, I can see my external IP address on device eth0.2@eth0, which I assume is requested from my ISP via DHCP. Is there a way to force the DHCP request or do I have to use the internal IP for the modem?

Thanks
-paul

please post commands output

nslookup www.google.it
ping -c 5 192.168.100.1
ping -c 5 192.168.100.2

You have installed an old unofficial build from robimarkos repo.

You should first upgrade to an official build.

https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/

scp that to the router and do a sysupgrade without saving the config (option -n)

After the upgrade you can install Luci via opkg.

1 Like

Thanks for the reply, and you original input on that developer thread. You and @robimarko were major contributors.

I did as suggested and it was successfully upgraded, but I still do not have internet access.

BusyBox v1.36.0 (2023-01-14 15:45:09 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r0-3a2144f
 -----------------------------------------------------
root@OpenWrt:~# sysupgrade -n /tmp/openwrt-qualcommax-ipq807x-qnap_301w-squashfs-sysupgrade.bin
Sat Jan 14 16:30:49 UTC 2023 upgrade: Commencing upgrade. Closing all shell sessions.
Command failed: Connection failed
root@OpenWrt:~# 
Session was closed


BusyBox v1.36.1 (2023-08-04 23:58:29 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r23684-881235c713
 -----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:~# passwd
Changing password for root
New password: 
Retype password: 
passwd: password for root changed by root
root@OpenWrt:~# 
root@OpenWrt:~# opkg update
Downloading https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/packages/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/packages/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/base/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/base/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/kmods/6.1.42-1-41909366fefc9edca8d69d06051b4aec/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/kmods/6.1.42-1-41909366fefc9edca8d69d06051b4aec/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/luci/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/luci/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/packages/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/packages/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/routing/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/routing/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/telephony/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/telephony/Packages.gz

Collected errors:
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/base/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/kmods/6.1.42-1-41909366fefc9edca8d69d06051b4aec/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/luci/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/routing/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/telephony/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

root@OpenWrt:~# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: miireg: <> mtu 0 qdisc noop state DOWN qlen 1000
    link/generic 
3: lan4: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq master br-lan state DOWN qlen 1000
    link/ether 24:5e:be:55:09:1a brd ff:ff:ff:ff:ff:ff
4: lan3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq master br-lan state DOWN qlen 1000
    link/ether 24:5e:be:55:09:1b brd ff:ff:ff:ff:ff:ff
5: lan2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP qlen 1000
    link/ether 24:5e:be:55:09:1c brd ff:ff:ff:ff:ff:ff
6: lan1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq master br-lan state DOWN qlen 1000
    link/ether 24:5e:be:55:09:1d brd ff:ff:ff:ff:ff:ff
7: 10g-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 24:5e:be:55:09:1e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::265e:beff:fe55:91e/64 scope link 
       valid_lft forever preferred_lft forever
8: 10g-2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq master br-lan state DOWN qlen 1000
    link/ether 24:5e:be:55:09:1f brd ff:ff:ff:ff:ff:ff
9: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:03:7f:12:9e:83 brd ff:ff:ff:ff:ff:ff
10: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:03:7f:12:82:77 brd ff:ff:ff:ff:ff:ff
11: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 24:5e:be:55:09:1d brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd10:d585:da1e::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::265e:beff:fe55:91d/64 scope link 
       valid_lft forever preferred_lft forever
root@OpenWrt:~# nslookup www.google.com
Server:         127.0.0.1
Address:        127.0.0.1:53

** server can't find www.google.com: REFUSED

** server can't find www.google.com: REFUSED

root@OpenWrt:~# uci get network.lan.ipaddr
192.168.1.1
root@OpenWrt:~# uci get network.lan.gateway
uci: Entry not found
root@OpenWrt:~# uci get network.lan.dns
uci: Entry not found
root@OpenWrt:~# 

Also, just curious why the official build not appear as a snapshot here https://firmware-selector.openwrt.org/

Thanks again
-paul

Please post your network config

At which port is your modem connected?

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd93:4936:1101::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports '10g-2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device '10g-1'
        option proto 'dhcp'

config interface 'wan6'
        option device '10g-1'
        option proto 'dhcpv6'

root@OpenWrt:/etc/config# 

Modem is connected to 10g-1

Have now flashed to OpenWrt SNAPSHOT, r23685-7e7eb5312d (built today at 08:43:10) after seeing a comment on https://openwrt.org/releases/snapshot regarding checksums.

-paul

According to your given information from you old router

eth0.2@eth0

You need to set the vlan id to 2 on the wan-interface.

So set the device to

option device '10g-1.2'

on both wan-interfaces

still no internet. tried a network restart and a full reboot

BusyBox v1.36.1 (2023-08-05 16:42:45 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r23685-7e7eb5312d
 -----------------------------------------------------
root@OpenWrt:~# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: miireg: <> mtu 0 qdisc noop state DOWN qlen 1000
    link/generic 
3: lan4: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq master br-lan state DOWN qlen 1000
    link/ether 24:5e:be:55:09:1a brd ff:ff:ff:ff:ff:ff
4: lan3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq master br-lan state DOWN qlen 1000
    link/ether 24:5e:be:55:09:1b brd ff:ff:ff:ff:ff:ff
5: lan2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP qlen 1000
    link/ether 24:5e:be:55:09:1c brd ff:ff:ff:ff:ff:ff
6: lan1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq master br-lan state DOWN qlen 1000
    link/ether 24:5e:be:55:09:1d brd ff:ff:ff:ff:ff:ff
7: 10g-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 24:5e:be:55:09:1e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::265e:beff:fe55:91e/64 scope link 
       valid_lft forever preferred_lft forever
8: 10g-2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq master br-lan state DOWN qlen 1000
    link/ether 24:5e:be:55:09:1f brd ff:ff:ff:ff:ff:ff
9: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:03:7f:12:7e:e3 brd ff:ff:ff:ff:ff:ff
10: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:03:7f:12:62:d7 brd ff:ff:ff:ff:ff:ff
11: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 24:5e:be:55:09:1d brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd93:4936:1101::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::265e:beff:fe55:91d/64 scope link 
       valid_lft forever preferred_lft forever
12: 10g-1.2@10g-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 24:5e:be:55:09:1e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::265e:beff:fe55:91e/64 scope link 
       valid_lft forever preferred_lft forever
root@OpenWrt:~# opkg update
Downloading https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/packages/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/packages/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/base/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/base/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/kmods/6.1.42-1-41909366fefc9edca8d69d06051b4aec/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/kmods/6.1.42-1-41909366fefc9edca8d69d06051b4aec/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/luci/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/luci/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/packages/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/packages/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/routing/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/routing/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/telephony/Packages.gz
Failed to send request: Operation not permitted
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/telephony/Packages.gz

Collected errors:
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/base/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/kmods/6.1.42-1-41909366fefc9edca8d69d06051b4aec/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/luci/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/routing/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/telephony/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd93:4936:1101::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports '10g-2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device '10g-1.2'
        option proto 'dhcp'

config interface 'wan6'
        option device '10g-1.2'
        option proto 'dhcpv6'

root@OpenWrt:~# 

thanks for the support
cheers
-paul

presumably i need to add something for the vlan too.

my old config:

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'
        option ula_prefix 'fd98:99d1:9448::/48'

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option device 'br-lan'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth0.2'

config interface 'wan6'
        option proto 'dhcpv6'
        option device 'eth0.2'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

config interface 'guest'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option device 'br-lan'

config route
        option target '192.168.254.0'
        option gateway '192.168.1.10'
        option netmask '255.255.255.0'
        option interface 'lan'
        option metric '10'
        option table 'main'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1.1'

root@OpenWrt:~# 

-paul

Huh, the vlan id 2 is just part of the old switchconfig.

It's not needed anymore, so set the wan interface devices back to 10g-1

But actually then the router should get an IP from the modem.

I figured it out after reading another unrelated post about DOCSIS modems on Virgin Media. It required a power cycle of the cable modem and then a new external IP is assigned.

Packages updated and Luci installed now.

Thanks a lot for taking the time to respond.
Cheers
-paul

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.