Installing Luci on Netgear WAC104

Hello there. I am new to OpenWRT and decided to install it on to my Netgear WAC104 to see what its like and learn. While the installation of the actual firmware and accessing the device via SSH has gone relatively smoothly for me, I cannot figure out how to install Luci onto my device. I tried using the commands
"opkg update
opkg install luci"
but because the WAC104 doesn't have a WAN Port, it cannot download what it needs to from the internet. I have regardless tried connecting an ethernet cable from my router to the WAC104 but that didn't work either so now I'm trying to figure out how to install it offline. I tried to read through the manual installation guide but the whole downloading and transferring of the individual packages is really confusing. Whether its how to do it offline or how to get internet access onto my access point, any help would be appreciated, thank you!

What's in /etc/resolv.conf ?
Can you ping or from the device?

Just installed tonight. Similar issue. Setting up a wac104 snapshot as an AP on an existing network. Luckily, I'm an old school linux dude, so it was pretty easy to figure out. I can walk you through it.

Let's pretend your existing network is "" (cidr /24 = netmask and it has a router with internet access at So when I say "10.1.2.x" replace that with your real network IP addresses. The 192.168.1.x addresses are defaults on the snapshot release.

(Note if your existing network IS already, you'll have to change that default IP on the wac104 of offline from your local network before plugging it in or you'll have an IP conflict on your local network plugging it in. In which case, leave it unplugged from your network but plugged into your computer until after the reboot or service network restart step. Then you can then plug it into your network to do the remainder).

Plug that wac104 into your router via lan ports. WAC has a default IP of
On your machine, give yourself a secondary virtual IP or set a static IP to on your machine of... ssh into the wac104 at the IP.
First, do a "service dnsmasq stop" and "service dnsmasq disable" so you aren't having DHCP server conflicts on your working network.

Edit "/etc/config/network" to put a static IP in for your working router network in place of the static IP configured - say if that is an unused IP on your network. Do a "service network restart" or just reboot the wac104. (If your existing network is 192.168.1.x, you can now plug the wac104 into your working router/network).

Get your PC on your working network as normal so you have a IP again on your computer and you can access your normal network and internet.
Now ssh back in to the static IP you gave the wac104 on the network. ( in the example above).

Once ssh'd into the WAP again with the new static IP on the existing network, you should be able to ping your router (in this example: Though you can't hit the internet yet. Here's the fix to your question above.

  1. Set your default gw with "route add default gw" so your wac104 knows where to route traffic by default. You can validate by looking for a default route using "route -n". Should see a default route starting with that goes to your router/gateway on your namework.
  2. And edit /etc/resolv.conf, which is empty, to contain "nameserver" so you have DNS resolution. ( is google DNS servers).

There, that'll put you on a usable network with a valid default route/gw and even a nameserver for DNS. Try to "ping". Should be fine. Now you can install the luci stuff since your wac104 has internet access. Once you have luci installed, feel free to use the WebUI to set it up however you want. Just go to that new static IP in the browser and you're set.

1 Like

This was a big help, thank you!

Glad to be of help. You know what was a real trip?
I have always had issues with this AP just occasionally getting TERRIBLE ping times randomly. But very noticeably. It was bad enough that I had to use the 2.4Ghz band as the 5Ghz band was so unreliable. Really messed with VoIP calls and video calls for work. I tried everything I could think of including complete resets. I re-ran cables, I even bought a scanner to check for wifi interference.

Finally decided to give openwrt a try. Something I haven't done in well over a decade.
After getting luci installed and setting up the webui, I haven't had ANY of the terrible ping times. It's been super reliable, no problems at all in the 24 days ago I installed it.

I was ready to throw that wac104 away, figured it was just cheap junk with crappy firmware bugs. Openwrt has been on it for 24 days, haven't needed to reboot, hasn't crashed and no noticeable packet loss issues or high ping time batches like before. I'm a heavy user that is almost always on VoIP/video calls all day for work, so I notice issues right quick - zoom even will say "your internet connection is unstable". Haven't seen any since I put on Openwrt. Totally fixed the darn thing. I'm just impressed as heck with the firmware! WAY better than the stock firmware, by far. Absolutely worth the try, especially if you have occasional terrible connectivity as I did. Openwrt is running perfectly fine. Saved me from having to buy a much more expensive access point.

here are the steps I used to get this going on the WAC104:

Step 1:
edit /etc/config/network - change the ip address to something that won't conflict with your router, then add the following options:
option gateway 'YourGatewayIpHere'
option dns 'yourFavoriteDnsHere'

In my case, the value for both these options was, the ip address of my router.

Step 2:
Disable dnsmasq with this command "/etc/init.d/dnsmasq disable"

Step 3:
Reboot - once the access point comes back up connect again with ssh (at the new ip address!). At this point you should have internet access.

Step 4:
Use opkg to install luci!
opkg update
opkg install luci

I found this documentation really useful:

I hope this is helpful!

This topic was automatically closed 0 minutes after the last reply. New replies are no longer allowed.