Installing Luci on Belkin RT3200/Linksys E8450 is quite a challenge

I am struggling to get Luci installed on my new Belkin RT3200 which I am planning to use as an access point.

What I did:

  • installed "openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery-installer.itb".
  • installed latest snapshot file.

Then I need to run okpg update && opkg install luci. So I plugged the RT3200 on the internet but no success. It wasn't even able to ping anything on the internet. As I have an PPPoE based internet-connection I altered /etc/config/network according for the WAN interfaces: still no succes.

Then I configured it as an "dump ap" according to these instructions (via ssh/commandline):
(did not do the wifi-part as I haven't got wifi (default of snapshots).

Still no luck when I connect it to my network. Still no internet sites can be pinged.
Googled it, found this topic:

Entered the commands:

uci set network.lan.gateway=""
uci set network.lan.dns=""
uci set network.lan.dns=""
uci commit
/etc/init.d/network restart

Ah: finally able to ping ip-addresses and sites as well. However: opkg update still doesn't work. Error message: "wget returned 5". Found over here that this a "SSL verification failed" error. related.

Found a topic on this: SSL support in OpenWrt OPKG (wget) stating that "

opkg list | grep -i wget
wget-ssl - 1.21.1-1

should solve it. However: I don't appear to have wget-ssl installed. Try to install it with:

opkg install wget-ssl --no-check-certificate
Error: Unknown package 'wget-ssl'.

Found these (outdated?) instructions:

But opkg install ca-certificates gave 'Unknown package" error.

Then I looked up the package on the downloadsite and found it here:

Downloaded it with:

wget --no-check-certificate

Tried to install it with:
ipkg install wget-ssl_1.21.2-1_aarch64_cortex-a53.ipk
But got a 'ipkg' not found error.

And now I am on the point that I am asking myself: is this really the way to install Luci on a Belkin RT3200(Linksys EA8450) snapshot?
Are there any better alternatives? Did I make any mistakes? How to proceed further?
Thanks in advance for any help.

First I don't have a E8450. Second I know the initial openwrt install is difficult so anyone else seeing this should first ensure they are at the point they can safely use openwrt sysupgrade (or factory images). I've already seen one E8450 user who did not back up their mtd having issues returning to stock and I've read you can brick your device if you don't follow the initial install instructions carefully.

Consider imagebuilder if you are going to use snapshot builds.

You can create your own sysupgrade image that includes all the packages you want including luci (plus custom installation scripts) before you ever upload and flash the image. Takes minutes to build an image this way, dependencies are automagically taken care of. You likely will never have to bother with "updating" your install again. Just create a new image with imagebuilder and flash that.

It does take some effort to learn to use imagebuilder.



Try opkg instead.

Unknown package 'wget-ssl'.
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency libpcre for wget-ssl
 * pkg_hash_check_unresolved: cannot find dependency zlib for wget-ssl
 * pkg_hash_check_unresolved: cannot find dependency libopenssl1.1 for wget-ssl
 * pkg_hash_check_unresolved: cannot find dependency librt for wget-ssl
 * pkg_hash_fetch_best_installation_candidate: Packages for wget-ssl found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package wget-ssl.

Or even better if you are relatively new to openwrt, stick with a stable build if it exists.

Opkg is fine for a day with snapshot builds assuming you can connect and get it to work. The OP indicated they had trouble with that and from the cli, it's difficult to know what to do if you are new.

After a day or so, opkg may become difficult if a new snapshot is built. Then you have to start customizing opkg links or if you wait to long, start over with a new snapshot image.

This is a Belkin RT3200, there's no stable release, yet.

1 Like

So you need more pkgs, to fulfill the dependencies.

I know. The E8450 is tough and a new (to openwrt) user will have some challenges. Imagebuilder is not easy either (requires linux or a linux VM to use it - not sure if it can work easily under mac os).

Get a free Linux cloud host at Amazon, Google, Microsoft or Oracle, create your images there.

It'll be slow, but you wouldn't have to use your own hw, and mess with the os:es.

1 Like

I have a Linux machine at home. And I used to work with snapshots in the LEDE-age. However: never experienced these kind of issues with my R7800's or C2600.

The issue isn't the router, it's probably network related, or some new bug.

Connecting an ethernet cable to the WAN port, and one from a client, to a LAN port, should be enough to get things going.

Unless you WAN and LAN subnets are the same, that would seriously mess things up....

I started with the 0.6.2 sysupgrade which already has LuCi installed and working. Then you can configure the device for internet access from within LuCi and update to the latest snapshot and add software from there.

Are you able to try that?

Hey there.

I just went with this one, which already comes with LuCI:

After having installed what dangowrt provided, upgrading to latest snapshot via "Attended Sysupgrade" worked just fine. Which, if I'm not mistaken, updated LuCi to the most recent version as well.
I'm not sure if what you described is exactly that or something different. I just mention this to clarify: I did not get through wat you are experiencing because for me things just worked without problems.

So, if you already run OpenWRT but without LuCI, things might be a bit different.

You can of course set your network stuff via CLI, but if you're fairly new to OpenWRT, that could be bit much.

I suggest to

  1. reset the router to OpenWRT defaults (even if that might drop LuCI in your case),
  2. connect its WAN port to your local network
  3. and your computer to the RT3200s LAN port
  4. Act as if your regular network was the internet.
  5. You can now just install LuCI (opkg update ; opgk install luci) and adjiust networking and vlan from there via browser.

The thing is: If you do a reset of your OpenWRT and plug its WAN port into one of your regular routers LAN ports, the belkin should be able to talk to its update servers with no additional configuration. So updating it to latest snapshot should be absolutely painless. You might need to update your belkins LAN network to something other than (e.g. set it to to make it not conflict with your regular routers network range. That is, if your regular router uses the very same newtork range,

Once your belkin is set to latest snapshot, just start making it a dumb AP from there. I do know, it
s a little bit tricky to make a device a dumb AP on one hand and allow it to still connect to the internet on the other hand. I wouldn't call it complicated either, it*s just easy to miss a little detail.


Ah, just an idea towards your ssl verifaction error. I don't think you have a broken wget or ssl lib, and I don't think the update servers certificate is wrong. That's just extremely unlikely.
Can you check what your belkin thinks about the current date? uses a certificate which is issued with specific start and end date.
The current certificate is only valid between 2022-03-29 and 2022-06-27.
So if your belkin thinks the current date is (e.g.) 2020-01-01 it will refuse connecting to

1 Like

The installer image you flash is just to facilitate a sysupgrade to the latest snapshot. Make sure you're using the latest from djangowrt so your flash is set up properly. Then download the official snapshot to your PC and transfer it to the router and sysupgrade with the command line. All of this without the router connected to the Internet-- just have it connected to your PC. Once the new snapshot is booted then you can connect to the Internet and install Luci etc.


E8450/RT3200 will be included in 22.03 stable which isn't officially released yet, but you can find the 22.03 snapshot here for them (currently hidden from main page since it's not officially released), it has Luci and works well, I've been running it for a few days.

edit - if you decide to use the 22.03 snapshot, just make sure to install all your packages in the first 24 hours, the snapshot will rebuild and kernels won't match after that

1 Like

Thank you very much! Indeed: the date was lagging 45 hours behind. After setting date/time opkg update went flawless and luci installed (only 'properly pkg_hash_check_unresolved: cannot find dependency kernel' warning messages, most likely because the kernel on my router is slightly older than the one now required). Again, thank you!

1 Like


I got a Belkin RT3200 and I see there's two ways of running OpenWRT on it.- UBI and non-UBI.

If I follow dangowrt's steps and initially flash his openwrt-mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery-installer.itb firmware to make OpenWRT permanent, what would come next?

Can I just flash the OpenWRT 22.03-SNAPSHOT linksys_e8450-squashfs-sysupgrade.bin firmware? Or do I need to stick to itb-firmwares like 22.03-SNAPSHOT linksys_e8450-ubi-squashfs-sysupgrade.itb? In other words, once I decided to go the UBI way, do I need to use itb-firmwares from now on?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.