Installing LEDE/u-boot via brnboot web interface (without rs232)

Thank you. This also means my own spurious reboots at are unrelated to this.

@Limer I'm following your guide atm. Could you help me with step 2 and 3 (I'm new to those things)?

What exactly are you struggling with?

1 Like

I managed to get it done! Everything went fine so far. Now I'm struggling to install luci. O2 Box is connect via LAN4 to my current dsl router. My Mac has internet through LAN1 (connected to the O2 Box) but when I try to make any changes via opkg (like "update") it can't connect.

I got it working. In case someone is wondering...

@Limer sorry to bother you again, but is it save to update open wrt via luci-update interface?

I've not done/tried that yet, but it should work without any problems.
I'd be more sure if I actually knew how exactly LEDE/owrt updates itself but other ways of installing oWRT on this router produce the same result as my tutorial here and I've not seen any posts concerning update problems...

@Limer is there a way to revert back to stock?

Here a tiny "just get openwrt working" installation howto with luci preinstalled based on official image:

  1. Download
  2. Set your computer at
  3. When device off, press reset-button and while holding the reset-button power the router on. When the power-led is red (after about 5sec) you should be able to use your browser to enter and stop holding the reset-button.
  4. Choose the downloaded openwrt-firmware-file and leave the at "firmware".
  5. Install it and wait about 6 Minutes. At the end you would get some random charakters - thats fine. Just power it off and on.
  6. Done. Have fun with openwrt installed and usable.

Note: This does not free up all the internal possible ROM space. This does not matter for normale usage. If you like to install much additional software on the router for some reason, you can follow up the longer howto in this thread.

yes - that is the same as the first set of substeps (1.1 to 1.6) in my howto with a different image....

But I'd like to know how/where the 18.06-SNAPSHOT is documented (how you found it) and why LuCi is integrated? I Thought snapshot builds where LuCi-less.

@Manuuuel86 philosophically speaking there is just no way to turn back time to "un-invent" something but I'd guess if you have a full backup or manage to create a full image with the original firmware it should be possible (to overwrite the whole flash from within u-boot).

But why in sciences name and its holy Noodliness would you even want to revert back to the stock cripplecrapware?


You guys are doing good job. Well done!

I have Speedport W 723V Typ B, want to run OpenWRT on it. But there are no ready images for this router.
Can I use another u-boot files from similar router ? If I successful on u-boot, is it possible to boot from TFTP without installing on flash? Could someone tell me the way to port, as summary of course?

Thank you in advance.

No, it really must match your hardware exactly.

Did you ever find out what caused the ethernet ports to go off? I'm still seeing the same problem, and it's always two ports which fail at the same time. Rebooting once doesn't fix it, I have to reboot twice or perform a power cycle.

Have you guys tested this device with 18.06.1 build? Maybe the problem with the ethernet ports is already fixed...

I haven't tested anything on/with those routers ~since posting my step-by-step instructions here.
drvcucwk has tested the 18.06-SNAPSHOT build successfully so I guess 18.06.1 should work fine.

No, but I didn't even try the newer releases. Did you?

1 Like

I didn't yet install a new u-boot, and I'd rather update both u-boot and OpenWrt before coming to conclusions. Installing OpenWrt 18.06.1 worked fine, though.
The ethernet hangs happen only rarely, sometimes it takes more than two weeks to trigger it. I'll report back once two weeks with new u-boot and new OpenWrt have elapsed.

I'm pretty sure you don't need to reinstall u-boot.
I didn't take a look at the changelog of 18.06.* but u-boot usually does not need to be updated (unless explicitly stated otherwise).

Well, I saw a changelog entry which mentioned that U-Boot was patched to fix ethernet PHY initialization, so I'd rather make sure this change is present before I declare any test to be complete.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.