Installing LEDE (OpenWrt) on UAP LR v2

It's been already 6 month since I am trying to find out a solution of flashing UAP LR v2 with LEDE (OpenWrt).
Is there any way to bypass on original firmware verification which they've added in new 3.7.* versions.

Every time I am getting following error: Invalid version...

If someone found a way, please let me know!

There are also many similar issues on this forum with the same question:



Some people advice to downgrade to older firmware, but the problem is that now it is not possible.
First of all they removed all old firmware from the website and second even if you find one somewhere in Internet and upload on UAP LR, it will simply stop working.

See this github thread...

https://github.com/openwrt/openwrt/issues/423

Hi Jim,

Thanks for your reply. Unfortunately this thread is not new for me, I've tried to downgrade the firmware, however if you put any firmware below version < 3.7.* device simply stop working. In order to return in back to life i have to use TFTP mode and install again 3.7.* version and device start working again.

What happens when you use TFTP to flash LEDE?

Have you tried to re-name the LEDE firmware file name to the Ubiquiti firmware file name you use to install 3.7.* with TFTP?

I didn't but I believe it will not help. Because as far as I know, they added a signature check inside the firmware file.

https://pwassi.privatedns.org/openwrt/unifiac/