Installing LEDE on TP-Link wr1043nd v1.11


Yesterday I thought I would quickly flash LEDE on my old wr1043nd so that I have it as a backup. I did it from the web GUI, selected the image for v1, pressed upgrade and was greeted upon reboot with the standard DD-WRT interface. Now, this confused me a bit because I was convinced I flashed LEDE. I then flashed the image again and again got the DD-WRT interface.

Did anyone experience something similar and can tell me what I am doing wrong? If possible, I don't want to open it and connect to the serial port.

Which LEDE firmware image did you download from where?

The stable one directly from the LEDE download page: lede-17.01.0-r3205-59508e3-ar71xx-generic-tl-wr1043nd-v1-squashfs-factory.bin

This was the first time that simply nothing happened when I installed an image.

Did you have DD-WRT on it before? Maybe it's DD-WRT refusing to flash LEDE image.

Or maybe it's your browser cached the DD-WRT admin page and showing it to you from cache. Try accessing your router in the incognito window and/or different browser.

It's certainly not cached. I tested it on another computer, DD-WRT is still on there.

It came with DD-WRT when I bought it. But when I look at the date of the firmware version on it and the latest firmware version of that router on the TP-Link website, it looks like the one on it is newer... I have no clue where that firmware did come from. But I also don't understand why I can not flash LEDE.

I did the trick with a recover to stock image and then flash lede today ... further you should try to make the name of the image easy ... like update.bin.
And you could try to flash it via sysupgrade at cli ?

simply go to /tmp/ and "wget" and "sysupgrade lede-17.01.0-r3205-59508e3-ar71xx-generic-tl-wr1043nd-v1-squashfs-factory.bin"

That works from DD-WRT? I will try it out. I just tried to flash the stock image. I don't think it worked.

Edit: There might be a small issue as even after enabling ssh, the connection is refused. And for telnet, my login data is not working. It's getting interesting.

Remember to take a cutted image without bootloader or you will brick your device !
Best is here:

Well, then it certainly didn't work, because it's not bricked. :slight_smile: But it's weird that I can not ssh or telnet into it... Maybe I can try the stripped image.

Aaaaaaaaaaaaaaand its gone ? :slight_smile:

Nope, it just didn't flash it. :slight_smile:

But now I could connect with ssh, but I can not download anything. Wget simply returns and that's it.

Chack space with df -h !

Nothing available. But even in /tmp there is nothing available at all. This does explain why the upgrade doesn't work. The image is not even uploaded. But that makes it hard to flash anything.

try "firstboot" or per interface reset to default before you try firmware update to get the installation clean

I did that in the interface and it didn't help. The command "firstboot" on the other hand is not found...

What about "erase nvram" via telnet or ssh ?

Let's see, it did a reset. Now I will try to flash it with LEDE from the GUI, but I don't have high hopes.

Edit: Didn't work. I'm wondering if the only option is tftp or serial... It's a bit annoying.

Maybe it would be more productive to seek help on DD-WRT forum, after all, it's DD-WRT which is at fault.