Installing LEDE on a Tenda AC9


I have a Tenda AC9, which is supported by LEDE, well, at least there is a install .trx file on the download repository... but there is no information of how to install it at all. No wiki, no support pages, nothing. The .trx is not accepted by the upgrade page of the factory firmware.

Does anyone know how to install it?

Thanks in advance,


I can't help with the installation, but want to mention that I just created a dataentry for the Tenda AC9 to show up in the Table of Hardware:

However, there are still some open fields like CPU, Flash, RAM, Switch, WLAN hardware.
Would be great if somebody knowledgeable could fill in the missing data.



Well, I got good news and bad news.

Good news: I've found out how to install the .trx image: just configure your computer to a fixed IP address in the 192.168.1.x range (x between 2 and 255), reset the router while keeping pressed the reset switch on the back for 20 seconds, and access the CFE mini web server at There you can upload the LEDE .trx image. :grinning:

Bad news: LEDE only supports the 2.4 GHz Wi-Fi, and only in B/G mode, not even N. So, it sends your router back to 2005 :weary:

So... you can revert to the factory firmware on the CFE mini web server. :sob:

1 Like

this product for free in China :slight_smile: ,

SOC:BCM47189 ARM Certox A7 900MHz
RAM:DDR3 128MB(W631GG6KB-15)
Flash:8MB SPI
WAN:BCM 53125

Dear hernan,
I pressed the reset switch to activate CPE mini web server, but I still can't upload the firmware because the CPE web server finish his role and after 10-15 seconds the router complete the boot with factory firmware. How I can stop the process to CPE mini web server?

1 Like

Hello, I first thank the work to the DEV, the project is still ongoing ?. I just did with an AC9. A greeting.

Here is source codes for same hardware. ( Not tried to compile )

I am having trouble flashing my Tenda AC9. I can get to the CFE mini server, but it seems like it's on some kind of very short timeout. I can get it to load, but if I refresh it a second later it won't connect and the device will continue its normal boot sequence. There's just enough time to execute an NVRAM erase or reboot command, but there doesn't seem to be time to do a firmware upload. Even if I have the form ready to go and hit "uplaod" immediately, it just sits for a few seconds then tells me "f2.htm" can't load, and boots normally.

I've done the 30-30-30 reset about 30 times, and can't manage to get anything else out of it. Can anyone help?

1 Like

I tried LEDE-17.01.1, 5G wifi is not supported ,will it fixed later?

Has anyone tried to install the 18.0.6 release on Tenda AC9? Are the Wi-Fi issues still present?

created account just to post -
re: ramenandvitamins - hurry to that page and pres reset nvram i was in the same position but once i did that router booted into openwrt OK.

re ppaladin01 - yes. still no 5G. going to try to fix myself. (still no 5G on 18.06.1)

Tenda released the GPL code: (From Tenda GPL center page)
Does it help?

@baranyaib90 @adonaros Sorry for the necro bump.
I saw that there was an update on July 19
Or, are 5Ghz issues still present with openwrt 18.06.4?

I dont mind the "necro bump" i really wish openwrt was working on this thing. (or i wish i knew enough to roll my own with the closed drivers so life could move on)

No.. it doesnt work. I was even unsucessful at booting it. I did flash it, but it would only boot for a little, crash, and restart.

1 Like

From :

Will this status change over time? If yes, in what timeframe?
Nobody knows. It all depends on the availability of FOSS drivers. Expect timeframes of multiple months up to multiple years, or even never.

What can you do now?
Easy / Short term: Get a device with different wifi chip / SoC which is fully supported by OpenWrt

From :

With that in mind (no or only limited open source support of Broadcom devices), it's up to you whether to buy Broadcom devices or not.

@tmomas @adonaros
Thanks! That saves a ton of (potential) trouble.
I was hoping that the latest update might have solved the issue, and that noone reported it. Oh well, I'll be more careful selecting a router next time. I've been through 10+ routers over the past decade, but I've miraculously selected an openwrt-unsupported device each time, lol.

I know. It would have been a great router for this, too bad we're smoking the super FOSS.

I have been using the cudy wr1000 or whatever they are. 5G works "ok" price point is great.

and i hate this quote

With that in mind (no or only limited open source support of Broadcom devices), it's up to you whether to buy Broadcom devices or not.
-- yes its up to me because openwrt doesnt want to use a binary blob.

1 Like

Sorry, I did not had luck with AC9 so I have sold it.
I have changed to TP-Link C5 V4 because it's cheap and 5GHz is working.

1 Like